aboutsummaryrefslogtreecommitdiff
path: root/devel/stlport
diff options
context:
space:
mode:
authorPete Fritchman <petef@FreeBSD.org>2001-12-24 22:17:44 +0000
committerPete Fritchman <petef@FreeBSD.org>2001-12-24 22:17:44 +0000
commit54728e6a3801dcb3f0679b22d478b2809f2883a6 (patch)
tree4e2bb716a79e70d4cc5cc83ce17b706cb8ff58d7 /devel/stlport
parentf5962ab9e4525deeae4a6005a9aae9aab7389c67 (diff)
downloadports-54728e6a3801dcb3f0679b22d478b2809f2883a6.tar.gz
ports-54728e6a3801dcb3f0679b22d478b2809f2883a6.zip
Notes
Diffstat (limited to 'devel/stlport')
-rw-r--r--devel/stlport/Makefile9
-rw-r--r--devel/stlport/distinfo2
-rw-r--r--devel/stlport/files/patch-common_macros.mak10
-rw-r--r--devel/stlport/files/patch-common_rules.mak45
-rw-r--r--devel/stlport/files/patch-export163
-rw-r--r--devel/stlport/files/patch-mkinstalldirs11
-rw-r--r--devel/stlport/pkg-plist1
7 files changed, 11 insertions, 230 deletions
diff --git a/devel/stlport/Makefile b/devel/stlport/Makefile
index 9db1c1a74b56..59cbc3f60cb9 100644
--- a/devel/stlport/Makefile
+++ b/devel/stlport/Makefile
@@ -7,10 +7,9 @@
#
PORTNAME= stlport
-PORTVERSION= 4.5
+PORTVERSION= 4.5.1
CATEGORIES= devel
-MASTER_SITES= http://www.stlport.com/archive/ \
- http://www.stlport.com/beta/
+MASTER_SITES= http://www.stlport.com/archive/
DISTNAME= STLport-${PORTVERSION:S/.b/-b/}
MAINTAINER= pmarquis@pobox.com
@@ -18,7 +17,7 @@ MAINTAINER= pmarquis@pobox.com
.include <bsd.port.pre.mk>
.if !exists(/usr/include/wchar.h)
-BROKEN= "requires /usr/include/wchar.h for compilation"
+BROKEN= "Requires /usr/include/wchar.h for compilation"
.endif
WRKSRC= ${WRKDIR}/STLport-${PORTVERSION:S/.b/b/}/src
@@ -28,7 +27,7 @@ MAKEFILE= gcc-freebsd.mak
MAKE_ARGS= INSTALLDIR=${PREFIX}
ALL_TARGET= clean all
INSTALL_TARGET= install_unix
-INSTALLS_SHLIB= ye
+INSTALLS_SHLIB= yes
.if ${OSVERSION} < 440000
BROKEN= "Not supported on systems prior to FreeBSD 4.4"
diff --git a/devel/stlport/distinfo b/devel/stlport/distinfo
index cf080a0cdb59..0d79dbba38b4 100644
--- a/devel/stlport/distinfo
+++ b/devel/stlport/distinfo
@@ -1 +1 @@
-MD5 (STLport-4.5.tar.gz) = 18f577b374d60b3c760a3a3350407632
+MD5 (STLport-4.5.1.tar.gz) = 7b81d27afc0928a3f604f458bb7d6948
diff --git a/devel/stlport/files/patch-common_macros.mak b/devel/stlport/files/patch-common_macros.mak
index 5ff5c7376e02..33f1f72eb2e7 100644
--- a/devel/stlport/files/patch-common_macros.mak
+++ b/devel/stlport/files/patch-common_macros.mak
@@ -1,11 +1,11 @@
---- src/common_macros.mak.orig Sat Jul 28 23:44:30 2001
-+++ src/common_macros.mak Fri Oct 5 09:05:56 2001
-@@ -14,7 +14,7 @@
+--- src/common_macros.mak.orig Thu Nov 15 17:08:56 2001
++++ src/common_macros.mak Mon Dec 24 10:37:02 2001
+@@ -10,7 +10,7 @@
# We do not assume any binary compatibility for betas.
BETA_SUFFIX=
-VERSION_SUFFIX= .$(VERSION_MAJOR).$(VERSION_MINOR)$(BETA_SUFFIX)
+VERSION_SUFFIX= _$(VERSION_MAJOR)_$(VERSION_MINOR)$(BETA_SUFFIX)
+ WIN_VERSION_SUFFIX= $(VERSION_MAJOR)$(VERSION_MINOR)$(BETA_SUFFIX)
- DYNAMIC_SUFFIX= $(VERSION_SUFFIX)$(PATCH_SUFFIX)
-
+ # DYNAMIC_SUFFIX= $(VERSION_SUFFIX)$(PATCH_SUFFIX)
diff --git a/devel/stlport/files/patch-common_rules.mak b/devel/stlport/files/patch-common_rules.mak
deleted file mode 100644
index 874a34681834..000000000000
--- a/devel/stlport/files/patch-common_rules.mak
+++ /dev/null
@@ -1,45 +0,0 @@
---- src/common_rules.mak.orig Thu May 31 20:43:14 2001
-+++ src/common_rules.mak Fri Oct 5 00:29:33 2001
-@@ -86,8 +86,8 @@
- ln -s $(STLDEBUG_DYNLIB) $(OUTDIR)/$(STLDEBUG_NAME).$(DYNEXT)
-
- install_unix :
-- -$(RM) $(INSTALLDIR_INC)
-- for dir in $(HEADER_DIRS1); \
-+ @-$(RM) $(INSTALLDIR_INC)
-+ @for dir in $(HEADER_DIRS1); \
- do \
- ./mkinstalldirs $(INSTALLDIR_INC)/$$dir; \
- for file in `cat ../stlport/$$dir/export`; \
-@@ -95,7 +95,7 @@
- $(INSTALL_H) ../stlport/$$dir/$$file $(INSTALLDIR_INC)/$$dir ; \
- done \
- done
-- for dir in $(HEADER_DIRS2); \
-+ @for dir in $(HEADER_DIRS2); \
- do \
- ./mkinstalldirs $(INSTALLDIR_INC)/$$dir; \
- for file in `ls ../stlport/$$dir/*.*`; \
-@@ -103,16 +103,16 @@
- $(INSTALL_H) $$file $(INSTALLDIR_INC)/$$dir ; \
- done \
- done
-- ./mkinstalldirs $(INSTALLDIR_LIB)
-- for file in `ls $(OUTDIR)/$(LIB_BASENAME)*`; \
-+ @./mkinstalldirs $(INSTALLDIR_LIB)
-+ @for file in `ls $(OUTDIR)/$(LIB_BASENAME)*`; \
- do \
- $(RM) $(INSTALLDIR_LIB)/$$file; \
- $(INSTALL_LIB) $$file $(INSTALLDIR_LIB); \
- done
-- $(RM) $(INSTALLDIR_LIB)/$(RELEASE_NAME).$(DYNEXT)
-- $(RM) $(INSTALLDIR_LIB)/$(STLDEBUG_NAME).$(DYNEXT)
-- ln -s $(INSTALLDIR_LIB)/$(RELEASE_DYNLIB) $(INSTALLDIR_LIB)/$(RELEASE_NAME).$(DYNEXT)
-- ln -s $(INSTALLDIR_LIB)/$(STLDEBUG_DYNLIB) $(INSTALLDIR_LIB)/$(STLDEBUG_NAME).$(DYNEXT)
-+ @$(RM) $(INSTALLDIR_LIB)/$(RELEASE_NAME).$(DYNEXT)
-+ @$(RM) $(INSTALLDIR_LIB)/$(STLDEBUG_NAME).$(DYNEXT)
-+ @ln -s $(INSTALLDIR_LIB)/$(RELEASE_DYNLIB) $(INSTALLDIR_LIB)/$(RELEASE_NAME).$(DYNEXT)
-+ @ln -s $(INSTALLDIR_LIB)/$(STLDEBUG_DYNLIB) $(INSTALLDIR_LIB)/$(STLDEBUG_NAME).$(DYNEXT)
-
- $(OUTDIR)$(PATH_SEP)$(RELEASE_DYNLIB) : $(OUTDIR) $(RELEASE_OBJDIR_dynamic) $(DEF_FILE) $(RELEASE_OBJECTS_dynamic)
- $(DYN_LINK) $(DYNLINK_OUT)$(OUTDIR)$(PATH_SEP)$(RELEASE_DYNLIB) $(LDFLAGS_RELEASE_dynamic) $(RELEASE_OBJECTS_dynamic) $(LDLIBS_RELEASE_dynamic)
diff --git a/devel/stlport/files/patch-export b/devel/stlport/files/patch-export
deleted file mode 100644
index 2305985fba60..000000000000
--- a/devel/stlport/files/patch-export
+++ /dev/null
@@ -1,163 +0,0 @@
---- stlport/export.orig Mon May 7 22:49:32 2001
-+++ stlport/export Sun Sep 30 22:07:42 2001
-@@ -1,160 +1,85 @@
- ./algorithm
--./algorithm.SUNWCCh
- ./bitset
--./bitset.SUNWCCh
- ./cassert
--./cassert.SUNWCCh
- ./cctype
--./cctype.SUNWCCh
- ./cerrno
--./cerrno.SUNWCCh
- ./cfloat
--./cfloat.SUNWCCh
- ./climits
--./climits.SUNWCCh
- ./clocale
--./clocale.SUNWCCh
- ./cmath
--./cmath.SUNWCCh
- ./complex
--./complex.SUNWCCh
- ./csetjmp
--./csetjmp.SUNWCCh
- ./csignal
--./csignal.SUNWCCh
- ./cstdarg
--./cstdarg.SUNWCCh
- ./cstddef
--./cstddef.SUNWCCh
- ./cstdio
--./cstdio.SUNWCCh
- ./cstdlib
--./cstdlib.SUNWCCh
- ./cstring
--./cstring.SUNWCCh
- ./ctime
--./ctime.SUNWCCh
- ./ctype.h
--./ctype.h.SUNWCCh
- ./cwchar
--./cwchar.SUNWCCh
- ./cwctype
--./cwctype.SUNWCCh
- ./deque
--./deque.SUNWCCh
- ./exception
--./exception.SUNWCCh
- ./exception.h
- ./export
- ./fstream
--./fstream.SUNWCCh
- ./fstream.h
--./fstream.h.SUNWCCh
- ./functional
--./functional.SUNWCCh
- ./hash_map
--./hash_map.SUNWCCh
- ./hash_set
--./hash_set.SUNWCCh
- ./iomanip
--./iomanip.SUNWCCh
- ./iomanip.h
--./iomanip.h.SUNWCCh
- ./ios
--./ios.SUNWCCh
- ./ios.h
--./ios.h.SUNWCCh
- ./iosfwd
--./iosfwd.SUNWCCh
- ./iostream
--./iostream.SUNWCCh
- ./iostream.h
--./iostream.h.SUNWCCh
- ./istream
--./istream.SUNWCCh
- ./istream.h
--./istream.h.SUNWCCh
- ./iterator
--./iterator.SUNWCCh
- ./limits
--./limits.SUNWCCh
- ./list
--./list.SUNWCCh
- ./locale
--./locale.SUNWCCh
- ./locale.h
--./locale.h.SUNWCCh
- ./map
--./map.SUNWCCh
- ./math.h
--./math.h.SUNWCCh
- ./mem.h
- ./memory
--./memory.SUNWCCh
- ./mmemory.h
- ./new
--./new.SUNWCCh
- ./new.h
- ./numeric
--./numeric.SUNWCCh
- ./ostream
--./ostream.SUNWCCh
- ./ostream.h
--./ostream.h.SUNWCCh
- ./pthread.h
- ./pthread_alloc
--./pthread_alloc.SUNWCCh
- ./queue
--./queue.SUNWCCh
- ./rope
- ./set
--./set.SUNWCCh
- ./setjmp.h
--./setjmp.h.SUNWCCh
- ./signal.h
--./signal.h.SUNWCCh
- ./slist
--./slist.SUNWCCh
- ./sstream
--./sstream.SUNWCCh
- ./stack
--./stack.SUNWCCh
- ./stdarg.h
--./stdarg.h.SUNWCCh
- ./stddef.h
--./stddef.h.SUNWCCh
- ./stdexcept
--./stdexcept.SUNWCCh
- ./stdio.h
--./stdio.h.SUNWCCh
- ./stdio_streambuf
- ./stdlib.h
--./stdlib.h.SUNWCCh
- ./stl_user_config.h
- ./streambuf
--./streambuf.SUNWCCh
- ./streambuf.h
--./streambuf.h.SUNWCCh
- ./string
--./string.SUNWCCh
- ./string.h
--./string.h.SUNWCCh
- ./strstream
--./strstream.SUNWCCh
- ./strstream.h
--./strstream.h.SUNWCCh
- ./time.h
--./time.h.SUNWCCh
- ./typeinfo
--./typeinfo.SUNWCCh
- ./typeinfo.h
- ./utility
--./utility.SUNWCCh
- ./valarray
--./valarray.SUNWCCh
- ./vector
--./vector.SUNWCCh
- ./wchar.h
--./wchar.h.SUNWCCh
- ./wctype.h
--./wctype.h.SUNWCCh
diff --git a/devel/stlport/files/patch-mkinstalldirs b/devel/stlport/files/patch-mkinstalldirs
deleted file mode 100644
index 61a7fb9bcd2f..000000000000
--- a/devel/stlport/files/patch-mkinstalldirs
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/mkinstalldirs.orig Thu Dec 7 19:54:47 2000
-+++ src/mkinstalldirs Fri Oct 5 01:03:31 2001
-@@ -19,7 +19,7 @@
- esac
-
- if test ! -d "$pathcomp"; then
-- echo "mkdir $pathcomp" 1>&2
-+# echo "mkdir $pathcomp" 1>&2
- mkdir "$pathcomp" || errstatus=$?
- fi
-
diff --git a/devel/stlport/pkg-plist b/devel/stlport/pkg-plist
index b49eaa383727..fa3696cd2726 100644
--- a/devel/stlport/pkg-plist
+++ b/devel/stlport/pkg-plist
@@ -133,6 +133,7 @@ include/stlport/stl/_algobase.c
include/stlport/stl/_algobase.h
include/stlport/stl/_alloc.c
include/stlport/stl/_alloc.h
+include/stlport/stl/_alloc_old.h
include/stlport/stl/_auto_ptr.h
include/stlport/stl/_bitset.c
include/stlport/stl/_bitset.h