aboutsummaryrefslogtreecommitdiff
path: root/devel/stlport
diff options
context:
space:
mode:
authorPhilip M. Gollucci <pgollucci@FreeBSD.org>2008-07-31 18:34:24 +0000
committerPhilip M. Gollucci <pgollucci@FreeBSD.org>2008-07-31 18:34:24 +0000
commit8bb6dc91efebbf095ca0dffbd4e124b33e19c697 (patch)
treee0c73b698eeb18d3785c41505a656ce4ef1241a0 /devel/stlport
parente51525b4948bc2e807ec1fe41f327e75e353dbf2 (diff)
downloadports-8bb6dc91efebbf095ca0dffbd4e124b33e19c697.tar.gz
ports-8bb6dc91efebbf095ca0dffbd4e124b33e19c697.zip
Notes
Diffstat (limited to 'devel/stlport')
-rw-r--r--devel/stlport/Makefile11
-rw-r--r--devel/stlport/files/extra-patch-boost-support-user_config.h.diff14
2 files changed, 24 insertions, 1 deletions
diff --git a/devel/stlport/Makefile b/devel/stlport/Makefile
index ceeddc8bd16e..91bb07670325 100644
--- a/devel/stlport/Makefile
+++ b/devel/stlport/Makefile
@@ -8,6 +8,7 @@
PORTNAME= stlport
PORTVERSION= 5.1.5
+PORTREVISION= 1
CATEGORIES= devel
MASTER_SITES= SF
PKGNAMESUFFIX= -${COMPILER}
@@ -36,7 +37,8 @@ PORTDOCS= *
OPTIONS= SHORT_STRING_OPTIM "Enable short string optimization." on \
PTR_SPECIALIZATIONS "Use pointer types specializations." off \
- TEMPLATE_EXPRESSION "Use template expressions for string." off
+ TEMPLATE_EXPRESSION "Use template expressions for string." off \
+ BOOST_SUPPORT "Use Boost type traits." off
.include <bsd.port.pre.mk>
@@ -52,6 +54,13 @@ EXTRA_PATCHES+= ${PATCHDIR}/extra-patch-ptr_spec-user_config.h.diff
EXTRA_PATCHES+= ${PATCHDIR}/extra-patch-templ-expr-user_config.h.diff
.endif
+.if defined(WITH_BOOST_SUPPORT)
+EXTRA_PATCHES+= ${PATCHDIR}/extra-patch-boost-support-user_config.h.diff
+MAKE_ENV+= STLP_BUILD_BOOST_PATH=${LOCALBASE}/include
+BUILD_DEPENDS+= ${LOCALBASE}/include/boost/config/stdlib/stlport.hpp:${PORTSDIR}/devel/boost
+RUN_DEPENDS+= ${LOCALBASE}/include/boost/config/stdlib/stlport.hpp:${PORTSDIR}/devel/boost
+.endif
+
pre-configure:
${REINPLACE_CMD} -e 's|gcc|${COMPILER}|' ${WRKSRC}/gcc.mak \
${WRKSRC}/../test/unit/gcc.mak
diff --git a/devel/stlport/files/extra-patch-boost-support-user_config.h.diff b/devel/stlport/files/extra-patch-boost-support-user_config.h.diff
new file mode 100644
index 000000000000..04ab4a780ffe
--- /dev/null
+++ b/devel/stlport/files/extra-patch-boost-support-user_config.h.diff
@@ -0,0 +1,14 @@
+--- stlport/stl/config/user_config.h 2008-07-30 22:57:38.719239317 +0200
++++ stlport/stl/config/user_config.h 2008-07-30 22:58:06.413639084 +0200
+@@ -298,9 +298,9 @@
+ * to use this feature at STLport built time you will have to define the
+ * STLP_BUILD_BOOST_PATH enrironment variable with the value of the boost library path.
+ */
+-/*
++
+ #define _STLP_USE_BOOST_SUPPORT 1
+-*/
++
+
+ /*==========================================================*/
+