aboutsummaryrefslogtreecommitdiff
path: root/devel/strace/Makefile
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2004-01-04 19:37:55 +0000
committerPav Lucistnik <pav@FreeBSD.org>2004-01-04 19:37:55 +0000
commit427422fb2187c264e191e896e8d09886e12b16b8 (patch)
tree871adb378828bcfb548b5c53a1f13dc013aad7af /devel/strace/Makefile
parent8d7399db8079de323d6c543b36936663d54e63a6 (diff)
Notes
Diffstat (limited to 'devel/strace/Makefile')
-rw-r--r--devel/strace/Makefile22
1 files changed, 19 insertions, 3 deletions
diff --git a/devel/strace/Makefile b/devel/strace/Makefile
index 740d542b5ff3..3f6cca2dd323 100644
--- a/devel/strace/Makefile
+++ b/devel/strace/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= strace
-PORTVERSION= 4.4.94
+PORTVERSION= 4.5.1
CATEGORIES= devel sysutils
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -15,16 +15,32 @@ MAINTAINER= alex@rinet.ru
COMMENT= A portable process tracer
USE_BZIP2= yes
+USE_PERL5= yes # for strace-graph
+USE_REINPLACE= yes
GNU_CONFIGURE= yes
ONLY_FOR_ARCHS= i386
MAN1= strace.1
+.if !defined(NOPORTDOCS)
+PORTDOCS= *
+.endif
+
+post-patch:
+ ${REINPLACE_CMD} 's,/usr/bin/perl,${PERL},' ${WRKSRC}/strace-graph
+
do-install:
- -${MKDIR} ${PREFIX}/bin
+ ${MKDIR} ${PREFIX}/bin
${INSTALL_PROGRAM} ${WRKSRC}/strace ${PREFIX}/bin
${INSTALL_SCRIPT} ${WRKSRC}/strace-graph ${PREFIX}/bin
- -${MKDIR} ${PREFIX}/man/man1
+ ${MKDIR} ${PREFIX}/man/man1
${INSTALL_MAN} ${WRKSRC}/strace.1 ${PREFIX}/man/man1
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+.for i in AUTHORS COPYRIGHT CREDITS ChangeLog NEWS PORTING \
+ README README-freebsd README-svr4 TODO
+ ${INSTALL_DATA} ${WRKSRC}/${i} ${DOCSDIR}
+.endfor
+.endif
.include <bsd.port.mk>