aboutsummaryrefslogtreecommitdiff
path: root/devel/strace
diff options
context:
space:
mode:
authorPhilip M. Gollucci <pgollucci@FreeBSD.org>2008-12-25 14:44:06 +0000
committerPhilip M. Gollucci <pgollucci@FreeBSD.org>2008-12-25 14:44:06 +0000
commit2cc66472a430b53eaf38eb0fb69a5862d9f82c7c (patch)
tree9b340cbe035e08986b2fd78b218b726b4a163151 /devel/strace
parenta15ec654cf7a179ccedc496354868e1f37b10da8 (diff)
downloadports-2cc66472a430b53eaf38eb0fb69a5862d9f82c7c.tar.gz
ports-2cc66472a430b53eaf38eb0fb69a5862d9f82c7c.zip
Notes
Diffstat (limited to 'devel/strace')
-rw-r--r--devel/strace/Makefile18
-rw-r--r--devel/strace/distinfo6
-rw-r--r--devel/strace/files/patch-file.c40
-rw-r--r--devel/strace/files/patch-sock.c37
-rw-r--r--devel/strace/files/patch-strace.c42
5 files changed, 101 insertions, 42 deletions
diff --git a/devel/strace/Makefile b/devel/strace/Makefile
index de4e74523cb6..b81d4603b371 100644
--- a/devel/strace/Makefile
+++ b/devel/strace/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= strace
-PORTVERSION= 4.5.7
+PORTVERSION= 4.5.18
CATEGORIES= devel sysutils
MASTER_SITES= SF
@@ -23,24 +23,22 @@ PLIST_FILES= bin/strace bin/strace-graph
MAN1= strace.1
.if !defined(NOPORTDOCS)
-PORTDOCS= *
+PORTDOCS= AUTHORS COPYRIGHT CREDITS ChangeLog NEWS PORTING \
+ README README-freebsd README-svr4 TODO
.endif
post-patch:
${REINPLACE_CMD} 's,/usr/bin/perl,${PERL},' ${WRKSRC}/strace-graph
do-install:
- ${MKDIR} ${PREFIX}/bin
+ @${MKDIR} ${PREFIX}/bin
${INSTALL_PROGRAM} ${WRKSRC}/strace ${PREFIX}/bin
${INSTALL_SCRIPT} ${WRKSRC}/strace-graph ${PREFIX}/bin
- ${MKDIR} ${PREFIX}/man/man1
- ${INSTALL_MAN} ${WRKSRC}/strace.1 ${PREFIX}/man/man1
+ @${MKDIR} ${MANPREFIX}/man/man1
+ ${INSTALL_MAN} ${WRKSRC}/strace.1 ${MANPREFIX}/man/man1
.if !defined(NOPORTDOCS)
- ${MKDIR} ${DOCSDIR}
-.for i in AUTHORS COPYRIGHT CREDITS ChangeLog NEWS PORTING \
- README README-freebsd README-svr4 TODO
- ${INSTALL_DATA} ${WRKSRC}/${i} ${DOCSDIR}
-.endfor
+ @${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${PORTDOCS:S,^,${WRKSRC}/,} ${DOCSDIR}
.endif
.include <bsd.port.mk>
diff --git a/devel/strace/distinfo b/devel/strace/distinfo
index 75abaa875d4c..a01e58acdcdc 100644
--- a/devel/strace/distinfo
+++ b/devel/strace/distinfo
@@ -1,3 +1,3 @@
-MD5 (strace-4.5.7.tar.bz2) = b1829d858b6cd7072f9b2fa9c17a2346
-SHA256 (strace-4.5.7.tar.bz2) = 4545d7118869c143d9875dfc8414eb6eb2176c35ec5d7f1e327372bd40a6ef1e
-SIZE (strace-4.5.7.tar.bz2) = 414738
+MD5 (strace-4.5.18.tar.bz2) = e9449fcee97e6a8ed73934c883c870e0
+SHA256 (strace-4.5.18.tar.bz2) = 95e7b7470e04f22c3ec8dc6d0b1fdd8944306cb5313c84c4545cd83abada26d0
+SIZE (strace-4.5.18.tar.bz2) = 480973
diff --git a/devel/strace/files/patch-file.c b/devel/strace/files/patch-file.c
index fa363c4e967a..4cb45cf6bb5d 100644
--- a/devel/strace/files/patch-file.c
+++ b/devel/strace/files/patch-file.c
@@ -1,6 +1,6 @@
---- file.c.orig Thu Nov 13 23:32:27 2003
-+++ file.c Fri Jan 2 19:11:23 2004
-@@ -1387,7 +1387,7 @@
+--- file.c.orig 2008-08-01 09:13:10.000000000 +0800
++++ file.c 2008-11-21 00:16:35.000000000 +0800
+@@ -1656,7 +1656,7 @@
statbuf.f_bsize, statbuf.f_blocks, statbuf.f_bfree);
tprintf("f_bavail=%u, f_files=%u, f_ffree=%u, f_fsid={%d, %d}, f_namelen=%u",
statbuf.f_bavail,statbuf.f_files, statbuf.f_ffree,
@@ -9,7 +9,7 @@
statbuf.f_namelen);
#else /* !ALPHA */
tprintf("{f_type=%s, f_bsize=%lu, f_blocks=%lu, f_bfree=%lu, ",
-@@ -1399,7 +1399,7 @@
+@@ -1668,7 +1668,7 @@
(unsigned long)statbuf.f_bavail,
(unsigned long)statbuf.f_files,
(unsigned long)statbuf.f_ffree,
@@ -18,3 +18,35 @@
#ifdef LINUX
tprintf(", f_namelen=%lu", (unsigned long)statbuf.f_namelen);
#endif /* LINUX */
+@@ -2856,6 +2856,7 @@
+ }
+
+
++#ifdef LINUX
+ static const struct xlat advise[] = {
+ { POSIX_FADV_NORMAL, "POSIX_FADV_NORMAL" },
+ { POSIX_FADV_RANDOM, "POSIX_FADV_RANDOM" },
+@@ -2865,6 +2866,7 @@
+ { POSIX_FADV_NOREUSE, "POSIX_FADV_NOREUSE" },
+ { 0, NULL }
+ };
++#endif
+
+
+ #ifdef LINUX
+@@ -2888,6 +2890,7 @@
+ #endif
+
+
++#ifdef LINUX
+ int
+ sys_fadvise64_64(tcp)
+ struct tcb *tcp;
+@@ -2909,6 +2912,7 @@
+ }
+ return 0;
+ }
++#endif
+
+ #ifdef LINUX
+ static const struct xlat inotify_modes[] = {
diff --git a/devel/strace/files/patch-sock.c b/devel/strace/files/patch-sock.c
index 9055542ff608..79623f0d031c 100644
--- a/devel/strace/files/patch-sock.c
+++ b/devel/strace/files/patch-sock.c
@@ -1,10 +1,39 @@
---- sock.c.orig 2007-12-20 16:31:01.000000000 +0000
-+++ sock.c 2007-12-20 16:31:23.000000000 +0000
-@@ -44,6 +44,7 @@
+--- sock.c.orig 2007-05-24 14:33:11.000000000 +0800
++++ sock.c 2008-11-21 00:51:02.000000000 +0800
+@@ -45,7 +45,9 @@
#include <ioctls.h>
#endif
#endif
+#include <sys/socket.h>
#include <net/if.h>
++#include <netinet/in.h>
+
+ extern const struct xlat addrfams[];
+
+@@ -55,16 +57,26 @@
+ { IFF_DEBUG, "IFF_DEBUG" },
+ { IFF_LOOPBACK, "IFF_LOOPBACK" },
+ { IFF_POINTOPOINT, "IFF_POINTOPOINT" },
++#ifdef IFF_NOTRAILERS
+ { IFF_NOTRAILERS, "IFF_NOTRAILERS" },
++#endif
+ { IFF_RUNNING, "IFF_RUNNING" },
+ { IFF_NOARP, "IFF_NOARP" },
+ { IFF_PROMISC, "IFF_PROMISC" },
+ { IFF_ALLMULTI, "IFF_ALLMULTI" },
++#ifdef IFF_MASTER
+ { IFF_MASTER, "IFF_MASTER" },
++#endif
++#ifdef IFF_SLAVE
+ { IFF_SLAVE, "IFF_SLAVE" },
++#endif
+ { IFF_MULTICAST, "IFF_MULTICAST" },
++#ifdef IFF_PORTSEL
+ { IFF_PORTSEL, "IFF_PORTSEL" },
++#endif
++#ifdef IFF_AUTOMEDIA
+ { IFF_AUTOMEDIA, "IFF_AUTOMEDIA" },
++#endif
+ { 0, NULL }
+ };
- extern struct xlat addrfams[];
diff --git a/devel/strace/files/patch-strace.c b/devel/strace/files/patch-strace.c
index 9157497dc3d1..5ab633221920 100644
--- a/devel/strace/files/patch-strace.c
+++ b/devel/strace/files/patch-strace.c
@@ -1,26 +1,26 @@
---- strace.c.orig Sun Dec 26 14:49:34 2004
-+++ strace.c Sun Dec 26 16:33:21 2004
-@@ -539,6 +539,23 @@
- cleanup();
- exit(1);
- }
+--- strace.c.orig 2008-08-19 12:47:50.000000000 +0800
++++ strace.c 2008-11-20 22:48:39.000000000 +0800
+@@ -604,6 +604,23 @@
+ cleanup();
+ exit(1);
+ }
+#ifdef FREEBSD
-+ {
-+ int status;
-+ pid_t err;
++ {
++ int status;
++ pid_t err;
+
-+ do {
-+ err = waitpid(pid, &status, WUNTRACED);
-+ } while (err == -1 && errno == EINTR);
-+ if (err == -1) {
-+ fprintf(stderr,
-+ "waitpid() failed: %s\n",
-+ strerror(errno));
-+ cleanup();
-+ exit(1);
-+ }
++ do {
++ err = waitpid(pid, &status, WUNTRACED);
++ } while (err == -1 && errno == EINTR);
++ if (err == -1) {
++ fprintf(stderr,
++ "waitpid() failed: %s\n",
++ strerror(errno));
++ cleanup();
++ exit(1);
+ }
++ }
+#endif
#ifdef USE_PROCFS
- if (proc_open(tcp, 0) < 0) {
- fprintf(stderr, "trouble opening proc file\n");
+ if (proc_open(tcp, 0) < 0) {
+ fprintf(stderr, "trouble opening proc file\n");