aboutsummaryrefslogtreecommitdiff
path: root/devel/styx/Makefile
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2001-04-16 19:40:59 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2001-04-16 19:40:59 +0000
commitd65101443756a528beab24dafd71366c1d36da4b (patch)
treecec30bb364dd288b66b07f729a45bed56a5a56f3 /devel/styx/Makefile
parent0ff8ac6584a3067f2cf8926ccb467f520248c500 (diff)
Notes
Diffstat (limited to 'devel/styx/Makefile')
-rw-r--r--devel/styx/Makefile39
1 files changed, 39 insertions, 0 deletions
diff --git a/devel/styx/Makefile b/devel/styx/Makefile
new file mode 100644
index 000000000000..219d74541ccb
--- /dev/null
+++ b/devel/styx/Makefile
@@ -0,0 +1,39 @@
+# ex:ts=8
+# New ports collection makefile for: styx
+# Date created: Apr 17, 2001
+# Whom: Ying-Chieh Liao <ijliao@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= styx
+PORTVERSION= 1.3
+CATEGORIES= devel
+MASTER_SITES= http://www.speculate.de/styx/
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= ijliao@FreeBSD.org
+
+LIB_DEPENDS= giconv.2:${PORTSDIR}/converters/libiconv
+
+USE_LIBTOOL= yes
+GNU_CONFIGURE= yes
+CONFIGURE_ENV= CPPFLAGS="${CXXFLAGS} -I${PREFIX}/include" \
+ LIBS="-L${PREFIX}/lib -lgiconv"
+CONFIGURE_ARGS= --includedir=${PREFIX}/include/styx \
+ --datadir=${PREFIX}/share/doc/styx
+
+USE_GMAKE= yes
+
+post-patch:
+.for file in config.h.in configure libbase/styconf0.h
+ @${PERL} -pi -e "s,iconv.h,giconv.h,g" ${WRKSRC}/${file}
+.endfor
+.for file in config.h.in libbase/styconf0.h libbase/gstream.c
+ @${PERL} -pi -e "s,ICONV_H,GICONV_H,g" ${WRKSRC}/${file}
+.endfor
+
+pre-configure:
+ @${RM} -f ${WRKSRC}/config.cache
+
+.include <bsd.port.mk>