aboutsummaryrefslogtreecommitdiff
path: root/devel/styx
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2003-01-02 19:02:39 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2003-01-02 19:02:39 +0000
commit3ea130669ddd7f12af79dc227428c2264b6beab0 (patch)
tree386313bc1c87d840118715c00510d8507c646f69 /devel/styx
parent41e3fb3dffcd3bbb650cee8eba23087088fda6dd (diff)
downloadports-3ea130669ddd7f12af79dc227428c2264b6beab0.tar.gz
ports-3ea130669ddd7f12af79dc227428c2264b6beab0.zip
Notes
Diffstat (limited to 'devel/styx')
-rw-r--r--devel/styx/Makefile30
-rw-r--r--devel/styx/distinfo2
-rw-r--r--devel/styx/files/patch-Makefile.in24
-rw-r--r--devel/styx/files/patch-configure10
-rw-r--r--devel/styx/pkg-plist448
5 files changed, 225 insertions, 289 deletions
diff --git a/devel/styx/Makefile b/devel/styx/Makefile
index c2193f082d37..e2d20026fc7d 100644
--- a/devel/styx/Makefile
+++ b/devel/styx/Makefile
@@ -7,36 +7,36 @@
#
PORTNAME= styx
-PORTVERSION= 1.5
-PORTREVISION= 2
+PORTVERSION= 1.5.1
CATEGORIES= devel
MASTER_SITES= http://www.speculate.de/styx/
-EXTRACT_SUFX= .tgz
MAINTAINER= ports@FreeBSD.org
LIB_DEPENDS= iconv.3:${PORTSDIR}/converters/libiconv
-USE_REINPLACE= yes
USE_GMAKE= yes
USE_LIBTOOL= yes
-CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include ${PTHREAD_FLAGS}" \
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include ${PTHREAD_CFLAGS}" \
LDFLAGS="-L${LOCALBASE}/lib -liconv ${PTHREAD_LIBS}"
+CONFIGURE_ARGS= --includedir=${PREFIX}/include/${PORTNAME}
INSTALLS_SHLIB= yes
-post-extract:
- @${RM} -f ${WRKSRC}/config.cache
-
-post-patch:
- @${REINPLACE_CMD} -e "s,-lrt,${PTHREAD_LIBS},g" ${WRKSRC}/configure
-
post-install:
.if !defined(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}
- ${TAR} -C ${WRKSRC} -cf - doc tutorial | \
- ${TAR} -C ${DOCSDIR} --unlink -xf -
- @${FIND} ${DOCSDIR} -type f | ${XARGS} ${CHMOD} ${SHAREMODE}
- @${FIND} ${DOCSDIR} | ${XARGS} ${CHOWN} ${SHAREOWN}:${SHAREGRP}
+ ${TAR} -C ${WRKSRC}/doc \
+ --exclude "*.in" --exclude "*Makefile*" -cf - . | \
+ ${TAR} -C ${DOCSDIR} --unlink -xf -
+ @${CHOWN} -R ${SHAREOWN}:${SHAREGRP} ${DOCSDIR}
+ @${MKDIR} ${EXAMPLESDIR}
+ ${TAR} -C ${WRKSRC} \
+ --exclude "*.in" --exclude "*Makefile*" -cf - spe pat | \
+ ${TAR} -C ${EXAMPLESDIR} --unlink -xf -
+ ${TAR} -C ${WRKSRC}/tutorial \
+ --exclude "*.in" --exclude "*Makefile*" -cf - . | \
+ ${TAR} -C ${EXAMPLESDIR} --unlink -xf -
+ @${CHOWN} -R ${SHAREOWN}:${SHAREGRP} ${DOCSDIR}
.endif
.include <bsd.port.mk>
diff --git a/devel/styx/distinfo b/devel/styx/distinfo
index c68983ac3de6..f2f8539b653c 100644
--- a/devel/styx/distinfo
+++ b/devel/styx/distinfo
@@ -1 +1 @@
-MD5 (styx-1.5.tgz) = fa8dd644b8aef8b2d5602078e08ed72d
+MD5 (styx-1.5.1.tar.gz) = 1742815ace3d6083e82d16f4e961f44c
diff --git a/devel/styx/files/patch-Makefile.in b/devel/styx/files/patch-Makefile.in
index b54a17c68283..523e1f6e9bc3 100644
--- a/devel/styx/files/patch-Makefile.in
+++ b/devel/styx/files/patch-Makefile.in
@@ -1,17 +1,11 @@
---- Makefile.in.orig Tue Mar 12 03:22:11 2002
-+++ Makefile.in Thu Mar 21 04:56:47 2002
-@@ -555,12 +555,10 @@
+--- Makefile.in.orig Thu Dec 5 20:01:08 2002
++++ Makefile.in Sat Dec 7 06:11:52 2002
+@@ -101,7 +101,7 @@
+ noinst_LTLIBRARIES = libfoolam.la
+ libfoolam_la_SOURCES = foolam.c
+-SUBDIRS = gen libbase libstyx libutil modext modstd pgm inc doc tutorial spe pat
++SUBDIRS = gen libbase libstyx libutil modext modstd pgm inc
- install-data-local:
-- install -d $(prefix)/include
-- for i in $(iHEADERS); do install -m 444 $$i $(prefix)/include; done
-+ install -d $(pkgincludedir)
-+ for i in $(iHEADERS); do install -m 444 $$i $(pkgincludedir); done
- if [ -d man ] ; then install -d $(prefix)/man; fi
- if [ -d man ] ; then for i in man/* ; do if [ $$i != "man/*" ]; then install $$i $(prefix)/man; fi; done; fi
-- if [ -d tutorial ] ; then cp -r tutorial $(prefix); fi;
-- if [ -d doc ] ; then cp -r doc $(prefix); fi;
-
- # Tell versions [3.59,3.63) of GNU make to not export all variables.
- # Otherwise a system limit (for SysV at least) may be exceeded.
+ EXTRA_DIST = CHANGELOG LICENSE bootstrap util windows
+ ACLOCAL_M4 = $(top_srcdir)/aclocal.m4
diff --git a/devel/styx/files/patch-configure b/devel/styx/files/patch-configure
new file mode 100644
index 000000000000..6469c11056d5
--- /dev/null
+++ b/devel/styx/files/patch-configure
@@ -0,0 +1,10 @@
+--- configure.orig Thu Dec 5 19:51:31 2002
++++ configure Sat Dec 7 05:18:00 2002
+@@ -5558,6 +5558,7 @@
+
+ # This can be used to rebuild libtool when needed
+ LIBTOOL_DEPS="$ac_aux_dir/ltmain.sh"
++$ac_aux_dir/ltconfig $LIBTOOL_DEPS
+
+ # Always use our own libtool.
+ LIBTOOL='$(SHELL) $(top_builddir)/libtool'
diff --git a/devel/styx/pkg-plist b/devel/styx/pkg-plist
index 72f00fd76f09..096d304f3087 100644
--- a/devel/styx/pkg-plist
+++ b/devel/styx/pkg-plist
@@ -76,266 +76,198 @@ include/styx/symbols.h
include/styx/sysbase0.h
include/styx/sysbase1.h
include/styx/syscbhdl.h
+lib/libdstyx.a
+lib/libdstyx.so
+lib/libdstyx.so.1
lib/libxstyx.a
lib/libxstyx.so
lib/libxstyx.so.1
-%%PORTDOCS%%share/doc/styx/doc/STYX_ANT.HTM
-%%PORTDOCS%%share/doc/styx/doc/STYX_CFG.HTM
-%%PORTDOCS%%share/doc/styx/doc/STYX_CIM.HTM
-%%PORTDOCS%%share/doc/styx/doc/bin__cim.htm
-%%PORTDOCS%%share/doc/styx/doc/binimg.htm
-%%PORTDOCS%%share/doc/styx/doc/binset.htm
-%%PORTDOCS%%share/doc/styx/doc/bnf.htm
-%%PORTDOCS%%share/doc/styx/doc/c
-%%PORTDOCS%%share/doc/styx/doc/c2sgml
-%%PORTDOCS%%share/doc/styx/doc/ccnv_lim.htm
-%%PORTDOCS%%share/doc/styx/doc/cdps_lim.htm
-%%PORTDOCS%%share/doc/styx/doc/cfg_abs.htm
-%%PORTDOCS%%share/doc/styx/doc/cfg_dfn.htm
-%%PORTDOCS%%share/doc/styx/doc/charlib.htm
-%%PORTDOCS%%share/doc/styx/doc/cmd__cim.htm
-%%PORTDOCS%%share/doc/styx/doc/cmd_ant.htm
-%%PORTDOCS%%share/doc/styx/doc/cmd_ctoh.htm
-%%PORTDOCS%%share/doc/styx/doc/cmd_int.htm
-%%PORTDOCS%%share/doc/styx/doc/cmd_lim.htm
-%%PORTDOCS%%share/doc/styx/doc/cmd_lim_test.htm
-%%PORTDOCS%%share/doc/styx/doc/cmd_pim.htm
-%%PORTDOCS%%share/doc/styx/doc/cmd_pim_test.htm
-%%PORTDOCS%%share/doc/styx/doc/cmd_stydoc.htm
-%%PORTDOCS%%share/doc/styx/doc/cmd_stypp.htm
-%%PORTDOCS%%share/doc/styx/doc/cmd_styx.htm
-%%PORTDOCS%%share/doc/styx/doc/cmda_cim.htm
-%%PORTDOCS%%share/doc/styx/doc/cmdd_cim.htm
-%%PORTDOCS%%share/doc/styx/doc/cmdlib.htm
-%%PORTDOCS%%share/doc/styx/doc/com_cim.htm
-%%PORTDOCS%%share/doc/styx/doc/com_get.htm
-%%PORTDOCS%%share/doc/styx/doc/cprj_ant.htm
-%%PORTDOCS%%share/doc/styx/doc/cprj_int.htm
-%%PORTDOCS%%share/doc/styx/doc/cprj_lim.htm
-%%PORTDOCS%%share/doc/styx/doc/cprj_pim.htm
-%%PORTDOCS%%share/doc/styx/doc/ctoh_cim.htm
-%%PORTDOCS%%share/doc/styx/doc/ctx.htm
-%%PORTDOCS%%share/doc/styx/doc/ctx_app.htm
-%%PORTDOCS%%share/doc/styx/doc/ctx_dfn.htm
-%%PORTDOCS%%share/doc/styx/doc/ctx_imp.htm
-%%PORTDOCS%%share/doc/styx/doc/date.htm
-%%PORTDOCS%%share/doc/styx/doc/dict.htm
-%%PORTDOCS%%share/doc/styx/doc/dicts.htm
-%%PORTDOCS%%share/doc/styx/doc/dps_cim.htm
-%%PORTDOCS%%share/doc/styx/doc/esty_ant.htm
-%%PORTDOCS%%share/doc/styx/doc/esty_int.htm
-%%PORTDOCS%%share/doc/styx/doc/esty_lim.htm
-%%PORTDOCS%%share/doc/styx/doc/esty_pim.htm
-%%PORTDOCS%%share/doc/styx/doc/estyx_ant.htm
-%%PORTDOCS%%share/doc/styx/doc/estyx_int.htm
-%%PORTDOCS%%share/doc/styx/doc/genm_cim.htm
-%%PORTDOCS%%share/doc/styx/doc/glo_tab.htm
-%%PORTDOCS%%share/doc/styx/doc/gls.htm
-%%PORTDOCS%%share/doc/styx/doc/gls_abs.htm
-%%PORTDOCS%%share/doc/styx/doc/gstream.htm
-%%PORTDOCS%%share/doc/styx/doc/hmap.htm
-%%PORTDOCS%%share/doc/styx/doc/hpat.htm
-%%PORTDOCS%%share/doc/styx/doc/hpat_ant.htm
-%%PORTDOCS%%share/doc/styx/doc/hpat_int.htm
-%%PORTDOCS%%share/doc/styx/doc/hpat_lim.htm
-%%PORTDOCS%%share/doc/styx/doc/hpat_pim.htm
-%%PORTDOCS%%share/doc/styx/doc/hset.htm
-%%PORTDOCS%%share/doc/styx/doc/integer.htm
-%%PORTDOCS%%share/doc/styx/doc/lim__cim.htm
-%%PORTDOCS%%share/doc/styx/doc/line_scn.htm
-%%PORTDOCS%%share/doc/styx/doc/list.htm
-%%PORTDOCS%%share/doc/styx/doc/literal.htm
-%%PORTDOCS%%share/doc/styx/doc/m
-%%PORTDOCS%%share/doc/styx/doc/mem_base.htm
-%%PORTDOCS%%share/doc/styx/doc/meta_ant.htm
-%%PORTDOCS%%share/doc/styx/doc/meta_cim.htm
-%%PORTDOCS%%share/doc/styx/doc/meta_exp.htm
-%%PORTDOCS%%share/doc/styx/doc/meta_int.htm
-%%PORTDOCS%%share/doc/styx/doc/meta_lim.htm
-%%PORTDOCS%%share/doc/styx/doc/meta_pim.htm
-%%PORTDOCS%%share/doc/styx/doc/meta_prs.htm
-%%PORTDOCS%%share/doc/styx/doc/nmk_cim.htm
-%%PORTDOCS%%share/doc/styx/doc/olist.htm
-%%PORTDOCS%%share/doc/styx/doc/otab.htm
-%%PORTDOCS%%share/doc/styx/doc/pathes.htm
-%%PORTDOCS%%share/doc/styx/doc/pgm_base.htm
-%%PORTDOCS%%share/doc/styx/doc/pim__cim.htm
-%%PORTDOCS%%share/doc/styx/doc/pl0.abs.sgml
-%%PORTDOCS%%share/doc/styx/doc/pl0.c.sgml
-%%PORTDOCS%%share/doc/styx/doc/pl0.sty.sgml
-%%PORTDOCS%%share/doc/styx/doc/prdp_cim.htm
-%%PORTDOCS%%share/doc/styx/doc/pre.htm
-%%PORTDOCS%%share/doc/styx/doc/prim.htm
-%%PORTDOCS%%share/doc/styx/doc/prjfun.htm
-%%PORTDOCS%%share/doc/styx/doc/prs.htm
-%%PORTDOCS%%share/doc/styx/doc/prs_abs.htm
-%%PORTDOCS%%share/doc/styx/doc/prs_dfn.htm
-%%PORTDOCS%%share/doc/styx/doc/prs_gen.htm
-%%PORTDOCS%%share/doc/styx/doc/prs_imp.htm
-%%PORTDOCS%%share/doc/styx/doc/prs_io.htm
-%%PORTDOCS%%share/doc/styx/doc/ptm.htm
-%%PORTDOCS%%share/doc/styx/doc/ptm__cim.htm
-%%PORTDOCS%%share/doc/styx/doc/ptm_gen.htm
-%%PORTDOCS%%share/doc/styx/doc/ptm_pp.htm
-%%PORTDOCS%%share/doc/styx/doc/rational.htm
-%%PORTDOCS%%share/doc/styx/doc/refo_cim.htm
-%%PORTDOCS%%share/doc/styx/doc/reg_exp.htm
-%%PORTDOCS%%share/doc/styx/doc/rexp_lim.htm
-%%PORTDOCS%%share/doc/styx/doc/scn_abs.htm
-%%PORTDOCS%%share/doc/styx/doc/scn_base.htm
-%%PORTDOCS%%share/doc/styx/doc/scn_gen.htm
-%%PORTDOCS%%share/doc/styx/doc/scn_imp.htm
-%%PORTDOCS%%share/doc/styx/doc/scn_io.htm
-%%PORTDOCS%%share/doc/styx/doc/scn_pre.htm
-%%PORTDOCS%%share/doc/styx/doc/shmain.htm
-%%PORTDOCS%%share/doc/styx/doc/sink.htm
-%%PORTDOCS%%share/doc/styx/doc/standard.htm
-%%PORTDOCS%%share/doc/styx/doc/stdosx.htm
-%%PORTDOCS%%share/doc/styx/doc/styconf0.htm
-%%PORTDOCS%%share/doc/styx/doc/styd_cim.htm
-%%PORTDOCS%%share/doc/styx/doc/styp_cim.htm
-%%PORTDOCS%%share/doc/styx/doc/styx-1.html
-%%PORTDOCS%%share/doc/styx/doc/styx-10.html
-%%PORTDOCS%%share/doc/styx/doc/styx-11.html
-%%PORTDOCS%%share/doc/styx/doc/styx-12.html
-%%PORTDOCS%%share/doc/styx/doc/styx-2.html
-%%PORTDOCS%%share/doc/styx/doc/styx-3.html
-%%PORTDOCS%%share/doc/styx/doc/styx-4.html
-%%PORTDOCS%%share/doc/styx/doc/styx-5.html
-%%PORTDOCS%%share/doc/styx/doc/styx-6.html
-%%PORTDOCS%%share/doc/styx/doc/styx-7.html
-%%PORTDOCS%%share/doc/styx/doc/styx-8.html
-%%PORTDOCS%%share/doc/styx/doc/styx-9.html
-%%PORTDOCS%%share/doc/styx/doc/styx-todo
-%%PORTDOCS%%share/doc/styx/doc/styx.html
-%%PORTDOCS%%share/doc/styx/doc/styx.sgml
-%%PORTDOCS%%share/doc/styx/doc/styx_gen.htm
-%%PORTDOCS%%share/doc/styx/doc/styx_hdl.htm
-%%PORTDOCS%%share/doc/styx/doc/styx_int.htm
-%%PORTDOCS%%share/doc/styx/doc/styx_lim.htm
-%%PORTDOCS%%share/doc/styx/doc/styx_pim.htm
-%%PORTDOCS%%share/doc/styx/doc/symbols.htm
-%%PORTDOCS%%share/doc/styx/doc/sysbase0.htm
-%%PORTDOCS%%share/doc/styx/doc/sysbase1.htm
-%%PORTDOCS%%share/doc/styx/doc/syscbhdl.htm
-%%PORTDOCS%%share/doc/styx/doc/term.htm
-%%PORTDOCS%%share/doc/styx/doc/testpl0.pl.sgml
-%%PORTDOCS%%share/doc/styx/doc/xc-doc-new/c
-%%PORTDOCS%%share/doc/styx/doc/xc-doc-new/inc/xm_new.h
-%%PORTDOCS%%share/doc/styx/doc/xc-doc-new/m
-%%PORTDOCS%%share/doc/styx/doc/xc-doc-new/memory-1.html
-%%PORTDOCS%%share/doc/styx/doc/xc-doc-new/memory-2.html
-%%PORTDOCS%%share/doc/styx/doc/xc-doc-new/memory-3.html
-%%PORTDOCS%%share/doc/styx/doc/xc-doc-new/memory-4.html
-%%PORTDOCS%%share/doc/styx/doc/xc-doc-new/memory-5.html
-%%PORTDOCS%%share/doc/styx/doc/xc-doc-new/memory.html
-%%PORTDOCS%%share/doc/styx/doc/xc-doc-new/memory.sgml
-%%PORTDOCS%%share/doc/styx/doc/xc-doc-new/mmg
-%%PORTDOCS%%share/doc/styx/doc/xc-doc-new/prj/ctoh.cth
-%%PORTDOCS%%share/doc/styx/doc/xc-doc-new/prj/project.dps
-%%PORTDOCS%%share/doc/styx/doc/xc-doc-new/prj/project.lst
-%%PORTDOCS%%share/doc/styx/doc/xc-doc-new/prj/project.nmk
-%%PORTDOCS%%share/doc/styx/doc/xc-doc-new/xm_new.c
-%%PORTDOCS%%share/doc/styx/doc/xc-doc-new/xm_new.s
-%%PORTDOCS%%share/doc/styx/doc/xmem_imp.htm
-%%PORTDOCS%%share/doc/styx/doc/xstdosx.htm
-%%PORTDOCS%%share/doc/styx/tutorial/readme
-%%PORTDOCS%%share/doc/styx/tutorial/tutorial01/calc.sty
-%%PORTDOCS%%share/doc/styx/tutorial/tutorial01/calctut.c
-%%PORTDOCS%%share/doc/styx/tutorial/tutorial01/explist.calc
-%%PORTDOCS%%share/doc/styx/tutorial/tutorial01/gen/calc.abs
-%%PORTDOCS%%share/doc/styx/tutorial/tutorial01/gen/calc_ant.c
-%%PORTDOCS%%share/doc/styx/tutorial/tutorial01/gen/calc_int.c
-%%PORTDOCS%%share/doc/styx/tutorial/tutorial01/gen/calc_lim.c
-%%PORTDOCS%%share/doc/styx/tutorial/tutorial01/gen/calc_pim.c
-%%PORTDOCS%%share/doc/styx/tutorial/tutorial01/inc/calc_ant.h
-%%PORTDOCS%%share/doc/styx/tutorial/tutorial01/inc/calc_int.h
-%%PORTDOCS%%share/doc/styx/tutorial/tutorial01/inc/calc_lim.h
-%%PORTDOCS%%share/doc/styx/tutorial/tutorial01/inc/calc_pim.h
-%%PORTDOCS%%share/doc/styx/tutorial/tutorial01/mx
-%%PORTDOCS%%share/doc/styx/tutorial/tutorial01/readme
-%%PORTDOCS%%share/doc/styx/tutorial/tutorial02/gen/pl0.abs
-%%PORTDOCS%%share/doc/styx/tutorial/tutorial02/gen/pl0.cim
-%%PORTDOCS%%share/doc/styx/tutorial/tutorial02/gen/pl0.lim
-%%PORTDOCS%%share/doc/styx/tutorial/tutorial02/gen/pl0.pim
-%%PORTDOCS%%share/doc/styx/tutorial/tutorial02/gen/pl0_ant.c
-%%PORTDOCS%%share/doc/styx/tutorial/tutorial02/gen/pl0_cim.c
-%%PORTDOCS%%share/doc/styx/tutorial/tutorial02/gen/pl0_int.c
-%%PORTDOCS%%share/doc/styx/tutorial/tutorial02/gen/pl0_lim.c
-%%PORTDOCS%%share/doc/styx/tutorial/tutorial02/gen/pl0_pim.c
-%%PORTDOCS%%share/doc/styx/tutorial/tutorial02/inc/pl0_ant.h
-%%PORTDOCS%%share/doc/styx/tutorial/tutorial02/inc/pl0_cim.h
-%%PORTDOCS%%share/doc/styx/tutorial/tutorial02/inc/pl0_int.h
-%%PORTDOCS%%share/doc/styx/tutorial/tutorial02/inc/pl0_lim.h
-%%PORTDOCS%%share/doc/styx/tutorial/tutorial02/inc/pl0_pim.h
-%%PORTDOCS%%share/doc/styx/tutorial/tutorial02/mx
-%%PORTDOCS%%share/doc/styx/tutorial/tutorial02/pl0.c
-%%PORTDOCS%%share/doc/styx/tutorial/tutorial02/pl0.sty
-%%PORTDOCS%%share/doc/styx/tutorial/tutorial02/readme
-%%PORTDOCS%%share/doc/styx/tutorial/tutorial02/t
-%%PORTDOCS%%share/doc/styx/tutorial/tutorial02/testpl0.pl0
-%%PORTDOCS%%share/doc/styx/tutorial/tutorial02/todo
-%%PORTDOCS%%share/doc/styx/tutorial/tutorial03/gen/pl0.abs
-%%PORTDOCS%%share/doc/styx/tutorial/tutorial03/gen/pl0.cim
-%%PORTDOCS%%share/doc/styx/tutorial/tutorial03/gen/pl0.lim
-%%PORTDOCS%%share/doc/styx/tutorial/tutorial03/gen/pl0.pim
-%%PORTDOCS%%share/doc/styx/tutorial/tutorial03/gen/pl0_ant.c
-%%PORTDOCS%%share/doc/styx/tutorial/tutorial03/gen/pl0_cim.c
-%%PORTDOCS%%share/doc/styx/tutorial/tutorial03/gen/pl0_int.c
-%%PORTDOCS%%share/doc/styx/tutorial/tutorial03/gen/pl0_lim.c
-%%PORTDOCS%%share/doc/styx/tutorial/tutorial03/gen/pl0_pim.c
-%%PORTDOCS%%share/doc/styx/tutorial/tutorial03/inc/pl0_ant.h
-%%PORTDOCS%%share/doc/styx/tutorial/tutorial03/inc/pl0_cim.h
-%%PORTDOCS%%share/doc/styx/tutorial/tutorial03/inc/pl0_int.h
-%%PORTDOCS%%share/doc/styx/tutorial/tutorial03/inc/pl0_lim.h
-%%PORTDOCS%%share/doc/styx/tutorial/tutorial03/inc/pl0_pim.h
-%%PORTDOCS%%share/doc/styx/tutorial/tutorial03/mx
-%%PORTDOCS%%share/doc/styx/tutorial/tutorial03/pl0.sty
-%%PORTDOCS%%share/doc/styx/tutorial/tutorial03/pl0c.c
-%%PORTDOCS%%share/doc/styx/tutorial/tutorial03/pl0r.c
-%%PORTDOCS%%share/doc/styx/tutorial/tutorial03/readme
-%%PORTDOCS%%share/doc/styx/tutorial/tutorial03/t
-%%PORTDOCS%%share/doc/styx/tutorial/tutorial03/testpl0
-%%PORTDOCS%%share/doc/styx/tutorial/tutorial03/testpl0.pl0
-%%PORTDOCS%%share/doc/styx/tutorial/tutorial03/todo
-%%PORTDOCS%%share/doc/styx/tutorial/tutorial04/calc
-%%PORTDOCS%%share/doc/styx/tutorial/tutorial04/calc.cpp
-%%PORTDOCS%%share/doc/styx/tutorial/tutorial04/calc.sty
-%%PORTDOCS%%share/doc/styx/tutorial/tutorial04/gen/calc.abs
-%%PORTDOCS%%share/doc/styx/tutorial/tutorial04/gen/calc.lim
-%%PORTDOCS%%share/doc/styx/tutorial/tutorial04/gen/calc.pim
-%%PORTDOCS%%share/doc/styx/tutorial/tutorial04/gen/calc_ant.c
-%%PORTDOCS%%share/doc/styx/tutorial/tutorial04/gen/calc_int.c
-%%PORTDOCS%%share/doc/styx/tutorial/tutorial04/gen/calc_lim.c
-%%PORTDOCS%%share/doc/styx/tutorial/tutorial04/gen/calc_pim.c
-%%PORTDOCS%%share/doc/styx/tutorial/tutorial04/inc/calc_ant.h
-%%PORTDOCS%%share/doc/styx/tutorial/tutorial04/inc/calc_int.h
-%%PORTDOCS%%share/doc/styx/tutorial/tutorial04/inc/calc_lim.h
-%%PORTDOCS%%share/doc/styx/tutorial/tutorial04/inc/calc_pim.h
-%%PORTDOCS%%share/doc/styx/tutorial/tutorial04/mx
-%%PORTDOCS%%share/doc/styx/tutorial/tutorial04/pattern_file.txt
-%%PORTDOCS%%share/doc/styx/tutorial/tutorial04/readme
-%%PORTDOCS%%share/doc/styx/tutorial/tutorial04/t
-%%PORTDOCS%%@dirrm share/doc/styx/tutorial/tutorial04/prj
-%%PORTDOCS%%@dirrm share/doc/styx/tutorial/tutorial04/inc
-%%PORTDOCS%%@dirrm share/doc/styx/tutorial/tutorial04/gen
-%%PORTDOCS%%@dirrm share/doc/styx/tutorial/tutorial04
-%%PORTDOCS%%@dirrm share/doc/styx/tutorial/tutorial03/prj
-%%PORTDOCS%%@dirrm share/doc/styx/tutorial/tutorial03/inc
-%%PORTDOCS%%@dirrm share/doc/styx/tutorial/tutorial03/gen
-%%PORTDOCS%%@dirrm share/doc/styx/tutorial/tutorial03
-%%PORTDOCS%%@dirrm share/doc/styx/tutorial/tutorial02/prj
-%%PORTDOCS%%@dirrm share/doc/styx/tutorial/tutorial02/inc
-%%PORTDOCS%%@dirrm share/doc/styx/tutorial/tutorial02/gen
-%%PORTDOCS%%@dirrm share/doc/styx/tutorial/tutorial02
-%%PORTDOCS%%@dirrm share/doc/styx/tutorial/tutorial01/prj
-%%PORTDOCS%%@dirrm share/doc/styx/tutorial/tutorial01/inc
-%%PORTDOCS%%@dirrm share/doc/styx/tutorial/tutorial01/gen
-%%PORTDOCS%%@dirrm share/doc/styx/tutorial/tutorial01
-%%PORTDOCS%%@dirrm share/doc/styx/tutorial
-%%PORTDOCS%%@dirrm share/doc/styx/doc/xc-doc-new/prj
-%%PORTDOCS%%@dirrm share/doc/styx/doc/xc-doc-new/inc
-%%PORTDOCS%%@dirrm share/doc/styx/doc/xc-doc-new
-%%PORTDOCS%%@dirrm share/doc/styx/doc
+%%PORTDOCS%%share/doc/styx/bin__cim.htm
+%%PORTDOCS%%share/doc/styx/binimg.htm
+%%PORTDOCS%%share/doc/styx/binset.htm
+%%PORTDOCS%%share/doc/styx/bnf.htm
+%%PORTDOCS%%share/doc/styx/ccnv_lim.htm
+%%PORTDOCS%%share/doc/styx/cdps_lim.htm
+%%PORTDOCS%%share/doc/styx/cfg_abs.htm
+%%PORTDOCS%%share/doc/styx/cfg_dfn.htm
+%%PORTDOCS%%share/doc/styx/charlib.htm
+%%PORTDOCS%%share/doc/styx/cmd__cim.htm
+%%PORTDOCS%%share/doc/styx/cmd_ant.htm
+%%PORTDOCS%%share/doc/styx/cmd_ctoh.htm
+%%PORTDOCS%%share/doc/styx/cmd_int.htm
+%%PORTDOCS%%share/doc/styx/cmd_lim.htm
+%%PORTDOCS%%share/doc/styx/cmd_lim_test.htm
+%%PORTDOCS%%share/doc/styx/cmd_pim.htm
+%%PORTDOCS%%share/doc/styx/cmd_pim_test.htm
+%%PORTDOCS%%share/doc/styx/cmd_stydoc.htm
+%%PORTDOCS%%share/doc/styx/cmd_stypp.htm
+%%PORTDOCS%%share/doc/styx/cmd_styx.htm
+%%PORTDOCS%%share/doc/styx/cmda_cim.htm
+%%PORTDOCS%%share/doc/styx/cmdd_cim.htm
+%%PORTDOCS%%share/doc/styx/cmdlib.htm
+%%PORTDOCS%%share/doc/styx/com_cim.htm
+%%PORTDOCS%%share/doc/styx/com_get.htm
+%%PORTDOCS%%share/doc/styx/cprj_ant.htm
+%%PORTDOCS%%share/doc/styx/cprj_int.htm
+%%PORTDOCS%%share/doc/styx/cprj_lim.htm
+%%PORTDOCS%%share/doc/styx/cprj_pim.htm
+%%PORTDOCS%%share/doc/styx/ctoh_cim.htm
+%%PORTDOCS%%share/doc/styx/ctx.htm
+%%PORTDOCS%%share/doc/styx/ctx_app.htm
+%%PORTDOCS%%share/doc/styx/ctx_dfn.htm
+%%PORTDOCS%%share/doc/styx/ctx_imp.htm
+%%PORTDOCS%%share/doc/styx/date.htm
+%%PORTDOCS%%share/doc/styx/dict.htm
+%%PORTDOCS%%share/doc/styx/dicts.htm
+%%PORTDOCS%%share/doc/styx/dps_cim.htm
+%%PORTDOCS%%share/doc/styx/esty_ant.htm
+%%PORTDOCS%%share/doc/styx/esty_int.htm
+%%PORTDOCS%%share/doc/styx/esty_lim.htm
+%%PORTDOCS%%share/doc/styx/esty_pim.htm
+%%PORTDOCS%%share/doc/styx/estyx_ant.htm
+%%PORTDOCS%%share/doc/styx/estyx_int.htm
+%%PORTDOCS%%share/doc/styx/genm_cim.htm
+%%PORTDOCS%%share/doc/styx/glo_tab.htm
+%%PORTDOCS%%share/doc/styx/gls.htm
+%%PORTDOCS%%share/doc/styx/gls_abs.htm
+%%PORTDOCS%%share/doc/styx/gstream.htm
+%%PORTDOCS%%share/doc/styx/hmap.htm
+%%PORTDOCS%%share/doc/styx/hpat.htm
+%%PORTDOCS%%share/doc/styx/hpat_ant.htm
+%%PORTDOCS%%share/doc/styx/hpat_int.htm
+%%PORTDOCS%%share/doc/styx/hpat_lim.htm
+%%PORTDOCS%%share/doc/styx/hpat_pim.htm
+%%PORTDOCS%%share/doc/styx/hset.htm
+%%PORTDOCS%%share/doc/styx/integer.htm
+%%PORTDOCS%%share/doc/styx/lim__cim.htm
+%%PORTDOCS%%share/doc/styx/line_scn.htm
+%%PORTDOCS%%share/doc/styx/list.htm
+%%PORTDOCS%%share/doc/styx/literal.htm
+%%PORTDOCS%%share/doc/styx/mem_base.htm
+%%PORTDOCS%%share/doc/styx/meta_ant.htm
+%%PORTDOCS%%share/doc/styx/meta_cim.htm
+%%PORTDOCS%%share/doc/styx/meta_exp.htm
+%%PORTDOCS%%share/doc/styx/meta_int.htm
+%%PORTDOCS%%share/doc/styx/meta_lim.htm
+%%PORTDOCS%%share/doc/styx/meta_pim.htm
+%%PORTDOCS%%share/doc/styx/meta_prs.htm
+%%PORTDOCS%%share/doc/styx/nmk_cim.htm
+%%PORTDOCS%%share/doc/styx/olist.htm
+%%PORTDOCS%%share/doc/styx/otab.htm
+%%PORTDOCS%%share/doc/styx/pathes.htm
+%%PORTDOCS%%share/doc/styx/pgm_base.htm
+%%PORTDOCS%%share/doc/styx/pim__cim.htm
+%%PORTDOCS%%share/doc/styx/pl0.abs.sgml
+%%PORTDOCS%%share/doc/styx/pl0.c.sgml
+%%PORTDOCS%%share/doc/styx/pl0.sty.sgml
+%%PORTDOCS%%share/doc/styx/prdp_cim.htm
+%%PORTDOCS%%share/doc/styx/pre.htm
+%%PORTDOCS%%share/doc/styx/prim.htm
+%%PORTDOCS%%share/doc/styx/prjfun.htm
+%%PORTDOCS%%share/doc/styx/prs.htm
+%%PORTDOCS%%share/doc/styx/prs_abs.htm
+%%PORTDOCS%%share/doc/styx/prs_dfn.htm
+%%PORTDOCS%%share/doc/styx/prs_gen.htm
+%%PORTDOCS%%share/doc/styx/prs_imp.htm
+%%PORTDOCS%%share/doc/styx/prs_io.htm
+%%PORTDOCS%%share/doc/styx/ptm.htm
+%%PORTDOCS%%share/doc/styx/ptm__cim.htm
+%%PORTDOCS%%share/doc/styx/ptm_gen.htm
+%%PORTDOCS%%share/doc/styx/ptm_pp.htm
+%%PORTDOCS%%share/doc/styx/rational.htm
+%%PORTDOCS%%share/doc/styx/refo_cim.htm
+%%PORTDOCS%%share/doc/styx/reg_exp.htm
+%%PORTDOCS%%share/doc/styx/rexp_lim.htm
+%%PORTDOCS%%share/doc/styx/scn_abs.htm
+%%PORTDOCS%%share/doc/styx/scn_base.htm
+%%PORTDOCS%%share/doc/styx/scn_gen.htm
+%%PORTDOCS%%share/doc/styx/scn_imp.htm
+%%PORTDOCS%%share/doc/styx/scn_io.htm
+%%PORTDOCS%%share/doc/styx/scn_pre.htm
+%%PORTDOCS%%share/doc/styx/shmain.htm
+%%PORTDOCS%%share/doc/styx/sink.htm
+%%PORTDOCS%%share/doc/styx/standard.htm
+%%PORTDOCS%%share/doc/styx/stdosx.htm
+%%PORTDOCS%%share/doc/styx/styconf0.htm
+%%PORTDOCS%%share/doc/styx/styd_cim.htm
+%%PORTDOCS%%share/doc/styx/styp_cim.htm
+%%PORTDOCS%%share/doc/styx/styx-1.html
+%%PORTDOCS%%share/doc/styx/styx-10.html
+%%PORTDOCS%%share/doc/styx/styx-11.html
+%%PORTDOCS%%share/doc/styx/styx-12.html
+%%PORTDOCS%%share/doc/styx/styx-2.html
+%%PORTDOCS%%share/doc/styx/styx-3.html
+%%PORTDOCS%%share/doc/styx/styx-4.html
+%%PORTDOCS%%share/doc/styx/styx-5.html
+%%PORTDOCS%%share/doc/styx/styx-6.html
+%%PORTDOCS%%share/doc/styx/styx-7.html
+%%PORTDOCS%%share/doc/styx/styx-8.html
+%%PORTDOCS%%share/doc/styx/styx-9.html
+%%PORTDOCS%%share/doc/styx/styx.html
+%%PORTDOCS%%share/doc/styx/styx.sgml
+%%PORTDOCS%%share/doc/styx/styx_ant.htm
+%%PORTDOCS%%share/doc/styx/styx_cfg.htm
+%%PORTDOCS%%share/doc/styx/styx_cim.htm
+%%PORTDOCS%%share/doc/styx/styx_gen.htm
+%%PORTDOCS%%share/doc/styx/styx_hdl.htm
+%%PORTDOCS%%share/doc/styx/styx_int.htm
+%%PORTDOCS%%share/doc/styx/styx_lim.htm
+%%PORTDOCS%%share/doc/styx/styx_pim.htm
+%%PORTDOCS%%share/doc/styx/symbols.htm
+%%PORTDOCS%%share/doc/styx/sysbase0.htm
+%%PORTDOCS%%share/doc/styx/sysbase1.htm
+%%PORTDOCS%%share/doc/styx/syscbhdl.htm
+%%PORTDOCS%%share/doc/styx/term.htm
+%%PORTDOCS%%share/doc/styx/testpl0.pl.sgml
+%%PORTDOCS%%share/doc/styx/xmem_imp.htm
+%%PORTDOCS%%share/doc/styx/xstdosx.htm
+%%PORTDOCS%%share/examples/styx/pat/lstydoc_us.htm
+%%PORTDOCS%%share/examples/styx/pat/pcmdbook.xml
+%%PORTDOCS%%share/examples/styx/pat/pcmddoc_us.htm
+%%PORTDOCS%%share/examples/styx/pat/rstydoc_us.htm
+%%PORTDOCS%%share/examples/styx/pat/tstydoc_us.htm
+%%PORTDOCS%%share/examples/styx/readme
+%%PORTDOCS%%share/examples/styx/spe/ccnv.sty
+%%PORTDOCS%%share/examples/styx/spe/cdps.sty
+%%PORTDOCS%%share/examples/styx/spe/cmd.sty
+%%PORTDOCS%%share/examples/styx/spe/cprj.sty
+%%PORTDOCS%%share/examples/styx/spe/estyx.sty
+%%PORTDOCS%%share/examples/styx/spe/hpat.sty
+%%PORTDOCS%%share/examples/styx/spe/meta.sty
+%%PORTDOCS%%share/examples/styx/spe/rexp.sty
+%%PORTDOCS%%share/examples/styx/spe/styx.sty
+%%PORTDOCS%%share/examples/styx/tutorial01/calc.sty
+%%PORTDOCS%%share/examples/styx/tutorial01/calctut.c
+%%PORTDOCS%%share/examples/styx/tutorial01/explist.calc
+%%PORTDOCS%%share/examples/styx/tutorial01/mx
+%%PORTDOCS%%share/examples/styx/tutorial01/readme
+%%PORTDOCS%%share/examples/styx/tutorial02/mx
+%%PORTDOCS%%share/examples/styx/tutorial02/pl0.c
+%%PORTDOCS%%share/examples/styx/tutorial02/pl0.sty
+%%PORTDOCS%%share/examples/styx/tutorial02/readme
+%%PORTDOCS%%share/examples/styx/tutorial02/t
+%%PORTDOCS%%share/examples/styx/tutorial02/testpl0.pl0
+%%PORTDOCS%%share/examples/styx/tutorial02/todo
+%%PORTDOCS%%share/examples/styx/tutorial03/mx
+%%PORTDOCS%%share/examples/styx/tutorial03/pl0.sty
+%%PORTDOCS%%share/examples/styx/tutorial03/pl0c.c
+%%PORTDOCS%%share/examples/styx/tutorial03/pl0r.c
+%%PORTDOCS%%share/examples/styx/tutorial03/readme
+%%PORTDOCS%%share/examples/styx/tutorial03/t
+%%PORTDOCS%%share/examples/styx/tutorial03/testpl0.pl0
+%%PORTDOCS%%share/examples/styx/tutorial03/todo
+%%PORTDOCS%%share/examples/styx/tutorial04/calc.cpp
+%%PORTDOCS%%share/examples/styx/tutorial04/calc.sty
+%%PORTDOCS%%share/examples/styx/tutorial04/mx
+%%PORTDOCS%%share/examples/styx/tutorial04/pattern_file.txt
+%%PORTDOCS%%share/examples/styx/tutorial04/readme
+%%PORTDOCS%%share/examples/styx/tutorial04/t
+%%PORTDOCS%%@dirrm share/examples/styx/tutorial04
+%%PORTDOCS%%@dirrm share/examples/styx/tutorial03
+%%PORTDOCS%%@dirrm share/examples/styx/tutorial02
+%%PORTDOCS%%@dirrm share/examples/styx/tutorial01
+%%PORTDOCS%%@dirrm share/examples/styx/spe
+%%PORTDOCS%%@dirrm share/examples/styx/pat
+%%PORTDOCS%%@dirrm share/examples/styx
%%PORTDOCS%%@dirrm share/doc/styx
@dirrm include/styx