aboutsummaryrefslogtreecommitdiff
path: root/devel/subversion-freebsd
diff options
context:
space:
mode:
authorLev A. Serebryakov <lev@FreeBSD.org>2006-09-12 12:46:30 +0000
committerLev A. Serebryakov <lev@FreeBSD.org>2006-09-12 12:46:30 +0000
commit0c0e8fd828132ba74baef61a04291cdc1a97f370 (patch)
tree46ce8239bae7e9573439bff5ae32fa8cc905f698 /devel/subversion-freebsd
parent56021600c2a491059f488a423a2e3f31a6b9d0ad (diff)
downloadports-0c0e8fd828132ba74baef61a04291cdc1a97f370.tar.gz
ports-0c0e8fd828132ba74baef61a04291cdc1a97f370.zip
Notes
Diffstat (limited to 'devel/subversion-freebsd')
-rw-r--r--devel/subversion-freebsd/Makefile40
-rw-r--r--devel/subversion-freebsd/distinfo57
-rw-r--r--devel/subversion-freebsd/files/patch-build--ltmain.sh (renamed from devel/subversion-freebsd/files/patch-ac-helpers::ltmain.sh)4
-rw-r--r--devel/subversion-freebsd/files/patch-build-outputs.mk11
-rw-r--r--devel/subversion-freebsd/files/patch-configure12
-rw-r--r--devel/subversion-freebsd/files/patch-contrib--client-side--asvn185
-rw-r--r--devel/subversion-freebsd/pkg-plist31
7 files changed, 277 insertions, 63 deletions
diff --git a/devel/subversion-freebsd/Makefile b/devel/subversion-freebsd/Makefile
index df96ae7a7eea..3e92b2db5022 100644
--- a/devel/subversion-freebsd/Makefile
+++ b/devel/subversion-freebsd/Makefile
@@ -5,13 +5,15 @@
# $FreeBSD$
PORTNAME= subversion
-PORTVERSION= 1.3.2
+PORTVERSION= 1.4.0
PORTREVISION?= 0
CATEGORIES= devel
MASTER_SITES= http://subversion.tigris.org/downloads/:main \
- http://svnbook.red-bean.com/en/1.1/:bookhtml \
- http://svnbook.red-bean.com/en/1.1/:bookpdf
+ http://svnbook.red-bean.com/en/1.2/:bookhtml \
+ http://svnbook.red-bean.com/en/1.2/images/:bookhtmlimg \
+ http://svnbook.red-bean.com/en/1.2/:bookpdf
DISTFILES= ${PORTNAME}-${DISTVERSION}${EXTRACT_SUFX}:main
+DIST_SUBDIR= subversion
EXTRACT_ONLY= ${PORTNAME}-${DISTVERSION}${EXTRACT_SUFX}
MAINTAINER= lev@freebsd.org
@@ -26,9 +28,9 @@ USE_AUTOTOOLS= libtool:15
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ARGS= --with-ssl
-USE_RC_SUBR=svnserve.sh
+USE_RC_SUBR= svnserve.sh
-MAN1= svn.1 svnadmin.1 svnlook.1 svndumpfilter.1 svnversion.1
+MAN1= svn.1 svnadmin.1 svnlook.1 svndumpfilter.1 svnsync.1 svnversion.1
MAN5= svnserve.conf.5
MAN8= svnserve.8
MANCOMPRESSED= no
@@ -38,6 +40,10 @@ TXT_DOCS= BUGS CHANGES COMMITTERS COPYING HACKING INSTALL README
PORTDOCS= ${TXT_DOCS}
.endif
+.if defined(WITH_ASVN)
+RUN_DEPENDS= ${LOCALBASE}/bin/gfind:${PORTSDIR}/misc/findutils:install
+.endif
+
.if !defined(WITHOUT_NLS)
USE_GETTEXT= yes
PLIST_SUB+= WITHOUT_GETTEXT=""
@@ -198,7 +204,15 @@ PLIST_SUB+= SVNSERVE_WRAPPER="@comment "
.if !defined(NOPORTDOCS) && defined(WITH_BOOK)
PORTDOCS+= book
-DISTFILES+= svn-book.html:bookhtml svn-book.pdf:bookpdf
+DISTFILES+= svn-book.html:bookhtml \
+ ch01dia1.png:bookhtmlimg ch02dia1.png:bookhtmlimg \
+ ch02dia2.png:bookhtmlimg ch02dia3.png:bookhtmlimg \
+ ch02dia5.png:bookhtmlimg ch02dia6.png:bookhtmlimg \
+ ch02dia7.png:bookhtmlimg ch04dia1.png:bookhtmlimg \
+ ch04dia2.png:bookhtmlimg ch04dia3.png:bookhtmlimg \
+ ch04dia4.png:bookhtmlimg ch08dia1.png:bookhtmlimg \
+ ch08dia2.png:bookhtmlimg \
+ svn-book.pdf:bookpdf
.endif
.if defined(WITH_ASVN)
@@ -315,10 +329,10 @@ pre-everything::
@${ECHO_MSG} ""
@${ECHO_MSG} "Many useful scripts will be installed into ${PREFIX}/share/subversion"
-post-extract:
- @${RM} -r ${WRKSRC}/neon
- @${RM} -r ${WRKSRC}/apr
- @${RM} -r ${WRKSRC}/apr-util
+#post-extract:
+# @${RM} -r ${WRKSRC}/neon
+# @${RM} -r ${WRKSRC}/apr
+# @${RM} -r ${WRKSRC}/apr-util
post-patch:
.if ${PREFIX} != "/usr"
@@ -386,8 +400,10 @@ post-install: ${MKREPOS_TARGET}
done
.if defined(WITH_BOOK)
${MKDIR} ${DOCSDIR}/book
- ${INSTALL_DATA} ${DISTDIR}/svn-book.html ${DOCSDIR}/book
- ${INSTALL_DATA} ${DISTDIR}/svn-book.pdf ${DOCSDIR}/book
+ ${MKDIR} ${DOCSDIR}/book/images
+ ${INSTALL_DATA} ${DISTDIR}/${DIST_SUBDIR}/svn-book.html ${DOCSDIR}/book
+ ${INSTALL_DATA} ${DISTDIR}/${DIST_SUBDIR}/*.png ${DOCSDIR}/book/images
+ ${INSTALL_DATA} ${DISTDIR}/${DIST_SUBDIR}/svn-book.pdf ${DOCSDIR}/book
.endif
.endif
.if defined(WITH_ASVN)
diff --git a/devel/subversion-freebsd/distinfo b/devel/subversion-freebsd/distinfo
index f4e236c7a410..f1e7af6b7a19 100644
--- a/devel/subversion-freebsd/distinfo
+++ b/devel/subversion-freebsd/distinfo
@@ -1,9 +1,48 @@
-MD5 (subversion-1.3.2.tar.bz2) = 34aaac35a8326eba1c8076ee9e93fb6c
-SHA256 (subversion-1.3.2.tar.bz2) = 805cb0ee894d2c219fe979dde98ccd56c06de6c3ca3986d87c80a2a2bcc08185
-SIZE (subversion-1.3.2.tar.bz2) = 6834364
-MD5 (svn-book.html) = 1800ef7abfa35df7f2e6f4776d74c37f
-SHA256 (svn-book.html) = dfa12f00574523e601c18a590cfbf0c76df10d090da0db9b7e41b152840e1403
-SIZE (svn-book.html) = 1055053
-MD5 (svn-book.pdf) = 2cb4a90f41904634db249cf006aea7d1
-SHA256 (svn-book.pdf) = 518512007f1feb5607afbb1f2adef90d6bde9090bc754a1dab341733a2a37a68
-SIZE (svn-book.pdf) = 1533253
+MD5 (subversion/subversion-1.4.0.tar.bz2) = f0c5fef69fccfb12ef6c8598f484ed0e
+SHA256 (subversion/subversion-1.4.0.tar.bz2) = 6960ed42174be9c54853e8708cc91a7c8355b23c4c3921a6d7fe7947d50843e4
+SIZE (subversion/subversion-1.4.0.tar.bz2) = 4709293
+MD5 (subversion/svn-book.html) = 3724fcf5e4c8383413462b9817213303
+SHA256 (subversion/svn-book.html) = 5faf71a02169f0ce473c253dd863ab0f327937237d2c64da84f8df7d93344e94
+SIZE (subversion/svn-book.html) = 1151588
+MD5 (subversion/ch01dia1.png) = d5cf54020bcbb99fb12150481d94bffa
+SHA256 (subversion/ch01dia1.png) = cffbe5942f45561567b92899d61a3ee8251384667454a8eb9d7bf0cd54b9a5ad
+SIZE (subversion/ch01dia1.png) = 55406
+MD5 (subversion/ch02dia1.png) = 9f98bd2bd15fabc36d55db0572a7b32b
+SHA256 (subversion/ch02dia1.png) = 77b8551c1714539d083ce8f3a26e51392b53d1298255cdb82bfe4a67cd32ab16
+SIZE (subversion/ch02dia1.png) = 2544
+MD5 (subversion/ch02dia2.png) = 4c3e6e55f9a0c50d6925f5ca4587e47b
+SHA256 (subversion/ch02dia2.png) = 140e3517a6f770a5b12d4bd598171b8d4ea3a12edea1cc2f161dfda3bbd88a8b
+SIZE (subversion/ch02dia2.png) = 11754
+MD5 (subversion/ch02dia3.png) = e9cd778666a999ab329a069efed37500
+SHA256 (subversion/ch02dia3.png) = ede7d162f22e208b61f1350f923c2db10e8df73b0b7895d8619a5512640a7f86
+SIZE (subversion/ch02dia3.png) = 14307
+MD5 (subversion/ch02dia5.png) = f4ec352cd843cf130fe500cfdbc358ca
+SHA256 (subversion/ch02dia5.png) = bb0a96acc02c877b5129cce42feccec7287b226db474f5726551881571e1608c
+SIZE (subversion/ch02dia5.png) = 12176
+MD5 (subversion/ch02dia6.png) = d4eac305c63464419d945a616284c4ce
+SHA256 (subversion/ch02dia6.png) = 8a3b9952ad43945063faeb7c02b476ebde1b1095f7418073637b9ca22613019e
+SIZE (subversion/ch02dia6.png) = 4023
+MD5 (subversion/ch02dia7.png) = 067bb47f6fe3dcdeefac6755da876cdf
+SHA256 (subversion/ch02dia7.png) = 8d14d9d5634e2bcaa839a96295cbd351b366bd20cf84d09b14d6870248bf5a7e
+SIZE (subversion/ch02dia7.png) = 5495
+MD5 (subversion/ch04dia1.png) = a157a2c9fc737cab3db918aaf489bf7e
+SHA256 (subversion/ch04dia1.png) = 8af0c00ca180323ab6a343579400d40f804104d5d9524db477bec2e4d1be5a58
+SIZE (subversion/ch04dia1.png) = 2713
+MD5 (subversion/ch04dia2.png) = 5c6b571282ff05d99a99d69fdef50378
+SHA256 (subversion/ch04dia2.png) = c007babb6fcb339e741ee241c987375dc216cd2355c21edcdc68b49c8e346d47
+SIZE (subversion/ch04dia2.png) = 4127
+MD5 (subversion/ch04dia3.png) = 7226def64bf6dea42b547d968b853a08
+SHA256 (subversion/ch04dia3.png) = 258d1fd04ea2d2ec9ed6943130d802ffa28bffb066a9fba3ca78ea593fa7e4d3
+SIZE (subversion/ch04dia3.png) = 6537
+MD5 (subversion/ch04dia4.png) = 03cbad24eee5abe0cadc452be19c2613
+SHA256 (subversion/ch04dia4.png) = fbe91cc08a34630929bc9608d0121041c3135b9afcfe513e0fa1665e2cda7cdc
+SIZE (subversion/ch04dia4.png) = 3849
+MD5 (subversion/ch08dia1.png) = 870a5b07012b21f7b187fdb1d912d8d6
+SHA256 (subversion/ch08dia1.png) = 6217bba808c33d80ce2be59e4972d5387de267d21a4e7e96c79bab05d84320da
+SIZE (subversion/ch08dia1.png) = 2644
+MD5 (subversion/ch08dia2.png) = a72633f0cc8f6f83fa4d8a96b47202ca
+SHA256 (subversion/ch08dia2.png) = da286b9a8cd3224226d28b9662904ef2c362cf56dbec23a2f119e96e9fd36daf
+SIZE (subversion/ch08dia2.png) = 3910
+MD5 (subversion/svn-book.pdf) = 37ecce7fa958e320b9b7e09edc2e2d46
+SHA256 (subversion/svn-book.pdf) = 43e226b7210b71a1220e60ac425412405a184767ee363960ef3c4464605947d2
+SIZE (subversion/svn-book.pdf) = 1336362
diff --git a/devel/subversion-freebsd/files/patch-ac-helpers::ltmain.sh b/devel/subversion-freebsd/files/patch-build--ltmain.sh
index 66f0c795aa35..1e37810f843c 100644
--- a/devel/subversion-freebsd/files/patch-ac-helpers::ltmain.sh
+++ b/devel/subversion-freebsd/files/patch-build--ltmain.sh
@@ -1,5 +1,5 @@
---- ac-helpers/ltmain.sh.orig Fri May 20 21:41:54 2005
-+++ ac-helpers/ltmain.sh Wed May 25 14:38:21 2005
+--- build/ltmain.sh.orig Fri May 20 21:41:54 2005
++++ build/ltmain.sh Wed May 25 14:38:21 2005
@@ -1492,7 +1492,7 @@
# These systems don't actually have a C library (as such)
test "X$arg" = "X-lc" && continue
diff --git a/devel/subversion-freebsd/files/patch-build-outputs.mk b/devel/subversion-freebsd/files/patch-build-outputs.mk
new file mode 100644
index 000000000000..f142bc22199f
--- /dev/null
+++ b/devel/subversion-freebsd/files/patch-build-outputs.mk
@@ -0,0 +1,11 @@
+--- build-outputs.mk.orig Tue Sep 12 15:16:30 2006
++++ build-outputs.mk Tue Sep 12 15:17:04 2006
+@@ -32,7 +32,7 @@
+
+ TEST_PROGRAMS = subversion/tests/libsvn_subr/compat-test$(EXEEXT) subversion/tests/libsvn_subr/config-test$(EXEEXT) subversion/tests/libsvn_diff/diff-diff3-test$(EXEEXT) subversion/tests/libsvn_fs/fs-test$(EXEEXT) subversion/tests/libsvn_subr/hashdump-test$(EXEEXT) subversion/tests/libsvn_fs/locks-test$(EXEEXT) subversion/tests/libsvn_subr/opt-test$(EXEEXT) subversion/tests/libsvn_subr/path-test$(EXEEXT) subversion/tests/libsvn_ra_local/ra-local-test$(EXEEXT) subversion/tests/libsvn_delta/random-test$(EXEEXT) subversion/tests/libsvn_repos/repos-test$(EXEEXT) subversion/tests/libsvn_subr/stream-test$(EXEEXT) subversion/tests/libsvn_subr/string-test$(EXEEXT) subversion/tests/libsvn_subr/time-test$(EXEEXT) subversion/tests/libsvn_wc/translate-test$(EXEEXT) subversion/tests/libsvn_subr/utf-test$(EXEEXT) subversion/tests/libsvn_subr/target-test.py subversion/tests/cmdline/getopt_tests.py subversion/tests/cmdline/basic_tests.py subversion/tests/cmdline/commit_tests.py subversion/tests/cmdline/update_tests.py subversion/tests/cmdline/switch_tests.py subversion/tests/cmdline/prop_tests.py subversion/tests/cmdline/schedule_tests.py subversion/tests/cmdline/log_tests.py subversion/tests/cmdline/copy_tests.py subversion/tests/cmdline/diff_tests.py subversion/tests/cmdline/export_tests.py subversion/tests/cmdline/externals_tests.py subversion/tests/cmdline/merge_tests.py subversion/tests/cmdline/revert_tests.py subversion/tests/cmdline/stat_tests.py subversion/tests/cmdline/trans_tests.py subversion/tests/cmdline/autoprop_tests.py subversion/tests/cmdline/blame_tests.py subversion/tests/cmdline/special_tests.py subversion/tests/cmdline/svnadmin_tests.py subversion/tests/cmdline/svnlook_tests.py subversion/tests/cmdline/svnversion_tests.py subversion/tests/cmdline/utf8_tests.py subversion/tests/cmdline/history_tests.py subversion/tests/cmdline/lock_tests.py subversion/tests/cmdline/cat_tests.py subversion/tests/cmdline/import_tests.py subversion/tests/cmdline/svnsync_tests.py subversion/tests/cmdline/authz_tests.py
+
+-MANPAGES = subversion/svn/svn.1 subversion/svnadmin/svnadmin.1 subversion/svndumpfilter/svndumpfilter.1 subversion/svnlook/svnlook.1 subversion/svnserve/svnserve.8 subversion/svnserve/svnserve.conf.5 subversion/svnversion/svnsync.1 subversion/svnversion/svnversion.1
++MANPAGES = subversion/svn/svn.1 subversion/svnadmin/svnadmin.1 subversion/svndumpfilter/svndumpfilter.1 subversion/svnlook/svnlook.1 subversion/svnserve/svnserve.8 subversion/svnserve/svnserve.conf.5 subversion/svnsync/svnsync.1 subversion/svnversion/svnversion.1
+
+ CLEAN_FILES = contrib/client-side/mucc$(EXEEXT) contrib/client-side/svn-push/svn-push$(EXEEXT) subversion/svn/svn$(EXEEXT) subversion/svnadmin/svnadmin$(EXEEXT) subversion/svndumpfilter/svndumpfilter$(EXEEXT) subversion/svnlook/svnlook$(EXEEXT) subversion/svnserve/svnserve$(EXEEXT) subversion/svnsync/svnsync$(EXEEXT) subversion/svnversion/svnversion$(EXEEXT) subversion/tests/libsvn_delta/random-test$(EXEEXT) subversion/tests/libsvn_delta/svndiff-test$(EXEEXT) subversion/tests/libsvn_delta/vdelta-test$(EXEEXT) subversion/tests/libsvn_diff/diff-diff3-test$(EXEEXT) subversion/tests/libsvn_fs/fs-test$(EXEEXT) subversion/tests/libsvn_fs/locks-test$(EXEEXT) subversion/tests/libsvn_fs_base/changes-test$(EXEEXT) subversion/tests/libsvn_fs_base/fs-base-test$(EXEEXT) subversion/tests/libsvn_fs_base/key-test$(EXEEXT) subversion/tests/libsvn_fs_base/skel-test$(EXEEXT) subversion/tests/libsvn_fs_base/strings-reps-test$(EXEEXT) subversion/tests/libsvn_ra_local/ra-local-test$(EXEEXT) subversion/tests/libsvn_repos/repos-test$(EXEEXT) subversion/tests/libsvn_subr/compat-test$(EXEEXT) subversion/tests/libsvn_subr/config-test$(EXEEXT) subversion/tests/libsvn_subr/hashdump-test$(EXEEXT) subversion/tests/libsvn_subr/opt-test$(EXEEXT) subversion/tests/libsvn_subr/path-test$(EXEEXT) subversion/tests/libsvn_subr/stream-test$(EXEEXT) subversion/tests/libsvn_subr/string-test$(EXEEXT) subversion/tests/libsvn_subr/target-test$(EXEEXT) subversion/tests/libsvn_subr/time-test$(EXEEXT) subversion/tests/libsvn_subr/utf-test$(EXEEXT) subversion/tests/libsvn_wc/translate-test$(EXEEXT) tools/diff/diff$(EXEEXT) tools/diff/diff3$(EXEEXT) tools/diff/diff4$(EXEEXT) tools/server-side/svnauthz-validate$(EXEEXT)
+
diff --git a/devel/subversion-freebsd/files/patch-configure b/devel/subversion-freebsd/files/patch-configure
index f4507ca50d20..75cc48429c03 100644
--- a/devel/subversion-freebsd/files/patch-configure
+++ b/devel/subversion-freebsd/files/patch-configure
@@ -1,7 +1,7 @@
---- configure.orig Tue Jun 6 20:18:54 2006
-+++ configure Tue Jun 6 20:19:34 2006
-@@ -18861,7 +18861,7 @@
- if test "$NEON_VERSION" = "$svn_allowed_neon" -o $svn_allowed_neon = "any"; then
+--- configure.orig Fri Sep 8 03:22:11 2006
++++ configure Tue Sep 12 13:41:03 2006
+@@ -3997,7 +3997,7 @@
+ test "$svn_allowed_neon" = "any"; then
svn_allowed_neon_on_system="yes"
SVN_NEON_INCLUDES=`$neon_config --cflags | sed -e 's/-D[^ ]*//g'`
- NEON_LIBS=`$neon_config --la-file`
@@ -9,8 +9,8 @@
CFLAGS="$CFLAGS `$neon_config --cflags | sed -e 's/-I[^ ]*//g'`"
svn_lib_neon="yes"
break
-@@ -19184,7 +19184,7 @@
- if test "$NEON_VERSION" = "$svn_allowed_neon" -o $svn_allowed_neon = "any"; then
+@@ -4324,7 +4324,7 @@
+ test "$svn_allowed_neon" = "any"; then
svn_allowed_neon_on_system="yes"
SVN_NEON_INCLUDES=`$neon_config --cflags | sed -e 's/-D[^ ]*//g'`
- NEON_LIBS=`$neon_config --la-file`
diff --git a/devel/subversion-freebsd/files/patch-contrib--client-side--asvn b/devel/subversion-freebsd/files/patch-contrib--client-side--asvn
index 07f339d29ed5..c8be147d7d77 100644
--- a/devel/subversion-freebsd/files/patch-contrib--client-side--asvn
+++ b/devel/subversion-freebsd/files/patch-contrib--client-side--asvn
@@ -1,14 +1,12 @@
--- contrib/client-side/asvn.orig Tue Jun 15 06:02:44 2004
-+++ contrib/client-side/asvn Thu May 18 16:05:43 2006
-@@ -36,6 +36,7 @@
- #
- #
++++ contrib/client-side/asvn Mon Sep 11 17:07:04 2006
+@@ -1,4 +1,4 @@
+-#!/bin/bash
++#!/usr/local/bin/bash
#-------------------------------------------------------------------------
-+EDITOR?=vi
- SVN=/usr/local/bin/svn
- ACTION=""
- DEV_PROP="dir:devices"
-@@ -46,7 +47,7 @@
+ # Author: Ross Mark (rossm@controllingedge.com.au)
+ # Date: Tue Mar 11 10:02:57 EST 2003
+@@ -46,7 +46,7 @@
TMPFILE2=/tmp/asvn.tmp2.$$
PCWD=`/bin/pwd`
SKIPSVN='\( -name .svn -prune -false \)'
@@ -17,27 +15,91 @@
trap cleanup 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20
-@@ -105,7 +106,7 @@
+@@ -58,7 +58,8 @@
+ function basedirname()
+ {
+ refname="$1"
+- dir="`dirname $2`"
++ shift
++ dir="`dirname \"$*\"`"
+ ref=`expr "$dir" : "$refname/\(.*\)"`
+ if [ -z "$ref" ]
+ then
+@@ -105,10 +106,10 @@
function recorddirinfo
{
- eval "find $PCWD $SKIPSVN -o \( -type d ! -name .svn -print \)" |while read dirlist
-+ eval "gfind $PCWD $SKIPSVN -o \( -type d ! -name .svn -print \)" |while read dirlist
++ eval "gfind \"$PCWD\" $SKIPSVN -o \( -type d ! -name .svn -print \)" |while read dirlist
do
- updatedirsymlinks $1 $dirlist
- updatedirdevices $1 $dirlist
-@@ -126,9 +127,9 @@
+- updatedirsymlinks $1 $dirlist
+- updatedirdevices $1 $dirlist
++ updatedirsymlinks $1 "$dirlist"
++ updatedirdevices $1 "$dirlist"
+ done
+ }
+
+@@ -126,15 +127,15 @@
#
# Obtain the list of devices in this directory
#
- find "$dir" \( \( -type b -o -type c -o -type p \) -print \) -o -type d ! -name "`basename $dir`" -prune | while read file
-+ gfind "$dir" \( \( -type b -o -type c -o -type p \) -print \) -o -type d ! -name "`basename $dir`" -prune | while read file
++ gfind "$dir" \( \( -type b -o -type c -o -type p \) -print \) -o -type d ! -name "`basename \"$dir\"`" -prune | while read file
do
- echo -n `find $file -printf "file='%f' mode=%m user=%u(%U) group=%g(%G)"`
-+ echo -n `gfind $file -printf "file='%f' mode=%m user=%u(%U) group=%g(%G)"`
- [ -b $file ] && echo -n ' type=b'
- [ -c $file ] && echo -n ' type=c'
- [ -p $file ] && echo ' type=p'
+- [ -b $file ] && echo -n ' type=b'
+- [ -c $file ] && echo -n ' type=c'
+- [ -p $file ] && echo ' type=p'
+- if [ -b $file -o -c $file ]
++ echo -n `gfind "$file" -printf "file='%f' mode=%m user=%u(%U) group=%g(%G)"`
++ [ -b "$file" ] && echo -n ' type=b'
++ [ -c "$file" ] && echo -n ' type=c'
++ [ -p "$file" ] && echo ' type=p'
++ if [ -b "$file" -o -c "$file" ]
+ then
+- ls -l $file |
++ ls -l "$file" |
+ sed -e 's/^[-lcpbrdwxXstugoTS]* *[0-9] [^ ]* *[^ ]* *\([0-9]*\), *\([0-9]*\) .*/ major=\1 minor=\2/'
+ fi
+ # In this case file is the full path.
+@@ -145,7 +146,7 @@
+ #
+ # Obtain the currently defined devices
+ #
+- $SVN propget $DEV_PROP $dir >$TMPFILE1
++ $SVN propget $DEV_PROP "$dir" >$TMPFILE1
+
+ #
+ # If the two list are the same then there is nothing to do.
+@@ -161,7 +162,7 @@
+ if [ "$CHECKIN" = "true" ]
+ then
+ # Add the current devices to the property
+- $SVN propset $DEV_PROP $dir -F $TMPFILE
++ $SVN propset $DEV_PROP "$dir" -F $TMPFILE
+ else
+ # Delete all the unwanted devices ie not in TMPFILE1
+ cat $TMPFILE |while read line
+@@ -169,8 +170,8 @@
+ file=`expr "$line" : "file='\(.*\)' mode"`
+ if ! grep -q "file='$file'" $TMPFILE1
+ then
+- rm $file
+- deleteignorefile $file
++ rm "$file"
++ deleteignorefile "$file"
+ fi
+ done
+ fi
+@@ -178,7 +179,7 @@
+ # There are no devices in this directory
+ if [ "$CHECKIN" = "true" ]
+ then
+- $SVN propdel $DEV_PROP $dir
++ $SVN propdel $DEV_PROP "$dir"
+ fi
+ fi
+
@@ -194,10 +195,10 @@
grep -q "$info" $TMPFILE && continue # This line still matches
file=`expr "$info" : "file='\(.*\)' "`
@@ -53,51 +115,101 @@
type=`expr "$info" : ".* type=\(.\)"`
major=`expr "$info" : ".* major=\([0-9]*\)"`
minor=`expr "$info" : ".* minor=\([0-9]*\)"`
-@@ -207,7 +208,8 @@
+@@ -205,10 +206,11 @@
+ # This file is either missing or wrong
+ # Delete the old and create it anew.
#
- rm -f $dir/$file
- mknod --mode=$mode $dir/$file $type $major $minor
+- rm -f $dir/$file
+- mknod --mode=$mode $dir/$file $type $major $minor
- chown $user:$group $dir/$file
+- addignorefile $dir/$file
++ rm -f "$dir/$file"
++ mknod --mode=$mode "$dir/$file" $type $major $minor
+# chown $user:$group $dir/$file
-+ chown $uid:$gid $dir/$file
- addignorefile $dir/$file
++ chown $uid:$gid "$dir/$file"
++ addignorefile "$dir/$file"
done
fi
+ }
@@ -228,7 +230,7 @@
#
# Obtain the list of symlinks in this directory
#
- find "$dir" \( -type l -printf "file='%f' dest='%l'\n" \) -o -type d ! -name "`basename $dir`" -prune |
-+ gfind "$dir" \( -type l -printf "file='%f' dest='%l'\n" \) -o -type d ! -name "`basename $dir`" -prune |
++ gfind "$dir" \( -type l -printf "file='%f' dest='%l'\n" \) -o -type d ! -name "`basename \"$dir\"`" -prune |
sort >$TMPFILE
#
-@@ -294,7 +296,7 @@
+@@ -243,7 +245,7 @@
+ #
+ # Obtain the currently defined symlinks
+ #
+- $SVN propget $SYM_PROP $dir >$TMPFILE1
++ $SVN propget $SYM_PROP "$dir" >$TMPFILE1
+
+ #
+ # If the two list are the same then there is nothing to do.
+@@ -259,7 +261,7 @@
+ if [ "$CHECKIN" = "true" ]
+ then
+ # Add the current symlinks to the property
+- $SVN propset $SYM_PROP $dir -F $TMPFILE
++ $SVN propset $SYM_PROP "$dir" -F $TMPFILE
+ else
+ # Delete all the unwanted symlinks
+ cat $TMPFILE |while read line
+@@ -268,8 +270,8 @@
+ efile="`echo $file |sed -e 's!\([\[\(\$]\)!\\\\\1!g'`"
+ if ! grep -q "file='$efile'" $TMPFILE1
+ then
+- rm $dir/$file
+- deleteignorefile $dir/$file
++ rm "$dir/$file"
++ deleteignorefile "$dir/$file"
+ fi
+ done
+ fi
+@@ -277,7 +279,7 @@
+ # There are no symlinks in this directory
+ if [ "$CHECKIN" = "true" ]
+ then
+- $SVN propdel $SYM_PROP $dir
++ $SVN propdel $SYM_PROP "$dir"
+ fi
+ fi
+
+@@ -294,10 +296,10 @@
if [ -L $dir/$file ]
then
- [ "`find $dir/$file -printf '%l'`" = "$dest" ] && continue
-+ [ "`gfind $dir/$file -printf '%l'`" = "$dest" ] && continue
++ [ "`gfind \"$dir/$file\" -printf '%l'`" = "$dest" ] && continue
fi
- rm -f $dir/$file
- ln -s $dest $dir/$file
+- rm -f $dir/$file
+- ln -s $dest $dir/$file
++ rm -f "$dir/$file"
++ ln -s $dest "$dir/$file"
+ done
+ fi
+ }
@@ -313,37 +315,39 @@
# Find all the directories and files
cp /dev/null $TMPFILE
- eval "find $PCWD $SKIPSVN -o \( \( -type d ! -name .svn \) -o -type f \) $PRINTDETAILS" | while read info
-+ eval "gfind $PCWD $SKIPSVN -o \( \( -type d ! -name .svn \) -o -type f \) $PRINTDETAILS" | while read info
++ eval "gfind \"$PCWD\" $SKIPSVN -o \( \( -type d ! -name .svn \) -o -type f \) $PRINTDETAILS" | while read info
do
device=`expr "$info" : "file='\(.*\)' mode"`
info=`expr "$info" : "file='.*' \(mode.*\)"`
-+ #echo DEBUG: device vale $device
++# echo DEBUG: device vale $device
if [ "$PCWD" = "$device" ]
then
dir="."
file=""
else
- dir="`basedirname $PCWD $device`"
+- dir="`basedirname $PCWD $device`"
- file="`basename $device`"
++ dir="`basedirname \"$PCWD\" $device`"
+ file=`basename "$device"`
fi
# see if the properties have changed.
@@ -144,3 +256,12 @@
fi
recorddirinfo
recordpermissions
+@@ -382,7 +387,7 @@
+
+ [ "$ACTION" = "pre" ] && pre_checkin $@
+
+-$SVN $@
++$SVN "$@"
+
+ [ $? = 0 -a "$ACTION" = "post" ] && post_checkout $@
+
diff --git a/devel/subversion-freebsd/pkg-plist b/devel/subversion-freebsd/pkg-plist
index 1341f6223109..e0a7d65283da 100644
--- a/devel/subversion-freebsd/pkg-plist
+++ b/devel/subversion-freebsd/pkg-plist
@@ -4,6 +4,7 @@ bin/svnadmin
bin/svndumpfilter
bin/svnlook
bin/svnserve
+bin/svnsync
%%ASVN%%bin/asvn
%%SVNSERVE_WRAPPER%%bin/svnserve.bin
bin/svnversion
@@ -18,6 +19,7 @@ include/subversion-1/svn_ctype.h
include/subversion-1/svn_dav.h
include/subversion-1/svn_delta.h
include/subversion-1/svn_diff.h
+include/subversion-1/svn_dso.h
include/subversion-1/svn_error.h
include/subversion-1/svn_error_codes.h
include/subversion-1/svn_fs.h
@@ -38,6 +40,7 @@ include/subversion-1/svn_string.h
include/subversion-1/svn_subst.h
include/subversion-1/svn_time.h
include/subversion-1/svn_types.h
+include/subversion-1/svn_user.h
include/subversion-1/svn_utf.h
include/subversion-1/svn_version.h
include/subversion-1/svn_wc.h
@@ -107,11 +110,13 @@ lib/libsvn_wc-1.so.0
%%WITHOUT_GETTEXT%%share/locale/sv/LC_MESSAGES/subversion.mo
%%WITHOUT_GETTEXT%%share/locale/zh_CN/LC_MESSAGES/subversion.mo
%%WITHOUT_GETTEXT%%share/locale/zh_TW/LC_MESSAGES/subversion.mo
+%%DATADIR%%/README
%%DATADIR%%/backup/hot-backup.py
%%DATADIR%%/bdb/erase-all-text-data.py
%%DATADIR%%/bdb/skel.py
%%DATADIR%%/bdb/svn-bdb-view.py
%%DATADIR%%/bdb/svnfs.py
+%%DATADIR%%/bdb/whatis-rep.py
%%DATADIR%%/client-side/bash_completion
%%DATADIR%%/client-side/bash_completion_test
%%DATADIR%%/client-side/server-vsn.py
@@ -120,10 +125,10 @@ lib/libsvn_wc-1.so.0
%%DATADIR%%/dev/check-license.py
%%DATADIR%%/dev/datecheck.py
%%DATADIR%%/dev/contribulyze.py
-%%DATADIR%%/dev/find-textfiles.sh
%%DATADIR%%/dev/gcov.patch
%%DATADIR%%/dev/getsigs.pl
%%DATADIR%%/dev/gnuify-changelog.pl
+%%DATADIR%%/dev/graph-dav-servers.py
%%DATADIR%%/dev/iz/defect.dem
%%DATADIR%%/dev/iz/ff2csv.command
%%DATADIR%%/dev/iz/ff2csv.py
@@ -142,6 +147,7 @@ lib/libsvn_wc-1.so.0
%%DATADIR%%/dev/svn-merge-revs.py
%%DATADIR%%/dev/trails.py
%%DATADIR%%/dev/verify-history.py
+%%DATADIR%%/dev/warn-ignored-err.sh
%%DATADIR%%/dev/which-error.py
%%DATADIR%%/diff/diff.c
%%DATADIR%%/diff/diff3.c
@@ -156,32 +162,50 @@ lib/libsvn_wc-1.so.0
%%DATADIR%%/examples/minimal_client.c
%%DATADIR%%/examples/putfile.py
%%DATADIR%%/examples/revplist.py
+%%DATADIR%%/examples/svnlog2html.rb
%%DATADIR%%/examples/svnlook.py
%%DATADIR%%/examples/svnlook.rb
%%DATADIR%%/examples/svnput.c
%%DATADIR%%/examples/svnserve-sgid.c
%%DATADIR%%/examples/svnshell.py
%%DATADIR%%/examples/svnshell.rb
+%%DATADIR%%/examples/testwrite.c
%%DATADIR%%/hook-scripts/commit-access-control.cfg.example
%%DATADIR%%/hook-scripts/commit-access-control.pl
%%DATADIR%%/hook-scripts/commit-email.pl
%%DATADIR%%/hook-scripts/commit-email.rb
+%%DATADIR%%/hook-scripts/log-police.py
%%DATADIR%%/hook-scripts/mailer/mailer.conf.example
%%DATADIR%%/hook-scripts/mailer/mailer.py
%%DATADIR%%/hook-scripts/mailer/tests/mailer-init.sh
%%DATADIR%%/hook-scripts/mailer/tests/mailer-t1.output
%%DATADIR%%/hook-scripts/mailer/tests/mailer-t1.sh
%%DATADIR%%/hook-scripts/mailer/tests/mailer-tweak.py
-%%DATADIR%%/hook-scripts/propchange-email.pl
%%DATADIR%%/hook-scripts/README
%%DATADIR%%/hook-scripts/svnperms.conf.example
%%DATADIR%%/hook-scripts/svnperms.py
%%DATADIR%%/hook-scripts/verify-po.py
+%%DATADIR%%/po/po-update.sh
%%DATADIR%%/po/svn-po-status-report.sh
%%DATADIR%%/po/svn-po-status-run.sh
+%%DATADIR%%/server-side/svn-backup-dumps.py
%%DATADIR%%/server-side/svnauthz-validate.c
%%DATADIR%%/test-scripts/svntest/README
%%DATADIR%%/test-scripts/svntest/dav_svn.passwd
+%%DATADIR%%/test-scripts/svntest/encode-base64.py
+%%DATADIR%%/test-scripts/svntest/examples/debian-gnulinux-shared/config.apr-0.9
+%%DATADIR%%/test-scripts/svntest/examples/debian-gnulinux-shared/config.apr-0.9.x
+%%DATADIR%%/test-scripts/svntest/examples/debian-gnulinux-shared/config.apr-util-0.9
+%%DATADIR%%/test-scripts/svntest/examples/debian-gnulinux-shared/config.httpd-2.0
+%%DATADIR%%/test-scripts/svntest/examples/debian-gnulinux-shared/config.shared
+%%DATADIR%%/test-scripts/svntest/examples/debian-gnulinux-shared/dav_svn.passwd
+%%DATADIR%%/test-scripts/svntest/examples/debian-gnulinux-shared/httpd-2.0.conf
+%%DATADIR%%/test-scripts/svntest/examples/debian-gnulinux-shared/mod_dav_svn.conf
+%%DATADIR%%/test-scripts/svntest/examples/solaris-7-static/config.apr-0.9
+%%DATADIR%%/test-scripts/svntest/examples/solaris-7-static/config.apr-util-0.9
+%%DATADIR%%/test-scripts/svntest/examples/solaris-7-static/config.httpd-2.0
+%%DATADIR%%/test-scripts/svntest/examples/solaris-7-static/config.solaris.static
+%%DATADIR%%/test-scripts/svntest/examples/solaris-7-static/dav_svn.passwd
%%DATADIR%%/test-scripts/svntest/mod_dav_svn.conf
%%DATADIR%%/test-scripts/svntest/svntest-bindings.sh
%%DATADIR%%/test-scripts/svntest/svntest-bindings-generic.sh
@@ -351,6 +375,9 @@ lib/libsvn_wc-1.so.0
@dirrm %%DATADIR%%/hook-scripts
@dirrm %%DATADIR%%/po
@dirrm %%DATADIR%%/server-side
+@dirrm %%DATADIR%%/test-scripts/svntest/examples/debian-gnulinux-shared
+@dirrm %%DATADIR%%/test-scripts/svntest/examples/solaris-7-static
+@dirrm %%DATADIR%%/test-scripts/svntest/examples
@dirrm %%DATADIR%%/test-scripts/svntest
@dirrm %%DATADIR%%/test-scripts
@dirrm %%DATADIR%%/xslt