aboutsummaryrefslogtreecommitdiff
path: root/devel/subversion/Makefile.common
diff options
context:
space:
mode:
authorSergey Skvortsov <skv@FreeBSD.org>2010-02-10 14:47:58 +0000
committerSergey Skvortsov <skv@FreeBSD.org>2010-02-10 14:47:58 +0000
commit2559330d73bfe215ead0fbd09ef94ea8e723cb33 (patch)
treeff0b1dc77f0be1a5b68c1afc0ad6b1b1ae14cc1f /devel/subversion/Makefile.common
parent3ea7dc64f51cdfed683205a9fe5a356a15bf0258 (diff)
downloadports-2559330d73bfe215ead0fbd09ef94ea8e723cb33.tar.gz
ports-2559330d73bfe215ead0fbd09ef94ea8e723cb33.zip
Notes
Diffstat (limited to 'devel/subversion/Makefile.common')
-rw-r--r--devel/subversion/Makefile.common14
1 files changed, 9 insertions, 5 deletions
diff --git a/devel/subversion/Makefile.common b/devel/subversion/Makefile.common
index 8fee8a454ca1..d25c6d66331b 100644
--- a/devel/subversion/Makefile.common
+++ b/devel/subversion/Makefile.common
@@ -5,8 +5,8 @@
# $FreeBSD$
PORTNAME= subversion
-PORTVERSION= 1.6.6
-PORTREVISION?= 1
+PORTVERSION= 1.6.9
+#PORTREVISION?= 1
CATEGORIES+= devel
MASTER_SITES= http://subversion.tigris.org/downloads/:main \
http://svnbook.red-bean.com/en/1.5/:book
@@ -35,9 +35,13 @@ CONFIGURE_ARGS+= --with-sqlite=${LOCALBASE}
# Default is "on"
.if !defined(WITHOUT_NEON)
-LIB_DEPENDS+= neon.28:${PORTSDIR}/www/neon28
-CONFIGURE_ARGS+= --with-neon=${LOCALBASE}
-PLIST_SUB+= NEON=""
+.if exists(${LOCALBASE}/bin/neon-config)
+NEON_VER!= ${LOCALBASE}/bin/neon-config --version | \
+ ${SED} -n -E 's/^neon [0-9]+\.([0-9]+)\..*$$/\1/p'
+.else
+NEON_VER= 29
+.endif
+LIB_DEPENDS+= neon.${NEON_VER}:${PORTSDIR}/www/neon${NEON_VER}
.else
CONFIGURE_ARGS+= --without-neon
PLIST_SUB+= NEON="@comment "