aboutsummaryrefslogtreecommitdiff
path: root/devel/subversion16/Makefile.common
diff options
context:
space:
mode:
authorAlberto Villa <avilla@FreeBSD.org>2011-04-01 15:19:58 +0000
committerAlberto Villa <avilla@FreeBSD.org>2011-04-01 15:19:58 +0000
commit990c4a7b757809c1d1b3d00db4fc8e6a2113a0dd (patch)
tree8a7ebb74638acd25bca5f87307b2ae381778ff5d /devel/subversion16/Makefile.common
parent8de0e51049d3ac37340208fb092203eea055a6aa (diff)
Notes
Diffstat (limited to 'devel/subversion16/Makefile.common')
-rw-r--r--devel/subversion16/Makefile.common14
1 files changed, 13 insertions, 1 deletions
diff --git a/devel/subversion16/Makefile.common b/devel/subversion16/Makefile.common
index 5f19d7112437..eccc9ed7e8fd 100644
--- a/devel/subversion16/Makefile.common
+++ b/devel/subversion16/Makefile.common
@@ -6,7 +6,7 @@
PORTNAME= subversion
PORTVERSION= 1.6.16
-PORTREVISION?= 0
+PORTREVISION?= 1
CATEGORIES+= devel
MASTER_SITES= http://subversion.tigris.org/downloads/:main \
http://svnbook.red-bean.com/en/1.5/:book
@@ -24,6 +24,7 @@ PATCHFILES+= svn_hacks_1.4.diff
MAKE_JOBS_SAFE= yes
USE_BZIP2= yes
USE_AUTOTOOLS= libtool
+USE_KDE4= # Used below if KWallet support is enabled
CONFIGURE_ARGS= --with-ssl
@@ -161,8 +162,19 @@ PLIST_SUB+= DYNAMIC_ENABLED=""
.if defined(WITH_GNOME_KEYRING)
LIB_DEPENDS+= gnome-keyring.0:${PORTSDIR}/security/gnome-keyring
CONFIGURE_ARGS+=--with-gnome-keyring
+PLIST_SUB+= GNOME_KEYRING=""
.else
CONFIGURE_ARGS+=--without-gnome-keyring
+PLIST_SUB+= GNOME_KEYRING="@comment "
+.endif
+
+.if defined(WITH_KDE_KWALLET)
+USE_KDE4= kdelibs
+CONFIGURE_ARGS+=--with-kwallet=${KDE4_PREFIX}
+PLIST_SUB+= KDE_KWALLET=""
+.else
+CONFIGURE_ARGS+=--without-kwallet
+PLIST_SUB+= KDE_KWALLET="@comment "
.endif
post-extract: