aboutsummaryrefslogtreecommitdiff
path: root/devel/subversion16/Makefile.common
diff options
context:
space:
mode:
authorLev A. Serebryakov <lev@FreeBSD.org>2010-07-07 14:42:53 +0000
committerLev A. Serebryakov <lev@FreeBSD.org>2010-07-07 14:42:53 +0000
commit1bf7642bdd7f11f0f13fe960b3b5a7bb0a483468 (patch)
treed6594e697496793ec1c01fd892477c10847819a0 /devel/subversion16/Makefile.common
parent32b6d40b36a40e91084e9830193d52d69eb3b6f8 (diff)
Notes
Diffstat (limited to 'devel/subversion16/Makefile.common')
-rw-r--r--devel/subversion16/Makefile.common14
1 files changed, 8 insertions, 6 deletions
diff --git a/devel/subversion16/Makefile.common b/devel/subversion16/Makefile.common
index b7aec91eb5e9..4c20203b9143 100644
--- a/devel/subversion16/Makefile.common
+++ b/devel/subversion16/Makefile.common
@@ -5,8 +5,8 @@
# $FreeBSD$
PORTNAME= subversion
-PORTVERSION= 1.6.11
-PORTREVISION?= 3
+PORTVERSION= 1.6.12
+PORTREVISION?= 0
CATEGORIES+= devel
MASTER_SITES= http://subversion.tigris.org/downloads/:main \
http://svnbook.red-bean.com/en/1.5/:book
@@ -43,17 +43,19 @@ CONFIGURE_ARGS+= --with-sqlite=${LOCALBASE}
# Default is "on"
.if !defined(WITHOUT_NEON)
+.if !defined(NEON_VER)
.if exists(${LOCALBASE}/bin/neon-config)
NEON_VER!= ${LOCALBASE}/bin/neon-config --version | \
${SED} -n -E 's/^neon [0-9]+\.([0-9]+)\..*$$/\1/p'
.else
-NEON_VER= 29
+NEON_VER= 29
+.endif
.endif
LIB_DEPENDS+= neon.${NEON_VER}:${PORTSDIR}/www/neon${NEON_VER}
-PLIST_SUB+= NEON=""
+PLIST_SUB+= NEON=""
.else
-CONFIGURE_ARGS+= --without-neon
-PLIST_SUB+= NEON="@comment "
+CONFIGURE_ARGS+=--without-neon
+PLIST_SUB+= NEON="@comment "
.endif
.if defined(WITH_SASL)