aboutsummaryrefslogtreecommitdiff
path: root/devel/subversion16/Makefile
diff options
context:
space:
mode:
authorWill Andrews <will@FreeBSD.org>2002-01-15 01:45:03 +0000
committerWill Andrews <will@FreeBSD.org>2002-01-15 01:45:03 +0000
commit54d616646b349e37b17ccd72e4fafb172fe974d1 (patch)
tree293ed3c59a03fbee4f90735b07226520fe82cac7 /devel/subversion16/Makefile
parentc9948e7561e2383cbbb3c0f47e52f860fd419686 (diff)
Add subversion r727, a version control system. This is a placebo until the
subversion developers decide they want to get subversion more exposure. So this port basically does nothing but point people at a location where they can get the maintainer's latest work. RESTRICTED is to keep it from being used anywhere, anyhow, and in any way, in addition to the other NO_*.
Notes
Notes: svn path=/head/; revision=53081
Diffstat (limited to 'devel/subversion16/Makefile')
-rw-r--r--devel/subversion16/Makefile44
1 files changed, 44 insertions, 0 deletions
diff --git a/devel/subversion16/Makefile b/devel/subversion16/Makefile
new file mode 100644
index 000000000000..e6c5ceb510ed
--- /dev/null
+++ b/devel/subversion16/Makefile
@@ -0,0 +1,44 @@
+# New ports collection makefile for: subversion
+# Date created: 10 September 2001
+# Whom: rooneg@electricjellyfish.net
+#
+# $FreeBSD$
+
+PORTNAME= subversion
+PORTVERSION= r727
+CATEGORIES= devel
+MASTER_SITES= # empty
+DISTFILES= # empty
+EXTRACT_ONLY= # empty
+
+MAINTAINER= rooneg@electricjellyfish.net
+
+NO_BUILD= nothing to build
+NO_INSTALL= nothing to install
+NO_CDROM= nothing to ship
+NO_PACKAGE= nothing to package here yet
+
+RESTRICTED= yes
+
+do-extract:
+ @${MKDIR} ${WRKDIR}
+ @${ECHO} "*************************************************************"
+ @${ECHO}
+ @${ECHO} "The current release of the FreeBSD port of Subversion is"
+ @${ECHO} "available from http://electricjellyfish.net/subversion.tar.gz"
+ @${ECHO} "and from the main Subversion svn repository at"
+ @${ECHO} "http://svn.collab.net/repos/svn. By request of its"
+ @${ECHO} "developers it is not being distributed with the ports tree"
+ @${ECHO} "until the project makes its first beta release."
+ @${ECHO}
+ @${ECHO} "THERE IS NOTHING TO BUILD HERE. USE THIS:"
+ @${ECHO}
+ @${ECHO} " http://electricjellyfish.net/subversion.tar.gz"
+ @${ECHO}
+ @${ECHO} "Check out Subversion's website too:"
+ @${ECHO}
+ @${ECHO} " http://subversion.tigris.org/"
+ @${ECHO}
+ @${ECHO} "*************************************************************"
+
+.include <bsd.port.mk>