aboutsummaryrefslogtreecommitdiff
path: root/devel/subversion16/Makefile
diff options
context:
space:
mode:
authorOllivier Robert <roberto@FreeBSD.org>2002-07-15 18:06:17 +0000
committerOllivier Robert <roberto@FreeBSD.org>2002-07-15 18:06:17 +0000
commit5b4bcd5f55702e84d858f9035642bdc1aa220a0a (patch)
treef6d7f02a31eb25a83caccd8660a5a758b024752a /devel/subversion16/Makefile
parenta01296839ae64d0aa154d7075f3af90841cff54d (diff)
downloadports-5b4bcd5f55702e84d858f9035642bdc1aa220a0a.tar.gz
ports-5b4bcd5f55702e84d858f9035642bdc1aa220a0a.zip
Notes
Diffstat (limited to 'devel/subversion16/Makefile')
-rw-r--r--devel/subversion16/Makefile18
1 files changed, 8 insertions, 10 deletions
diff --git a/devel/subversion16/Makefile b/devel/subversion16/Makefile
index 5ce054e8c62f..0cb992131d18 100644
--- a/devel/subversion16/Makefile
+++ b/devel/subversion16/Makefile
@@ -5,16 +5,16 @@
# $FreeBSD$
PORTNAME= subversion
-PORTVERSION= r1868 # 0.12.0
+PORTVERSION= r2376 # 0.13.2
CATEGORIES= devel
-MASTER_SITES= http://subversion.tigris.org/files/documents/15/196/
+MASTER_SITES= http://subversion.tigris.org/files/documents/15/340/
MAINTAINER= rooneg@electricjellyfish.net
LIB_DEPENDS= db4:${PORTSDIR}/databases/db4 \
neon.21:${PORTSDIR}/www/neon \
expat.2:${PORTSDIR}/textproc/expat2 \
- apr:${PORTSDIR}/devel/apr-devel
+ apr:${PORTSDIR}/devel/apr
RUN_DEPENDS= gdiff3:${PORTSDIR}/textproc/diffutils
BUILD_DEPENDS= gdiff3:${PORTSDIR}/textproc/diffutils
@@ -22,24 +22,22 @@ MAN1= svn.1
WRKSRC= ${WRKDIR}/subversion-${PORTVERSION}
GNU_CONFIGURE= yes
+USE_REINPLACE= yes
CONFIGURE_ARGS= --with-ssl \
--with-neon=${LOCALBASE} \
+ --with-berkeley-db=${LOCALBASE}/include/db4:${LOCALBASE}/lib \
--with-apr=${LOCALBASE} \
--with-apr-util=${LOCALBASE}
post-extract:
- # work around libdb4's name.
- @${PERL} -pi -e 's/ldb/ldb4/g' ${WRKSRC}/configure
+ @${REINPLACE_CMD} 's/ldb/ldb4/g' ${WRKSRC}/configure
- # axe the neon, apr, and apr-util subdirs to keep svn's build process
- # from using them, since we're providing our own.
@${RM} -r ${WRKSRC}/neon
@${RM} -r ${WRKSRC}/apr
@${RM} -r ${WRKSRC}/apr-util
post-configure:
- # make sure we don't install the swig stuff, even if it was found
- @${PERL} -pi -e 's/install-swig-py-lib//g' ${WRKSRC}/Makefile
- @${PERL} -pi -e 's/swig-py-lib//g' ${WRKSRC}/Makefile
+ @${REINPLACE_CMD} 's/install-swig-py-lib//g' ${WRKSRC}/Makefile
+ @${REINPLACE_CMD} 's/swig-py-lib//g' ${WRKSRC}/Makefile
.include <bsd.port.mk>