aboutsummaryrefslogtreecommitdiff
path: root/devel/subversion16
diff options
context:
space:
mode:
authorLev A. Serebryakov <lev@FreeBSD.org>2004-11-05 15:42:05 +0000
committerLev A. Serebryakov <lev@FreeBSD.org>2004-11-05 15:42:05 +0000
commit0c55337c2612ba6c0c869191e585f0bd94c8e6a0 (patch)
tree81faa392413316afcf32acd52b41e2210bd8205e /devel/subversion16
parent85fb473a05440f79c9b57bc97f67f022068aedf8 (diff)
downloadports-0c55337c2612ba6c0c869191e585f0bd94c8e6a0.tar.gz
ports-0c55337c2612ba6c0c869191e585f0bd94c8e6a0.zip
Notes
Diffstat (limited to 'devel/subversion16')
-rw-r--r--devel/subversion16/Makefile72
-rw-r--r--devel/subversion16/distinfo4
-rw-r--r--devel/subversion16/files/build-outputs.mk.patch20
-rw-r--r--devel/subversion16/files/patch-ac-helpers::ltmain.sh7
-rw-r--r--devel/subversion16/files/patch-configure14
-rw-r--r--devel/subversion16/files/patch-doc::book::Makefile (renamed from devel/subversion16/files/patch-book-Makefile)8
-rw-r--r--devel/subversion16/files/patch-subversion::bindings::swig::perl::Makefile.PL11
-rw-r--r--devel/subversion16/files/patch-subversion::bindings::swig::perl::natives::Base.pm10
-rw-r--r--devel/subversion16/files/patch-subversion::bindings::swig::perl::natives::Makefle.PL.in83
-rw-r--r--devel/subversion16/files/patch-svnperl-noruntime82
-rw-r--r--devel/subversion16/pkg-plist93
11 files changed, 255 insertions, 149 deletions
diff --git a/devel/subversion16/Makefile b/devel/subversion16/Makefile
index a751eb2b93dc..8de5b28a7abf 100644
--- a/devel/subversion16/Makefile
+++ b/devel/subversion16/Makefile
@@ -5,7 +5,7 @@
# $FreeBSD$
PORTNAME= subversion
-PORTVERSION= 1.0.8
+PORTVERSION= 1.1.1
CATEGORIES= devel
MASTER_SITES= http://subversion.tigris.org/tarballs/
@@ -64,6 +64,7 @@ MAN3= SVN::Base.3 \
SVN::Client.3 \
SVN::Core.3 \
SVN::Delta.3 \
+ SVN::Fs.3 \
SVN::Ra.3 \
SVN::Repos.3 \
SVN::Wc.3
@@ -80,13 +81,26 @@ PLIST_SUB+= WITH_PYTHON=""
PLIST_SUB+= WITH_PYTHON="@comment "
.endif
+#.if defined(WITH_JAVA)
+#USE_JAVA= yes
+#JAVA_VERSION= 1.2+
+#JAVA_OS= native
+#JAVA_BUILD= yes
+#JAVA_RUN= yes
+#.include "${PORTSDIR}/Mk/bsd.java.mk"
+#CONFIGURE_ARGS+= --enable-javahl --with-jdk=${JAVA_HOME}
+#PLIST_SUB+= WITH_JAVA=""
+#.else
+#PLIST_SUB+= WITH_JAVA="@comment "
+#.endif
+
.if defined(SWIG_BINDINGS) && ${SWIG_BINDINGS} != ""
BUILD_DEPENDS+= swig1.3:${PORTSDIR}/devel/swig13
DEPENDS_ARGS+= SWIG_LANGUAGES='${SWIG_BINDINGS}'
CONFIGURE_ARGS+= --with-swig=${LOCALBASE} \
--enable-swig-bindings=${SWIG_BINDINGS:Q:S/ /,/g:S/\\//g}
.else
-CONFIGURE_ARGS+= --with-swig=no
+CONFIGURE_ARGS+= --without-swig --disable-swig-bindings
.endif
.if defined(WITH_MOD_DAV_SVN)
@@ -105,19 +119,21 @@ APACHE2_PORT?= www/apache2
BUILD_DEPENDS+= ${APXS}:${PORTSDIR}/${APACHE2_PORT}
RUN_DEPENDS+= ${APXS}:${PORTSDIR}/${APACHE2_PORT}
DEPENDS_ARGS+= WITH_BERKELEYDB=db4
-CONFIGURE_ARGS+=--with-apr=${LOCALBASE}/lib/apache2/apr-config \
- --with-apr-util=${LOCALBASE}/lib/apache2/apu-config
APR_APU_DIR= ${LOCALBASE}/lib/apache2
+APR_CONFIG= apr-config
+APU_CONFIG= apu-config
APR_PORT= www/apache2
OPT_NAME= WITH_BERKELEYDB=(db4|db41|db42)
.else
LIB_DEPENDS+= apr-1.0:${PORTSDIR}/devel/apr-svn
-CONFIGURE_ARGS+=--with-apr=${LOCALBASE} \
- --with-apr-util=${LOCALBASE}
APR_APU_DIR= ${LOCALBASE}/bin
+APR_CONFIG= apr-1-config
+APU_CONFIG= apu-1-config
APR_PORT= devel/apr
OPT_NAME= APR_UTIL_WITH_BERKELEY_DB=yes
.endif
+CONFIGURE_ARGS+=--with-apr=${APR_APU_DIR}/${APR_CONFIG} \
+ --with-apr-util=${APR_APU_DIR}/${APU_CONFIG}
.if defined(WITH_SVNSERVE_WRAPPER)
PLIST_SUB+= SVNSERVE_WRAPPER=""
@@ -132,6 +148,10 @@ BUILD_DEPENDS+= ${LOCALBASE}/share/xsl/docbook/html/docbook.xsl:${PORTSDIR}/text
${LOCALBASE}/bin/xsltproc:${PORTSDIR}/textproc/libxslt
.endif
+SCRIPTS=
+
+SCRIPTS_DATA=
+
pre-extract:
@${ECHO_MSG} ""
.if defined(WITHOUT_NEON)
@@ -160,6 +180,13 @@ pre-extract:
@${ECHO_MSG} "You can enable Python bindings by defining WITH_PYTHON."
.endif
@${ECHO_MSG} ""
+#.if defined(WITH_JAVA)
+# @${ECHO_MSG} "Build with Java (JavaHL) bindings."
+#.else
+# @${ECHO_MSG} "You can enable Java bindings by defining WITH_JAVA."
+# @${ECHO_MSG} "You should have apr builded with threads for Java support!"
+#.endif
+# @${ECHO_MSG} ""
.if defined(WITH_MOD_DAV_SVN)
@${ECHO_MSG} "mod_dav_svn module for Apache 2.X enabled."
.else
@@ -209,6 +236,7 @@ pre-extract:
@${ECHO_MSG} "WITH_BOOK_HTML."
.endif
@${ECHO_MSG} ""
+ @${ECHO_MSG} "May useful scripts will be installed into ${PREFIX}/share/subversion"
post-extract:
@${RM} -r ${WRKSRC}/neon
@@ -225,17 +253,17 @@ post-patch:
@${REINPLACE_CMD} "s#^LIBTOOL =.*#LIBTOOL = ${LIBTOOL}#" ${WRKSRC}/Makefile.in
pre-configure:
- @if [ ! -x ${APR_APU_DIR}/apr-config -o ! -x ${APR_APU_DIR}/apu-config ] ; then \
+ @if [ ! -x ${APR_APU_DIR}/${APR_CONFIG} -o ! -x ${APR_APU_DIR}/${APU_CONFIG} ] ; then \
${ECHO_MSG} "" ; \
- ${ECHO_MSG} 'You select to use`'"${APR_PORT}' for apr library." ; \
+ ${ECHO_MSG} 'You selected to use`'"${APR_PORT}' for apr library." ; \
${ECHO_MSG} 'It seems that `'"${APR_PORT}' is not properly installed." ; \
${ECHO_MSG} "" ; \
${FALSE} ; \
fi
- @if [ `${APR_APU_DIR}/apu-config --db-version` != "4" ] ; then \
+ @if [ `${APR_APU_DIR}/${APU_CONFIG} --db-version` != "4" ] ; then \
${ECHO_MSG} "" ; \
${ECHO_MSG} 'You should build `'"${APR_PORT}' with db4 support to use subversion with it." ; \
- ${ECHO_MSG} 'Please, rebuild `'"${APR_PORT}' with option "'`'"${OPT_NAME}' and try again." ; \
+ ${ECHO_MSG} 'Please rebuild `'"${APR_PORT}' with option "'`'"${OPT_NAME}' and try again." ; \
${ECHO_MSG} "" ; \
${FALSE} ; \
fi
@@ -243,18 +271,17 @@ pre-configure:
post-build:
.if defined(WITH_PERL)
cd ${WRKSRC} ; \
- ${MAKE} swig-pl-lib
- cd ${WRKSRC}/subversion/bindings/swig/perl ; \
- ${SETENV} APR_CONFIG="${APR_APU_DIR}/apr-config" APU_CONFIG="${APR_APU_DIR}/apu-config" \
- CCFLAGS="${CCFLAGS}" CC="${CC}" \
- ${PERL} Makefile.PL PREFIX="${PREFIX}" \
- INSTALLPRIVLIB="${PREFIX}/lib" INSTALLARCHLIB="${PREFIX}/lib" ; \
- ${MAKE} all
+ ${MAKE} swig-pl
.endif
.if defined(WITH_PYTHON)
cd ${WRKSRC} ; \
${MAKE} swig-py
.endif
+#.if defined(WITH_JAVA)
+# @${MKDIR} ${WRKSRC}/subversion/bindings/java/javahl/classes
+# cd ${WRKSRC} ; \
+# ${MAKE} javahl
+#.endif
.if defined(WITH_BOOK_HTML)
cd ${WRKSRC}/doc/book/tools/ ; \
${LN} -s ${PREFIX}/share/xsl/docbook xsl
@@ -268,6 +295,9 @@ pre-install:
.endif
post-install:
+ @${MKDIR} ${PREFIX}/share/subversion
+ cd ${WRKSRC}/tools ; \
+ tar --exclude '*.in' -cf - * | tar -C ${PREFIX}/share/subversion -xf -
.if !defined(NOPORTDOCS)
${MKDIR} ${DOCSDIR}
for f in ${TXT_DOCS}; do \
@@ -280,14 +310,16 @@ post-install:
.endif
.if defined(WITH_PERL)
cd ${WRKSRC} ; \
- ${MAKE} install-swig-pl-lib
- cd ${WRKSRC}/subversion/bindings/swig/perl ; \
- ${MAKE} install
+ ${MAKE} install-swig-pl
.endif
.if defined(WITH_PYTHON)
cd ${WRKSRC} ; \
${MAKE} install-swig-py
.endif
+#.if defined(WITH_JAVA)
+# cd ${WRKSRC} ; \
+# ${MAKE} install-javahl
+#.endif
.if defined(WITH_SVNSERVE_WRAPPER)
@${INSTALL_SCRIPT} ${FILESDIR}/svnserve.wrapper ${PREFIX}/bin/svnserve
.endif
diff --git a/devel/subversion16/distinfo b/devel/subversion16/distinfo
index 7e43c3bfb40b..8ee34a7a0885 100644
--- a/devel/subversion16/distinfo
+++ b/devel/subversion16/distinfo
@@ -1,2 +1,2 @@
-MD5 (subversion-1.0.8.tar.bz2) = b2378b7d9d00653249877531a61ef1db
-SIZE (subversion-1.0.8.tar.bz2) = 5978990
+MD5 (subversion-1.1.1.tar.bz2) = a180c3fe91680389c210c99def54d9e0
+SIZE (subversion-1.1.1.tar.bz2) = 6768086
diff --git a/devel/subversion16/files/build-outputs.mk.patch b/devel/subversion16/files/build-outputs.mk.patch
index 3612f626c7ce..a7c191b652b5 100644
--- a/devel/subversion16/files/build-outputs.mk.patch
+++ b/devel/subversion16/files/build-outputs.mk.patch
@@ -1,11 +1,11 @@
---- build-outputs.mk.orig Wed Oct 8 16:01:40 2003
-+++ build-outputs.mk Wed Oct 8 16:02:00 2003
-@@ -447,7 +447,7 @@
- cd subversion/svnadmin ; $(INSTALL_FS_BIN) svnadmin$(EXEEXT) $(DESTDIR)$(fs_bindir)/svnadmin$(EXEEXT)
- cd subversion/svndumpfilter ; $(INSTALL_FS_BIN) svndumpfilter$(EXEEXT) $(DESTDIR)$(fs_bindir)/svndumpfilter$(EXEEXT)
- cd subversion/svnlook ; $(INSTALL_FS_BIN) svnlook$(EXEEXT) $(DESTDIR)$(fs_bindir)/svnlook$(EXEEXT)
-- cd subversion/svnserve ; $(INSTALL_FS_BIN) svnserve$(EXEEXT) $(DESTDIR)$(fs_bindir)/svnserve$(EXEEXT)
-+ cd subversion/svnserve ; $(INSTALL_FS_BIN) svnserve$(EXEEXT) $(DESTDIR)$(fs_bindir)/svnserve.bin$(EXEEXT)
+--- build-outputs.mk.orig 2004-10-22 22:13:15.000000000 +0400
++++ build-outputs.mk 2004-11-05 11:15:30.265625000 +0300
+@@ -500,7 +500,7 @@
+ cd subversion/svnadmin ; $(INSTALL_BIN) svnadmin$(EXEEXT) $(DESTDIR)$(bindir)/svnadmin$(EXEEXT)
+ cd subversion/svndumpfilter ; $(INSTALL_BIN) svndumpfilter$(EXEEXT) $(DESTDIR)$(bindir)/svndumpfilter$(EXEEXT)
+ cd subversion/svnlook ; $(INSTALL_BIN) svnlook$(EXEEXT) $(DESTDIR)$(bindir)/svnlook$(EXEEXT)
+- cd subversion/svnserve ; $(INSTALL_BIN) svnserve$(EXEEXT) $(DESTDIR)$(bindir)/svnserve$(EXEEXT)
++ cd subversion/svnserve ; $(INSTALL_BIN) svnserve$(EXEEXT) $(DESTDIR)$(bindir)/svnserve.bin$(EXEEXT)
+ cd subversion/svnversion ; $(INSTALL_BIN) svnversion$(EXEEXT) $(DESTDIR)$(bindir)/svnversion$(EXEEXT)
- install-fs-lib: subversion/libsvn_fs/libsvn_fs-1.la subversion/libsvn_repos/libsvn_repos-1.la subversion/libsvn_ra_local/libsvn_ra_local-1.la
- $(MKDIR) $(DESTDIR)$(fs_libdir)
+ install-contrib: contrib/client-side/svn-push/svn-push$(EXEEXT) install-lib install-fsmod-lib
diff --git a/devel/subversion16/files/patch-ac-helpers::ltmain.sh b/devel/subversion16/files/patch-ac-helpers::ltmain.sh
index 4de20aae8a99..ba6fe13c1cdb 100644
--- a/devel/subversion16/files/patch-ac-helpers::ltmain.sh
+++ b/devel/subversion16/files/patch-ac-helpers::ltmain.sh
@@ -1,6 +1,6 @@
---- ac-helpers/ltmain.sh.orig Thu Oct 23 17:15:47 2003
-+++ ac-helpers/ltmain.sh Tue Nov 11 15:04:17 2003
-@@ -1072,7 +1072,7 @@
+--- ac-helpers/ltmain.sh.orig 2004-10-22 22:13:13.000000000 +0400
++++ ac-helpers/ltmain.sh 2004-11-05 11:30:39.328125000 +0300
+@@ -1061,7 +1061,7 @@
esac
elif test "X$arg" = "X-lc_r"; then
case $host in
@@ -9,4 +9,3 @@
# Do not include libc_r directly, use -pthread flag.
continue
;;
-
diff --git a/devel/subversion16/files/patch-configure b/devel/subversion16/files/patch-configure
deleted file mode 100644
index ff40c1342847..000000000000
--- a/devel/subversion16/files/patch-configure
+++ /dev/null
@@ -1,14 +0,0 @@
---- configure.orig Thu Oct 9 09:10:22 2003
-+++ configure Thu Oct 9 09:10:30 2003
-@@ -2952,9 +2952,9 @@
-
-
-
--APR_VER_REGEX="0\.9\.[5-9]"
-+APR_VER_REGEX="0\.9\.[4-9]"
- APR_VER_REGEX_TOO="1\.0"
--APU_VER_REGEX="0\.9\.[5-9]"
-+APU_VER_REGEX="0\.9\.[4-9]"
- APU_VER_REGEX_TOO="1\.0"
-
-
diff --git a/devel/subversion16/files/patch-book-Makefile b/devel/subversion16/files/patch-doc::book::Makefile
index 662b08245c1b..dce562b68f18 100644
--- a/devel/subversion16/files/patch-book-Makefile
+++ b/devel/subversion16/files/patch-doc::book::Makefile
@@ -1,5 +1,5 @@
---- doc/book/Makefile.orig Fri Feb 20 01:57:40 2004
-+++ doc/book/Makefile Wed Jul 7 19:58:29 2004
+--- doc/book/Makefile.orig 2004-09-14 06:50:26.000000000 +0400
++++ doc/book/Makefile 2004-11-05 11:33:23.265625000 +0300
@@ -1,5 +1,5 @@
XSLTPROC = xsltproc
-INSTALL_DIR = $(DESTDIR)/usr/share/doc/subversion
@@ -7,7 +7,7 @@
INSTALL = install
## You shouldn't normally need to edit anything below here.
-@@ -114,7 +114,7 @@
+@@ -118,7 +118,7 @@
$(BOOK_INSTALL_DIR):
$(INSTALL) -d $(BOOK_INSTALL_DIR)
@@ -16,7 +16,7 @@
$(INSTALL) -d $(BOOK_INSTALL_DIR)/images
$(INSTALL) $(BOOK_HTML_TARGET) $(BOOK_INSTALL_DIR)
$(INSTALL) $(BOOK_DIR)/styles.css $(BOOK_INSTALL_DIR)
-@@ -126,10 +126,10 @@
+@@ -130,10 +130,10 @@
$(INSTALL) $(BOOK_DIR)/styles.css $(BOOK_INSTALL_DIR)
$(INSTALL) $(BOOK_IMAGES) $(BOOK_INSTALL_DIR)/images
diff --git a/devel/subversion16/files/patch-subversion::bindings::swig::perl::Makefile.PL b/devel/subversion16/files/patch-subversion::bindings::swig::perl::Makefile.PL
deleted file mode 100644
index 8fd38e8ae647..000000000000
--- a/devel/subversion16/files/patch-subversion::bindings::swig::perl::Makefile.PL
+++ /dev/null
@@ -1,11 +0,0 @@
---- subversion/bindings/swig/perl/Makefile.PL.orig Sat Jan 24 20:46:46 2004
-+++ subversion/bindings/swig/perl/Makefile.PL Sat Jan 31 21:40:23 2004
-@@ -41,7 +41,7 @@
-
- my %config = (
- ABSTRACT => 'Perl bindings for Subversion',
-- CCFLAGS => join(' ', $apr_cflags, $apu_cflags,
-+ CCFLAGS => join(' ', $ENV{'CCFLAGS'} || '', $apr_cflags, $apu_cflags,
- `$perl_path -MExtUtils::Embed -e ccopts`,
- ' -I.. -I../../../include -g'),
- OBJECT => q/$(O_FILES)/,
diff --git a/devel/subversion16/files/patch-subversion::bindings::swig::perl::natives::Base.pm b/devel/subversion16/files/patch-subversion::bindings::swig::perl::natives::Base.pm
new file mode 100644
index 000000000000..143db2f1ce38
--- /dev/null
+++ b/devel/subversion16/files/patch-subversion::bindings::swig::perl::natives::Base.pm
@@ -0,0 +1,10 @@
+--- subversion/bindings/swig/perl/native/Base.pm.orig 2004-10-20 10:46:59.000000000 +0400
++++ subversion/bindings/swig/perl/native/Base.pm 2004-11-05 11:43:35.578125000 +0300
+@@ -60,6 +60,7 @@
+ package SVN::_$pkg;
+ require DynaLoader;
+ bootstrap SVN::_$pkg;
++sub dl_load_flags { 0x01 }
+ 1;
+ ' or die $@;
+ };
diff --git a/devel/subversion16/files/patch-subversion::bindings::swig::perl::natives::Makefle.PL.in b/devel/subversion16/files/patch-subversion::bindings::swig::perl::natives::Makefle.PL.in
new file mode 100644
index 000000000000..868ff9a558e4
--- /dev/null
+++ b/devel/subversion16/files/patch-subversion::bindings::swig::perl::natives::Makefle.PL.in
@@ -0,0 +1,83 @@
+--- subversion/bindings/swig/perl/native/Makefile.PL.in.orig 2004-09-14 20:32:08.000000000 +0400
++++ subversion/bindings/swig/perl/native/Makefile.PL.in 2004-11-05 11:51:01.000000000 +0300
+@@ -1,4 +1,5 @@
+-#!/usr/bin/perl
++#!/usr/bin/perl -w
++use strict;
+ use ExtUtils::MakeMaker;
+ use Config;
+ use Cwd 'abs_path';
+@@ -15,6 +16,12 @@
+ my $swig_srcdir = "${svnlib_srcdir}/bindings/swig";
+ my $swig_builddir = "${svnlib_builddir}/bindings/swig";
+
++my $top_builddir = '../../../../..';
++my $top_srcdir = '@top_srcdir@';
++my $svnlib_srcdir = "${top_srcdir}/subversion";
++my $swig_srcdir = "${svnlib_srcdir}/bindings/swig";
++
++
+ my $swig_version = @SWIG_VERSION@;
+ my $swig = '@SWIG@';
+
+@@ -41,15 +48,14 @@
+
+ my %config = (
+ ABSTRACT => 'Perl bindings for Subversion',
+- INC => join(' ',$apr_cflags, $apu_cflags,
++ INC => join(' ',$ENV{'CCFLAGS'} || '',$apr_cflags, $apu_cflags,
+ " -I$swig_srcdir/perl/libsvn_swig_perl",
+ " -I$svnlib_srcdir/include",
+ " -I$swig_srcdir -g"),
+ OBJECT => q/$(O_FILES)/,
+ LIBS => [join(' ', $apr_ldflags,
+ (map {$_ = abs_path($_); "-L$_"} @ldpaths),
+- @ldmodules, '-lsvn_swig_perl-1',
+- `$swig -perl -ldflags`)],
++ @ldmodules)],
+ test => { TESTS => "$swig_srcdir/perl/native/t/*.t" }
+ );
+
+@@ -64,6 +70,7 @@
+ "\$(INST_LIBDIR)/$_.pm") }
+ map { perlish $_ }
+ ('base', 'core', @modules)},
++ LDFROM => '$(O_FILES) '."../libsvn_swig_perl/.libs/libsvn_swig_perl-1.a",
+ MAN3PODS => {map { ("$swig_srcdir/perl/native/$_.pm" =>
+ "\$(INST_MAN3DIR)/SVN::$_.\$(MAN3EXT)") }
+ map { perlish $_ }
+@@ -88,18 +95,22 @@
+ my $module_c_files = join (' ',map { "svn_$_.c"} @modules);
+ my $module_make_commands = join ('',map {"\t\$(MAKE) -f Makefile.$_\n"} @modules);
+
+- my $flags;
++ my ($flags, $flags_runtime);
+ if ($swig_version >= 103020) {
+ $flags = '-noruntime -noproxy';
++ $flags_runtime = '-runtime -noproxy';
+ } else {
++ # XXX: prehaps deprecated
+ $flags = '-c';
+ }
+
+- my $swig_command = "$swig $flags -nopm -perl " .
++ my ($swig_command, $swig_command_runtime) =
++ map {"$swig $_ -nopm -perl " .
+ "-I$swig_srcdir " .
+ "-I$swig_srcdir/perl/libsvn_swig_perl".
+ " -I$svnlib_srcdir/include" .
+- $apr_cflags;
++ $apr_cflags}
++ ($flags, $flags_runtime);
+
+ my $swig_modules_command = join ('',
+ map {"\nsvn_$_.c : $swig_srcdir/svn_$_.i ".
+@@ -137,7 +148,7 @@
+ $module_make_commands\t\$(NOECHO) \$(TOUCH) \$\@
+
+ core.c :: $swig_srcdir/core.i
+-\t$swig_command -o core.c $swig_srcdir/core.i
++\t$swig_command_runtime -o core.c $swig_srcdir/core.i
+
+ $swig_modules_command
+
diff --git a/devel/subversion16/files/patch-svnperl-noruntime b/devel/subversion16/files/patch-svnperl-noruntime
deleted file mode 100644
index 26ada812435b..000000000000
--- a/devel/subversion16/files/patch-svnperl-noruntime
+++ /dev/null
@@ -1,82 +0,0 @@
---- subversion/bindings/swig/perl/Base.pm (revision 10173)
-+++ subversion/bindings/swig/perl/Base.pm (revision 10174)
-@@ -60,6 +60,7 @@ sub import {
- package SVN::_$pkg;
- require DynaLoader;
- bootstrap SVN::_$pkg;
-+sub dl_load_flags { 0x01 }
- 1;
- ' or die $@;
- };
---- subversion/bindings/swig/perl/Makefile.PL (revision 10173)
-+++ subversion/bindings/swig/perl/Makefile.PL (revision 10174)
-@@ -1,4 +1,5 @@
--#!/usr/bin/perl
-+#!/usr/bin/perl -w
-+use strict;
- use ExtUtils::MakeMaker;
- use Cwd 'abs_path';
- use Config;
-@@ -8,6 +9,12 @@ if ($^O ne 'VMS') {
- $perl_path .= $Config{_exe} unless $perl_path =~ m/$Config{_exe}$/i;
- }
-
-+my $top_builddir = '../../../..';
-+my $top_srcdir = '@top_srcdir@';
-+my $svnlib_srcdir = "${top_srcdir}/subversion";
-+my $swig_srcdir = "${svnlib_srcdir}/bindings/swig";
-+
-+
- my $swig_version;
- open TOPMAKE, "<../../../../Makefile";
- while (<TOPMAKE>) {
-@@ -50,8 +57,7 @@ my %config = (
- OBJECT => q/$(O_FILES)/,
- LIBS => [join(' ', $apr_ldflags,
- (map {$_ = abs_path($_); "-L$_"} @ldpaths),
-- @ldmodules, '-lsvn_swig_perl-1',
-- `swig -perl -ldflags`)],
-+ @ldmodules)],
- );
-
- sub perlish {
-@@ -64,6 +70,7 @@ WriteMakefile(%config, NAME => 'SVN::_Co
- PM => {map { ("$_.pm" => "\$(INST_LIBDIR)/$_.pm") }
- map { perlish $_ }
- ('base', 'core', @modules)},
-+ LDFROM => '$(O_FILES) '."../.libs/libsvn_swig_perl-1.a",
- clean => { FILES => "*.hi *.c *.bs".
- join(' Makefile.','',@modules) }
- );
-@@ -84,15 +91,19 @@ sub MY::postamble {
- my $module_c_files = join (' ',map { "svn_$_.c"} @modules);
- my $module_make_commands = join ('',map {"\tmake -f Makefile.$_\n"} @modules);
-
-- my $flags;
-+ my ($flags, $flags_runtime);
- if ($swig_version >= 103020) {
- $flags = '-noruntime -noproxy';
-+ $flags_runtime = '-runtime -noproxy';
- } else {
-+ # XXX: prehaps deprecated
- $flags = '-c';
- }
-
-- my $swig_command = "swig $flags -nopm -perl " .
-- "-I.. -I../../../include $apr_cflags";
-+ my ($swig_command, $swig_command_runtime) =
-+ map {"swig $_ -nopm -perl " .
-+ "-I.. -I../../../include $apr_cflags" }
-+ ($flags, $flags_runtime);
-
- my $swig_modules_command = join ('',
- map {"\nsvn_$_.c : ../svn_$_.i ".
-@@ -127,7 +138,7 @@ modules :: $module_c_files
- $module_make_commands\t\$(NOECHO) \$(TOUCH) \$\@
-
- core.c :: ../core.i
--\t$swig_command -module SVN::_Core -o core.c ../core.i
-+\t$swig_command_runtime -module SVN::_Core -o core.c ../core.i
-
- $swig_modules_command
-
diff --git a/devel/subversion16/pkg-plist b/devel/subversion16/pkg-plist
index 2bf600114ed2..442b8418ac80 100644
--- a/devel/subversion16/pkg-plist
+++ b/devel/subversion16/pkg-plist
@@ -52,6 +52,12 @@ lib/libsvn_diff-1.so.0
lib/libsvn_fs-1.a
lib/libsvn_fs-1.so
lib/libsvn_fs-1.so.0
+lib/libsvn_fs_base-1.a
+lib/libsvn_fs_base-1.so
+lib/libsvn_fs_base-1.so.0
+lib/libsvn_fs_fs-1.a
+lib/libsvn_fs_fs-1.so
+lib/libsvn_fs_fs-1.so.0
lib/libsvn_ra-1.a
lib/libsvn_ra-1.so
lib/libsvn_ra-1.so.0
@@ -73,9 +79,78 @@ lib/libsvn_subr-1.so.0
lib/libsvn_wc-1.a
lib/libsvn_wc-1.so
lib/libsvn_wc-1.so.0
-%%MOD_DAV_SVN%%libexec/apache2/mod_dav_svn.a
+share/locale/de/LC_MESSAGES/subversion.mo
+share/locale/es/LC_MESSAGES/subversion.mo
+share/locale/ja/LC_MESSAGES/subversion.mo
+share/locale/nb/LC_MESSAGES/subversion.mo
+share/locale/pl/LC_MESSAGES/subversion.mo
+share/locale/pt_BR/LC_MESSAGES/subversion.mo
+share/locale/sv/LC_MESSAGES/subversion.mo
+share/locale/zh_CN/LC_MESSAGES/subversion.mo
+share/locale/zh_TW/LC_MESSAGES/subversion.mo
+share/subversion/backup/hot-backup.py
+share/subversion/client-side/bash_completion
+share/subversion/client-side/bash_completion_test
+share/subversion/client-side/server-vsn.py
+share/subversion/client-side/showchange.pl
+share/subversion/cvs2svn/README
+share/subversion/dev/check-license.py
+share/subversion/dev/datecheck.py
+share/subversion/dev/find-textfiles.sh
+share/subversion/dev/gcov.patch
+share/subversion/dev/gnuify-changelog.pl
+share/subversion/dev/iz/defect.dem
+share/subversion/dev/iz/ff2csv.command
+share/subversion/dev/iz/ff2csv.py
+share/subversion/dev/iz/find-fix.py
+share/subversion/dev/iz/run-queries.sh
+share/subversion/dev/normalize-dump.py
+share/subversion/dev/prebuild-cleanup.sh
+share/subversion/dev/random-commits.py
+share/subversion/dev/scramble-tree.py
+share/subversion/dev/stress.pl
+share/subversion/dev/svn-dev.el
+share/subversion/dev/svn-dev.vim
+share/subversion/dev/trails.py
+share/subversion/dev/verify-history.py
+share/subversion/examples/blame.py
+share/subversion/examples/check-modified.py
+share/subversion/examples/dumpprops.py
+share/subversion/examples/getfile.py
+share/subversion/examples/geturl.py
+share/subversion/examples/minimal_client.c
+share/subversion/examples/putfile.py
+share/subversion/examples/revplist.py
+share/subversion/examples/svnlook.py
+share/subversion/examples/svnserve-sgid.c
+share/subversion/examples/svnshell.py
+share/subversion/hook-scripts/commit-access-control.cfg.example
+share/subversion/hook-scripts/commit-access-control.pl
+share/subversion/hook-scripts/commit-email.pl
+share/subversion/hook-scripts/mailer/mailer.conf.example
+share/subversion/hook-scripts/mailer/mailer.py
+share/subversion/hook-scripts/mailer/tests/mailer-init.sh
+share/subversion/hook-scripts/mailer/tests/mailer-t1.output
+share/subversion/hook-scripts/mailer/tests/mailer-t1.sh
+share/subversion/hook-scripts/mailer/tests/mailer-tweak.py
+share/subversion/hook-scripts/propchange-email.pl
+share/subversion/hook-scripts/README
+share/subversion/hook-scripts/svnperms.conf.example
+share/subversion/hook-scripts/svnperms.py
+share/subversion/hook-scripts/verify-po.py
+share/subversion/po/svn-po-status-report.sh
+share/subversion/test-scripts/svntest/README
+share/subversion/test-scripts/svntest/svntest-check-configuration.sh
+share/subversion/test-scripts/svntest/svntest-config.sh
+share/subversion/test-scripts/svntest/svntest-rebuild-generic.sh
+share/subversion/test-scripts/svntest/svntest-rebuild.sh
+share/subversion/test-scripts/svntest/svntest-run.sh
+share/subversion/test-scripts/svntest/svntest-sendmail.sh
+share/subversion/test-scripts/svntest/svntest-update.sh
+share/subversion/test-scripts/svntest/svntest.sh
+share/subversion/xslt/svnindex.css
+share/subversion/xslt/svnindex.xsl
%%MOD_DAV_SVN%%libexec/apache2/mod_dav_svn.so
-%%MOD_DAV_SVN%%libexec/apache2/mod_authz_svn.a
%%MOD_DAV_SVN%%libexec/apache2/mod_authz_svn.so
%%MOD_DAV_SVN%%@exec %D/sbin/apxs -e -S LIBEXECDIR=%D/libexec/apache2 -a -n dav libexec/apache2/mod_dav.so
%%MOD_DAV_SVN%%@exec %D/sbin/apxs -e -S LIBEXECDIR=%D/libexec/apache2 -a -n dav_svn libexec/apache2/mod_dav_svn.so
@@ -160,3 +235,17 @@ lib/libsvn_wc-1.so.0
%%WITH_PYTHON%%%%PYTHON_SITELIBDIR%%/svn/wc.pyc
%%WITH_PYTHON%%@dirrm %%PYTHON_SITELIBDIR%%/libsvn
%%WITH_PYTHON%%@dirrm %%PYTHON_SITELIBDIR%%/svn
+@dirrm share/subversion/backup
+@dirrm share/subversion/client-side
+@dirrm share/subversion/cvs2svn
+@dirrm share/subversion/dev/iz
+@dirrm share/subversion/dev
+@dirrm share/subversion/examples
+@dirrm share/subversion/hook-scripts/mailer/tests
+@dirrm share/subversion/hook-scripts/mailer
+@dirrm share/subversion/hook-scripts
+@dirrm share/subversion/po
+@dirrm share/subversion/test-scripts/svntest
+@dirrm share/subversion/test-scripts
+@dirrm share/subversion/xslt
+@dirrm share/subversion \ No newline at end of file