aboutsummaryrefslogtreecommitdiff
path: root/devel/subversion16
diff options
context:
space:
mode:
authorBruce A. Mah <bmah@FreeBSD.org>2003-06-27 21:03:40 +0000
committerBruce A. Mah <bmah@FreeBSD.org>2003-06-27 21:03:40 +0000
commit4374d7ef2a7df11e903f60b1983186c13f5c6f97 (patch)
treeb1e7f6a4fce0f5cc3687ed74d92e3812ec92dc11 /devel/subversion16
parenta6424a12dfebc96efe63607a0a446594c3b03747 (diff)
downloadports-4374d7ef2a7df11e903f60b1983186c13f5c6f97.tar.gz
ports-4374d7ef2a7df11e903f60b1983186c13f5c6f97.zip
Notes
Diffstat (limited to 'devel/subversion16')
-rw-r--r--devel/subversion16/Makefile41
1 files changed, 31 insertions, 10 deletions
diff --git a/devel/subversion16/Makefile b/devel/subversion16/Makefile
index c6440acf1e31..3a73dfc110d2 100644
--- a/devel/subversion16/Makefile
+++ b/devel/subversion16/Makefile
@@ -6,6 +6,7 @@
PORTNAME= subversion
PORTVERSION= 0.24.2
+PORTREVISION= 1
CATEGORIES= devel
MASTER_SITES= http://subversion.tigris.org/files/documents/15/4807/
MASTER_SITES+= ${MASTER_SITE_LOCAL}
@@ -16,8 +17,7 @@ COMMENT= Version control system
LIB_DEPENDS= db4:${PORTSDIR}/databases/db4 \
neon.23:${PORTSDIR}/www/neon \
- expat.4:${PORTSDIR}/textproc/expat2 \
- apr-0.9:${PORTSDIR}/devel/apr
+ expat.4:${PORTSDIR}/textproc/expat2
INSTALLS_SHLIB= yes
@@ -28,17 +28,15 @@ CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ARGS= --with-ssl \
--with-neon=${LOCALBASE} \
--with-berkeley-db=${LOCALBASE}/include/db4:${LOCALBASE}/lib \
- --with-apr=${LOCALBASE} \
- --with-apr-util=${LOCALBASE} \
--with-swig=no
MAN1= svn.1 svnadmin.1
MANCOMPRESSED= no
-.if defined(WITH_MOD_DAV_SVN)
APXS=${LOCALBASE}/sbin/apxs
-BUILD_DEPENDS+= ${APXS}:${PORTSDIR}/www/apache2
-RUN_DEPENDS+= ${APXS}:${PORTSDIR}/www/apache2
+
+.if defined(WITH_MOD_DAV_SVN)
+WITH_APACHE2_APR= yes
CONFIGURE_ARGS+= \
--with-apxs=${APXS}
PLIST_SUB+= MOD_DAV_SVN=""
@@ -47,13 +45,36 @@ PLIST_SUB+= MOD_DAV_SVN="@comment "
PKGDEINSTALL= NONEXISTENT
.endif
+.if defined(WITH_APACHE2_APR)
+APACHE2_PORT?= ${PORTSDIR}/www/apache2
+BUILD_DEPENDS+= ${APXS}:${APACHE2_PORT}
+RUN_DEPENDS+= ${APXS}:${APACHE2_PORT}
+CONFIGURE_ARGS+=--with-apr=${LOCALBASE}/lib/apache2/apr-config \
+ --with-apr-util=${LOCALBASE}/lib/apache2/apu-config
+.else
+LIB_DEPENDS+= apr-0.9:${PORTSDIR}/devel/apr
+CONFIGURE_ARGS+=--with-apr=${LOCALBASE} \
+ --with-apr-util=${LOCALBASE}
+.endif
+
pre-extract:
-.if !defined(WITH_MOD_DAV_SVN)
- @${ECHO_MSG}
+.if defined(WITH_MOD_DAV_SVN)
+ @${ECHO_MSG} "mod_dav_svn module for Apache 2.X enabled."
+.else
@${ECHO_MSG} "You can enable the mod_dav_svn module for Apache 2.X"
- @${ECHO_MSG} "by defining WITH_MOD_DAV_SVN."
+ @${ECHO_MSG} "by defining WITH_MOD_DAV_SVN. This option implies
+ @${ECHO_MSG} "the WITH_APACHE2_APR option."
+.endif
@${ECHO_MSG}
+.if defined(WITH_APACHE2_APR)
+ @${ECHO_MSG} "Using APR from www/apache2. If you have the devel/apr"
+ @${ECHO_MSG} "port/package installed, you may need to remove it."
+else
+ @${ECHO_MSG} "You can link subversion against the APR built with"
+ @${ECHO_MSG} "the www/apache2 port, rather than the devel/apr port,"
+ @${ECHO_MSG} "by defining WITH_APACHE2_APR."
.endif
+ @${ECHO_MSG}
post-extract:
@${REINPLACE_CMD} 's/ldb/ldb4/g' ${WRKSRC}/configure