aboutsummaryrefslogtreecommitdiff
path: root/devel/subversion
diff options
context:
space:
mode:
authorLev A. Serebryakov <lev@FreeBSD.org>2003-10-09 12:50:16 +0000
committerLev A. Serebryakov <lev@FreeBSD.org>2003-10-09 12:50:16 +0000
commit18c82f1b151e37ba088cc5ae353fd065d09d133d (patch)
tree8e9e21250d0245c819f69a4c038c4c772162aee2 /devel/subversion
parent016a4aa1e9831906d9351e518e8e10d864c140b8 (diff)
downloadports-18c82f1b151e37ba088cc5ae353fd065d09d133d.tar.gz
ports-18c82f1b151e37ba088cc5ae353fd065d09d133d.zip
Notes
Diffstat (limited to 'devel/subversion')
-rw-r--r--devel/subversion/Makefile96
-rw-r--r--devel/subversion/distinfo2
-rw-r--r--devel/subversion/files/build-outputs.mk.patch11
-rw-r--r--devel/subversion/files/patch-configure11
-rw-r--r--devel/subversion/files/svnserve.wrapper7
-rw-r--r--devel/subversion/pkg-plist1
6 files changed, 115 insertions, 13 deletions
diff --git a/devel/subversion/Makefile b/devel/subversion/Makefile
index 7e6f6b072c83..967b7301ce51 100644
--- a/devel/subversion/Makefile
+++ b/devel/subversion/Makefile
@@ -5,7 +5,7 @@
# $FreeBSD$
PORTNAME= subversion
-PORTVERSION= 0.30.0
+PORTVERSION= 0.31.0
CATEGORIES= devel
MASTER_SITES= http://svn.collab.net/tarballs/
MASTER_SITES+= ${MASTER_SITE_LOCAL}
@@ -29,20 +29,22 @@ CONFIGURE_ARGS= --with-ssl \
--with-berkeley-db=${LOCALBASE}/include/db4:${LOCALBASE}/lib \
--with-swig=no
-
-MAN1= svn.1 svnadmin.1
+MAN1= svn.1 svnadmin.1 svnlook.1
MANCOMPRESSED= no
-APXS=${LOCALBASE}/sbin/apxs
+SVNREPOS?= /home/svn/repos
+APXS= ${LOCALBASE}/sbin/apxs
.if defined(WITH_MOD_DAV_SVN)
WITH_APACHE2_APR= yes
CONFIGURE_ARGS+= \
--with-apxs=${APXS}
PLIST_SUB+= MOD_DAV_SVN=""
+SVNGROUP?= www
.else
PLIST_SUB+= MOD_DAV_SVN="@comment "
PKGDEINSTALL= NONEXISTENT
+SVNGROUP?= svn
.endif
.if defined(WITH_APACHE2_APR)
@@ -57,11 +59,34 @@ CONFIGURE_ARGS+=--with-apr=${LOCALBASE} \
--with-apr-util=${LOCALBASE}
.endif
+.if defined(WITH_SVNSERVE_WRAPPER)
+PLIST_SUB+= SVNSERVE_WRAPPER=""
+EXTRA_PATCHES= ${PATCHDIR}/build-outputs.mk.patch
+.else
+PLIST_SUB+= SVNSERVE_WRAPPER="@comment "
+.endif
+
pre-extract:
.if !defined (BATCH)
- @dialog --title "-- URGENT UPGRADE INFORMATION --" --clear --yesno \
- "If you upgrade Subversion from pre-0.28.0 version, please,\ndump you repository with old (pre-0.28.0) svnadmin command.\nAfter this, install new version, remove old repository, create new\none with svnadmin & load dump created from old repository\n\nVersions after 0.28.0 have different repository format and\nyour old repository could not be used with versions 0.28.0 and up.\n\nRead\nhttp://svn.collab.net/repos/svn/trunk/notes/repos_upgrade_HOWTO\nfor details.\n\nDid you dump you repository and ready to install new version?" \
- 18 70
+ @${ECHO_MSG} "!!! WARNING !!! WARNING !!! WARNING !!! WARNING !!! WARNING !!! WARNING !!!"
+ @${ECHO_MSG} ""
+ @${ECHO_MSG} "If you upgrade Subversion from pre-0.28.0 version, please,"
+ @${ECHO_MSG} "dump you repository with old (pre-0.28.0) svnadmin command."
+ @${ECHO_MSG} "After this, install new version, remove old repository, create new"
+ @${ECHO_MSG} "one with svnadmin & load dump created from old repository"
+ @${ECHO_MSG} ""
+ @${ECHO_MSG} "Versions after 0.28.0 have different repository format and"
+ @${ECHO_MSG} "your old repository could not be used with versions 0.28.0 and up."
+ @${ECHO_MSG} ""
+ @${ECHO_MSG} "Read"
+ @${ECHO_MSG} "http://svn.collab.net/repos/svn/trunk/notes/repos_upgrade_HOWTO"
+ @${ECHO_MSG} "for details."
+ @${ECHO_MSG} ""
+ @${ECHO_MSG} "Did you dump you repository and ready to install new version?"
+ @${ECHO_MSG} ""
+ @${ECHO_MSG} "!!! WARNING !!! WARNING !!! WARNING !!! WARNING !!! WARNING !!! WARNING !!!"
+ @${ECHO_MSG} ""
+ @sleep 5
.endif
.if defined(WITH_MOD_DAV_SVN)
@${ECHO_MSG} "mod_dav_svn module for Apache 2.X enabled."
@@ -80,6 +105,31 @@ pre-extract:
@${ECHO_MSG} "by defining WITH_APACHE2_APR."
.endif
@${ECHO_MSG}
+.if defined(WITH_SVNSERVE_WRAPPER)
+ @${ECHO_MSG} "svnserve wrapper enabled."
+.else
+ @${ECHO_MSG} "You can install the svnserve wrapper (sets umask 002)"
+ @${ECHO_MSG} "by defining WITH_SVNSERVE_WRAPPER."
+.endif
+ @${ECHO_MSG}
+.if defined(WITH_REPOSITORY_CREATION)
+ @${ECHO_MSG} "I will create (or use, if it exists) \"${SVNGROUP}\" group."
+ @${ECHO_MSG} "Make sure that all commiters are its members."
+.else
+ @${ECHO_MSG} "You can have the repository created for you by defining"
+ @${ECHO_MSG} "WITH_REPOSITORY_CREATION."
+ @${ECHO_MSG} ""
+ @${ECHO_MSG} "Make sure that:"
+ @${ECHO_MSG} "* all your svn users are members of a common group"
+ @${ECHO_MSG} "* this group is the group id of the db/ and locks/"
+ @${ECHO_MSG} " subdirectories of your repository"
+ @${ECHO_MSG} "* the above subdirectories are writable by this group"
+ @${ECHO_MSG} ""
+ @${ECHO_MSG} "Repository will be created at '${SVNREPOS}' with group '${SVNGROUP}'"
+ @${ECHO_MSG} "You could change tese settings by defining SVNREPOS and SVNGROUP"
+ @${ECHO_MSG} ""
+.endif
+ @${ECHO_MSG}
post-extract:
@${REINPLACE_CMD} 's/ldb/ldb4/g' ${WRKSRC}/configure
@@ -100,6 +150,38 @@ post-install:
${INSTALL_DATA} ${WRKSRC}/$$f ${DOCSDIR}; \
done
.endif
+.if defined(WITH_SVNSERVE_WRAPPER)
+ @${INSTALL_SCRIPT} ${FILESDIR}/svnserve.wrapper ${PREFIX}/bin/svnserve
+.endif
+.if defined(WITH_REPOSITORY_CREATION) && !exists(${SVNREPOS})
+. if defined(WITH_SVNSERVE_WRAPPER)
+ @if /usr/sbin/pw groupshow "${SVNGROUP}" >/dev/null 2>&1; then \
+ echo "You already have a group \"${SVNGROUP}\", so I will use it."; \
+ else \
+ if /usr/sbin/pw groupadd ${SVNGROUP} -h -; \
+ then \
+ echo "Added group \"${SVNGROUP}\"."; \
+ else \
+ echo "Adding group \"${SVNGROUP}\" failed..."; \
+ echo "Please create it, and try again."; \
+ ${FALSE}; \
+ fi; \
+ fi
+. endif
+ @${MKDIR} ${SVNREPOS}
+ @${PREFIX}/bin/svnadmin create ${SVNREPOS}
+ @${CHGRP} ${SVNGROUP} ${SVNREPOS}/db ${SVNREPOS}/locks/db.lock
+ @${CHMOD} g+w ${SVNREPOS}/db ${SVNREPOS}/locks/db.lock
+ @for i in ${SVNREPOS}/db/* ; do \
+ i=$${i##*/}; \
+ case $$i in \
+ DB_CONFIG) ;; \
+ *) ${CHGRP} ${SVNGROUP} ${SVNREPOS}/db/$$i; \
+ ${CHMOD} g+w ${SVNREPOS}/db/$$i; \
+ ;; \
+ esac; \
+ done
+.endif
post-deinstall:
.if defined(WITH_MOD_DAV_SVN)
diff --git a/devel/subversion/distinfo b/devel/subversion/distinfo
index 3b70cfec5f84..4facbda3ff6e 100644
--- a/devel/subversion/distinfo
+++ b/devel/subversion/distinfo
@@ -1 +1 @@
-MD5 (subversion-0.30.0.tar.gz) = 9dac76a67a217dc6b7f63259761ff93f
+MD5 (subversion-0.31.0.tar.gz) = a58df76993c1e6b1bfe80dd77d290ab2
diff --git a/devel/subversion/files/build-outputs.mk.patch b/devel/subversion/files/build-outputs.mk.patch
new file mode 100644
index 000000000000..3612f626c7ce
--- /dev/null
+++ b/devel/subversion/files/build-outputs.mk.patch
@@ -0,0 +1,11 @@
+--- build-outputs.mk.orig Wed Oct 8 16:01:40 2003
++++ build-outputs.mk Wed Oct 8 16:02:00 2003
+@@ -447,7 +447,7 @@
+ cd subversion/svnadmin ; $(INSTALL_FS_BIN) svnadmin$(EXEEXT) $(DESTDIR)$(fs_bindir)/svnadmin$(EXEEXT)
+ cd subversion/svndumpfilter ; $(INSTALL_FS_BIN) svndumpfilter$(EXEEXT) $(DESTDIR)$(fs_bindir)/svndumpfilter$(EXEEXT)
+ cd subversion/svnlook ; $(INSTALL_FS_BIN) svnlook$(EXEEXT) $(DESTDIR)$(fs_bindir)/svnlook$(EXEEXT)
+- cd subversion/svnserve ; $(INSTALL_FS_BIN) svnserve$(EXEEXT) $(DESTDIR)$(fs_bindir)/svnserve$(EXEEXT)
++ cd subversion/svnserve ; $(INSTALL_FS_BIN) svnserve$(EXEEXT) $(DESTDIR)$(fs_bindir)/svnserve.bin$(EXEEXT)
+
+ install-fs-lib: subversion/libsvn_fs/libsvn_fs-1.la subversion/libsvn_repos/libsvn_repos-1.la subversion/libsvn_ra_local/libsvn_ra_local-1.la
+ $(MKDIR) $(DESTDIR)$(fs_libdir)
diff --git a/devel/subversion/files/patch-configure b/devel/subversion/files/patch-configure
index a61b6659305d..8ad6cd1ae5ed 100644
--- a/devel/subversion/files/patch-configure
+++ b/devel/subversion/files/patch-configure
@@ -1,13 +1,14 @@
---- configure.orig Fri Jul 25 09:25:23 2003
-+++ configure Fri Jul 25 09:25:28 2003
-@@ -1820,8 +1820,8 @@
+--- configure.orig Thu Oct 9 09:10:22 2003
++++ configure Thu Oct 9 09:10:30 2003
+@@ -2952,9 +2952,9 @@
-APR_VER_REGEX="0\.9\.[4-9]"
--APU_VER_REGEX="0\.9\.[4-9]"
+APR_VER_REGEX="0\.9\.[3-9]"
+ APR_VER_REGEX_TOO="1\.0"
+-APU_VER_REGEX="0\.9\.[4-9]"
+APU_VER_REGEX="0\.9\.[3-9]"
-
+ APU_VER_REGEX_TOO="1\.0"
diff --git a/devel/subversion/files/svnserve.wrapper b/devel/subversion/files/svnserve.wrapper
new file mode 100644
index 000000000000..6797f9478ad5
--- /dev/null
+++ b/devel/subversion/files/svnserve.wrapper
@@ -0,0 +1,7 @@
+#!/bin/sh
+
+SVNSERVE=$(dirname $(realpath $0))/svnserve.bin
+
+umask 002
+$SVNSERVE "$@"
+
diff --git a/devel/subversion/pkg-plist b/devel/subversion/pkg-plist
index 20d10f6c9ada..b46ff155223e 100644
--- a/devel/subversion/pkg-plist
+++ b/devel/subversion/pkg-plist
@@ -3,6 +3,7 @@ bin/svnadmin
bin/svndumpfilter
bin/svnlook
bin/svnserve
+%%SVNSERVE_WRAPPER%%bin/svnserve.bin
bin/svnversion
include/subversion-1/mod_dav_svn.h
include/subversion-1/svn-revision.txt