aboutsummaryrefslogtreecommitdiff
path: root/devel/subversive
diff options
context:
space:
mode:
authorAlex Dupre <ale@FreeBSD.org>2007-02-16 06:50:54 +0000
committerAlex Dupre <ale@FreeBSD.org>2007-02-16 06:50:54 +0000
commit7563fe2a8bb52297ff07aa7c0cd62b4d9133343a (patch)
treea93203f8d67568ad9dd533bbdf89dbddeffa1404 /devel/subversive
parent9c6fb5335ae1c12ad627075898fbe4b207c636c4 (diff)
downloadports-7563fe2a8bb52297ff07aa7c0cd62b4d9133343a.tar.gz
ports-7563fe2a8bb52297ff07aa7c0cd62b4d9133343a.zip
Notes
Diffstat (limited to 'devel/subversive')
-rw-r--r--devel/subversive/Makefile33
-rw-r--r--devel/subversive/distinfo3
-rw-r--r--devel/subversive/pkg-descr19
3 files changed, 55 insertions, 0 deletions
diff --git a/devel/subversive/Makefile b/devel/subversive/Makefile
new file mode 100644
index 000000000000..85491cc5a670
--- /dev/null
+++ b/devel/subversive/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: subversive
+# Date created: 14 Feb 2007
+# Whom: Alex Dupre <ale@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= subversive
+DISTVERSION= 1.1.0.RC5
+CATEGORIES= devel java
+MASTER_SITES= http://www.polarion.org/projects/subversive/download/1.1/builds/
+DISTNAME= Subversive_${DISTVERSION}-LocalUpdateSite
+
+MAINTAINER= ale@FreeBSD.org
+COMMENT= An Eclipse plug-in that provides Subversion support
+
+RUN_DEPENDS= eclipse:${PORTSDIR}/java/eclipse
+
+NO_BUILD= yes
+NO_WRKSUBDIR= yes
+USE_ZIP= yes
+USE_JAVA= yes
+JAVA_VERSION= 1.4+
+JAVA_OS= native
+
+do-install:
+ @${MKDIR} ${PREFIX}/eclipse
+ @${CP} -r ${WRKSRC}/plugins ${PREFIX}/eclipse
+ @${CP} -r ${WRKSRC}/features ${PREFIX}/eclipse
+ @(cd ${WRKSRC}; ${FIND} -s features plugins -not -type d) | \
+ ${SED} -ne 's,^,eclipse/,p' >> ${TMPPLIST}
+
+.include <bsd.port.mk>
diff --git a/devel/subversive/distinfo b/devel/subversive/distinfo
new file mode 100644
index 000000000000..4e5b69607915
--- /dev/null
+++ b/devel/subversive/distinfo
@@ -0,0 +1,3 @@
+MD5 (Subversive_1.1.0.RC5-LocalUpdateSite.zip) = d054727a6b6eb1b42c51ce2dc2e4058d
+SHA256 (Subversive_1.1.0.RC5-LocalUpdateSite.zip) = d8e025a3a14787c7d204a8713fa662003c6af5f1f1f41300951e73a57c913b57
+SIZE (Subversive_1.1.0.RC5-LocalUpdateSite.zip) = 6275463
diff --git a/devel/subversive/pkg-descr b/devel/subversive/pkg-descr
new file mode 100644
index 000000000000..d8c42630fc3b
--- /dev/null
+++ b/devel/subversive/pkg-descr
@@ -0,0 +1,19 @@
+The Subversive project is a brand new Eclipse plug-in that provides
+Subversion support. From a user point of view, Subversive provides
+Subversion support similar to CVS support, which is already part of
+the standard Eclipse platform.
+
+The main use cases, which are familiar to CVS users, are:
+ * Connection to the repository using different connection types
+ * Repository browsing
+ * Check-out
+ * Synchronization
+ * Commiting
+ * Update
+ * Resolving conflicts
+ * Adding to the list of ignored resources
+
+WWW: http://www.polarion.org/index.php?page=overview&project=subversive
+
+- Alex Dupre
+ale@FreeBSD.org