aboutsummaryrefslogtreecommitdiff
path: root/devel/swig13
diff options
context:
space:
mode:
authorRong-En Fan <rafan@FreeBSD.org>2008-03-29 16:37:59 +0000
committerRong-En Fan <rafan@FreeBSD.org>2008-03-29 16:37:59 +0000
commitfe9f2ce3ee3f21bea560bf02a064033ce68a6839 (patch)
tree685cf0664d7efb1d2bd17b2421efd7cb38a191ca /devel/swig13
parent67ecec9e65d5ab4625673ab05cf54cac54af6b32 (diff)
downloadports-fe9f2ce3ee3f21bea560bf02a064033ce68a6839.tar.gz
ports-fe9f2ce3ee3f21bea560bf02a064033ce68a6839.zip
Notes
Diffstat (limited to 'devel/swig13')
-rw-r--r--devel/swig13/Makefile18
1 files changed, 14 insertions, 4 deletions
diff --git a/devel/swig13/Makefile b/devel/swig13/Makefile
index 41a13cc6916c..8b1cc1349d4d 100644
--- a/devel/swig13/Makefile
+++ b/devel/swig13/Makefile
@@ -19,19 +19,29 @@ USE_AUTOTOOLS= autoconf:261:env libtool:15
VER= ${PORTVERSION:R}
PLIST_SUB+= PORTVERSION=${PORTVERSION}
-# Supported languages: guile perl php4 python ruby tcl ocaml pike java csharp
-# allegrocl modula3 chicken
+# Supported languages: allegrocl c# clisp chicken guile java lua ocaml perl
+# php pike python R ruby tcl
WRKSRC= ${WRKDIR}/${DISTNAME}
CONFIGURE_ENV+= CFLAGS="${CFLAGS} -fPIC -DPIC"
ALL_TARGET= swig
PLIST_SUB+= VER="${VER}"
+WANT_LUA= yes
+WANT_LUA_VER= 5.0+
+
.include <bsd.port.pre.mk>
+.if ${HAVE_LUA:Mlua-5.*} != ""
+USE_LUA= yes
+LUA_COMPS= lua:build
+CONFIGURE_ARGS+=--with-lua=${LUA_BINDIR}/lua \
+ --with-luaincl=${LUA_INCDIR} \
+ --with-lualib=${LUA_LIBDIR}
+.endif
+
post-patch:
- ${REINPLACE_CMD} -e 's/SKIP_CHICKEN=$$/&"1"/; \
- s|$$RUBY |${RUBY} |; \
+ ${REINPLACE_CMD} -e 's|$$RUBY |${RUBY} |; \
s|^PHP4CONFIG=.*$$|PHP4CONFIG=php-config|; \
' ${WRKSRC}/configure
${REINPLACE_CMD} -e 's|malloc.h|stdlib.h|' \