aboutsummaryrefslogtreecommitdiff
path: root/devel/synfig
diff options
context:
space:
mode:
authorMikhail Teterin <mi@FreeBSD.org>2008-05-22 00:00:25 +0000
committerMikhail Teterin <mi@FreeBSD.org>2008-05-22 00:00:25 +0000
commit937e718588dbc1036b1766e0054fea750ffebf42 (patch)
tree861ff5cc75cb8336e39754fc5054777317f57b6e /devel/synfig
parent4285180b55dee8276f2fd7ed86db0145c2170e12 (diff)
Add the missing dependency on OpenEXR. When built without it present on the
building system (such as pointyhat), the OpenEXR support is disabled and plist is incomplete. This unbreaks the port -- or so it seems. While here drop the requirement for gmake and allow parallel builds on multi-CPU systems. Drop explicit requirements for particular shared library-versions of the dependencies.
Notes
Notes: svn path=/head/; revision=213480
Diffstat (limited to 'devel/synfig')
-rw-r--r--devel/synfig/Makefile19
1 files changed, 9 insertions, 10 deletions
diff --git a/devel/synfig/Makefile b/devel/synfig/Makefile
index 8012695e0a97..124920d1a5ea 100644
--- a/devel/synfig/Makefile
+++ b/devel/synfig/Makefile
@@ -15,24 +15,23 @@ COMMENT= A vector based 2D animation package
BUILD_DEPENDS= ${LOCALBASE}/libdata/pkgconfig/ETL.pc:${PORTSDIR}/devel/etl
LIB_DEPENDS= glibmm-2.4.1:${PORTSDIR}/devel/glibmm \
- MagickWand.1:${PORTSDIR}/graphics/ImageMagick \
- jpeg.9:${PORTSDIR}/graphics/jpeg \
- mng.1:${PORTSDIR}/graphics/libmng \
- png.5:${PORTSDIR}/graphics/png \
- tiff.4:${PORTSDIR}/graphics/tiff \
- avcodec.1:${PORTSDIR}/multimedia/ffmpeg \
- dv.4:${PORTSDIR}/multimedia/libdv \
+ MagickWand:${PORTSDIR}/graphics/ImageMagick \
+ jpeg:${PORTSDIR}/graphics/jpeg \
+ mng:${PORTSDIR}/graphics/libmng \
+ png:${PORTSDIR}/graphics/png \
+ tiff:${PORTSDIR}/graphics/tiff \
+ avcodec:${PORTSDIR}/multimedia/ffmpeg \
+ dv:${PORTSDIR}/multimedia/libdv \
+ IlmImf:${PORTSDIR}/graphics/OpenEXR \
xml\\+\\+-2.6:${PORTSDIR}/textproc/libxml++26
-BROKEN= bad plist
-
USE_GNOME= gnomehack gnometarget glib20
USE_GETTEXT= yes
GNU_CONFIGURE= yes
-USE_GMAKE= yes
USE_LDCONFIG= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
+ALL_TARGET= -j`${SYSCTL} -n hw.ncpu`
post-patch:
@${REINPLACE_CMD} -e '/optimization_flags/s|CXXFLAGS=|#CXXFLAGS=| ; \