aboutsummaryrefslogtreecommitdiff
path: root/devel/talloc/Makefile
diff options
context:
space:
mode:
authorTimur I. Bakeyev <timur@FreeBSD.org>2009-07-12 21:40:50 +0000
committerTimur I. Bakeyev <timur@FreeBSD.org>2009-07-12 21:40:50 +0000
commitff368cb1d932b75cfe995ec7a048ad13e4b4c776 (patch)
treec49f3435058e4288894e92e9ecb052cfb68b9eeb /devel/talloc/Makefile
parentfe933bd984de8d50b2e13e73eb80211d2a66eda3 (diff)
Notes
Diffstat (limited to 'devel/talloc/Makefile')
-rw-r--r--devel/talloc/Makefile51
1 files changed, 51 insertions, 0 deletions
diff --git a/devel/talloc/Makefile b/devel/talloc/Makefile
new file mode 100644
index 000000000000..a07e0dbd6e82
--- /dev/null
+++ b/devel/talloc/Makefile
@@ -0,0 +1,51 @@
+# New ports collection makefile for: talloc
+# Date created: 18 Apr 2009
+# Whom: Koop Mast <kwm@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= talloc
+PORTVERSION?= 1.3.1
+PORTREVISION= 0
+PORTEPOCH= 0
+CATEGORIES= devel
+PKGNAMESUFFIX=
+
+COMMENT= Hierarchical pool based memory allocator
+
+CONFLICTS=
+
+SAMBA_PORT?= samba4-devel
+SAMBA_SUBPORT= yes
+
+MASTERDIR= ${.CURDIR}/../../net/${SAMBA_PORT}
+FILESDIR= ${.CURDIR}/files
+PKGDIR= ${.CURDIR}
+
+WRKSRC= ${WRKDIR}/${DISTNAME}/lib/talloc
+
+USE_GMAKE= yes
+USE_LDCONFIG= yes
+GNU_CONFIGURE= yes
+USE_AUTOTOOLS= autoconf:262 autoheader:262
+
+CONFIGURE_ENV+= XSLTPROC="/usr/bin/true"
+
+MAN3= talloc.3
+
+PLIST_FILES= include/talloc.h \
+ lib/libtalloc.a \
+ lib/libtalloc.so \
+ lib/libtalloc.so.1 \
+ libdata/pkgconfig/talloc.pc
+
+pre-install:
+.if !exists(${WRKSRC}/talloc.3)
+ @${CP} ${FILESDIR}/talloc.3 ${WRKSRC}
+.endif
+
+post-install:
+ ${LN} -sf libtalloc.so.1 ${PREFIX}/lib/libtalloc.so
+
+.include "${MASTERDIR}/Makefile"