aboutsummaryrefslogtreecommitdiff
path: root/devel/tclcl
diff options
context:
space:
mode:
authorMikhail Teterin <mi@FreeBSD.org>2005-07-03 00:41:01 +0000
committerMikhail Teterin <mi@FreeBSD.org>2005-07-03 00:41:01 +0000
commit1b4ce15ea6b5ea24a30fa4b789b7d0c69eabd251 (patch)
treeee453be2830cacad2d31d8487761741259d4cdda /devel/tclcl
parent55d90d60de472bfcd80b1975a52b4a57a92ec2e0 (diff)
downloadports-1b4ce15ea6b5ea24a30fa4b789b7d0c69eabd251.tar.gz
ports-1b4ce15ea6b5ea24a30fa4b789b7d0c69eabd251.zip
Notes
Diffstat (limited to 'devel/tclcl')
-rw-r--r--devel/tclcl/Makefile6
-rw-r--r--devel/tclcl/distinfo4
-rw-r--r--devel/tclcl/files/patch-Makefile.in9
-rw-r--r--devel/tclcl/files/patch-aa2
-rw-r--r--devel/tclcl/files/patch-ab15
-rw-r--r--devel/tclcl/files/patch-tclcl.h22
6 files changed, 15 insertions, 43 deletions
diff --git a/devel/tclcl/Makefile b/devel/tclcl/Makefile
index 767007cd536f..a8ca2e9ea1da 100644
--- a/devel/tclcl/Makefile
+++ b/devel/tclcl/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= tclcl
-PORTVERSION= 1.15
+PORTVERSION= 1.16
CATEGORIES= devel tcl84 tk84
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= otcl-tclcl
@@ -15,8 +15,8 @@ DISTFILES= tclcl-src-${PORTVERSION}.tar.gz
MAINTAINER= ports@FreeBSD.org
COMMENT= Tcl/C++ interface used by ns and nam
-LIB_DEPENDS= tk84.1:${PORTSDIR}/x11-toolkits/tk84 \
- otcl.1:${PORTSDIR}/lang/otcl
+LIB_DEPENDS= tk84:${PORTSDIR}/x11-toolkits/tk84 \
+ otcl:${PORTSDIR}/lang/otcl
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-tcl-ver=8.4 --with-tk-ver=8.4
diff --git a/devel/tclcl/distinfo b/devel/tclcl/distinfo
index 08a1654e47bf..145ac583be02 100644
--- a/devel/tclcl/distinfo
+++ b/devel/tclcl/distinfo
@@ -1,2 +1,2 @@
-MD5 (tclcl-src-1.15.tar.gz) = 0b6403ea9303d776717855eb0828a408
-SIZE (tclcl-src-1.15.tar.gz) = 143000
+MD5 (tclcl-src-1.16.tar.gz) = 2a25a4736c1bf4ec7f4e6343aa533bc6
+SIZE (tclcl-src-1.16.tar.gz) = 203269
diff --git a/devel/tclcl/files/patch-Makefile.in b/devel/tclcl/files/patch-Makefile.in
new file mode 100644
index 000000000000..e388e9b3bc8d
--- /dev/null
+++ b/devel/tclcl/files/patch-Makefile.in
@@ -0,0 +1,9 @@
+--- Makefile.in Wed Jan 19 14:21:21 2005
++++ Makefile.in Sat Jul 2 20:33:28 2005
+@@ -110,5 +110,5 @@
+ TCL_84_LIBRARY_FILES = \
+ $(TCL_BASE_LIBRARY_FILES) \
+- $(LIBRARY_TCL)/http2.4/http.tcl
++ $(LIBRARY_TCL)/http2.5/http.tcl
+
+ TCL_LIBRARY_FILES = \
diff --git a/devel/tclcl/files/patch-aa b/devel/tclcl/files/patch-aa
index 16d9b77abdcd..3b1426c5c03f 100644
--- a/devel/tclcl/files/patch-aa
+++ b/devel/tclcl/files/patch-aa
@@ -5,7 +5,7 @@
# the exec restarts using tclsh which in turn ignores
# the command because of this backslash: \
-exec tclsh "$0" "$@"
-+exec tclsh8.3 "$0" "$@"
++exec tclsh8.4 "$0" "$@"
#
# otcldoc - a simple script for translating otcl classes into
diff --git a/devel/tclcl/files/patch-ab b/devel/tclcl/files/patch-ab
deleted file mode 100644
index c387d4c4f390..000000000000
--- a/devel/tclcl/files/patch-ab
+++ /dev/null
@@ -1,15 +0,0 @@
---- Makefile.in.orig Wed Mar 10 22:31:11 2004
-+++ Makefile.in Wed Mar 10 22:34:54 2004
-@@ -103,10 +103,10 @@
- $(LIBRARY_TCL)/http2.1/http.tcl
- TCL_83_LIBRARY_FILES = \
- $(TCL_BASE_LIBRARY_FILES) \
-- $(LIBRARY_TCL)/http2.3/http.tcl
-+ $(LIBRARY_TCL)/http2.4/http.tcl
- TCL_84_LIBRARY_FILES = \
- $(TCL_BASE_LIBRARY_FILES) \
-- $(LIBRARY_TCL)/http/http.tcl
-+ $(LIBRARY_TCL)/http2.4/http.tcl
-
- TCL_LIBRARY_FILES = \
- @V_TCL_LIBRARY_FILES@
diff --git a/devel/tclcl/files/patch-tclcl.h b/devel/tclcl/files/patch-tclcl.h
deleted file mode 100644
index e5bdef43c79e..000000000000
--- a/devel/tclcl/files/patch-tclcl.h
+++ /dev/null
@@ -1,22 +0,0 @@
-
-$FreeBSD$
-
---- tclcl.h.orig
-+++ tclcl.h
-@@ -45,7 +45,6 @@
- }
-
- #include "tclcl-config.h"
--#include "tclcl-mappings.h"
- #include "tracedvar.h"
-
- struct Tk_Window_;
-@@ -253,6 +252,8 @@
- InstVar* instvar_;
- TracedVar* tracedvar_;
- };
-+
-+#include "tclcl-mappings.h"
-
- /*
- * johnh xxx: delete this