aboutsummaryrefslogtreecommitdiff
path: root/devel/tcllib/Makefile
diff options
context:
space:
mode:
authorMikhail Teterin <mi@FreeBSD.org>2003-04-24 16:29:16 +0000
committerMikhail Teterin <mi@FreeBSD.org>2003-04-24 16:29:16 +0000
commit0775c9f862e187d093004510692fe43cd873d458 (patch)
treeecfbb5024e11b8552f8903614e1eb8a07e8a5a49 /devel/tcllib/Makefile
parent1589b46341686daff075f74afb7aca5a240fc9dc (diff)
downloadports-0775c9f862e187d093004510692fe43cd873d458.tar.gz
ports-0775c9f862e187d093004510692fe43cd873d458.zip
Notes
Diffstat (limited to 'devel/tcllib/Makefile')
-rw-r--r--devel/tcllib/Makefile31
1 files changed, 20 insertions, 11 deletions
diff --git a/devel/tcllib/Makefile b/devel/tcllib/Makefile
index 1696561ceb1c..4caee186d215 100644
--- a/devel/tcllib/Makefile
+++ b/devel/tcllib/Makefile
@@ -6,30 +6,39 @@
#
PORTNAME= tcllib
-PORTVERSION= 1.2
-CATEGORIES= devel
+PORTVERSION= 1.3
+CATEGORIES= devel tcl83
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= tcllib
MAINTAINER= mi@aldan.algebra.com
COMMENT= A collection of utility modules for Tcl
-BROKEN= "Creates /root/foo at install-time"
+BUILD_DEPENDS= tclsh:${PORTSDIR}/lang/tcl84
-BUILD_DEPENDS= tclsh:${PORTSDIR}/lang/tcl83
GNU_CONFIGURE= yes
-ALL_TARGET= test
+ALL_TARGET= all nroff-doc
MAKE_ENV+= LANG=C
PLIST_SUB+= PORTVERSION=${PORTVERSION}
-MANN= base64.n cksum.n cmdline.n combinatorics.n comm.n control.n \
- counter.n crc32.n csv.n expander.n fileutil.n ftp.n ftpd.n \
- graph.n html.n htmlparse.n javascript.n log.n math.n matrix.n \
- md5.n mime.n ncgi.n nntp.n pop3.n profiler.n report.n queue.n \
- sha1.n smtp.n smtpd.n stack.n stooop.n sum.n textutil.n tree.n \
- uri.n uuencode.n
+MANN= base64.n calculus.n cksum.n cmdline.n combinatorics.n comm.n \
+ control.n counter.n crc32.n csv.n dns.n dtformat.n dtformatter.n \
+ exif.n expander.n fileutil.n ftp.n ftpd.n graph.n html.n htmlparse.n \
+ irc.n javascript.n log.n math.n matrix.n md5.n mime.n mpexpand.n \
+ ncgi.n nntp.n pool.n pop3.n pop3d.n pop3d_dbox.n pop3d_udb.n \
+ profiler.n queue.n report.n sha1.n smtp.n smtpd.n stack.n \
+ stooop.n sum.n textutil.n tree.n uri.n uuencode.n yencode.n
MANCOMPRESSED= no
+test:
+ ${MAKE_ENV} ${MAKE} -C ${WRKSRC} test
+
+# The directory is created by install, but not populated. Just
+# remove it for now. In future versions, it may get some files
+# and we will remove this target.
+post-install: test
+ @${RMDIR} ${PREFIX}/lib/tcllib${PORTVERSION}/doctools
+
.include <bsd.port.mk>