aboutsummaryrefslogtreecommitdiff
path: root/devel/tcllib
diff options
context:
space:
mode:
authorMikhail Teterin <mi@FreeBSD.org>2009-02-28 23:59:00 +0000
committerMikhail Teterin <mi@FreeBSD.org>2009-02-28 23:59:00 +0000
commit17340ce55c65a92c71c0113f7ec9825ab1d08919 (patch)
treec7d27ae9d743b7f10f458a31010622c8cebbe665 /devel/tcllib
parent02fe757290c1a4a9a34b5414d1513634838eff1b (diff)
downloadports-17340ce55c65a92c71c0113f7ec9825ab1d08919.tar.gz
ports-17340ce55c65a92c71c0113f7ec9825ab1d08919.zip
Notes
Diffstat (limited to 'devel/tcllib')
-rw-r--r--devel/tcllib/Makefile62
-rw-r--r--devel/tcllib/distinfo6
-rw-r--r--devel/tcllib/files/patch-jpeg9
-rw-r--r--devel/tcllib/pkg-plist27
4 files changed, 80 insertions, 24 deletions
diff --git a/devel/tcllib/Makefile b/devel/tcllib/Makefile
index 94aa646b9e92..c02e1c46c27d 100644
--- a/devel/tcllib/Makefile
+++ b/devel/tcllib/Makefile
@@ -6,9 +6,8 @@
#
PORTNAME= tcllib
-PORTVERSION= 1.10
+PORTVERSION= 1.11
CATEGORIES= devel tcl
-PORTREVISION= 2
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= tcllib
@@ -26,14 +25,17 @@ MAKE_ENV+= LANG=C
.if defined(NO_INSTALL_MANPAGES)
INSTALL_TARGET= install-libraries install-applications
.else
-MANN= aes.n ansi_cattr.n ansi_cctrl.n ansi_cmacros.n ansi_code.n \
+MANN= S3.n adjust.n aes.n annealing.n \
+ ansi_cattr.n ansi_cctrl.n ansi_cmacros.n ansi_code.n \
ansi_ctrlu.n ansi_send.n asn.n autoproxy.n base32.n \
base32core.n base32hex.n base64.n bee.n bibtex.n bigfloat.n \
- bignum.n blowfish.n calculus.n changelog.n cksum.n cmdline.n \
+ bignum.n blowfish.n calculus.n cfront.n cgen.n \
+ changelog.n cksum.n cmdline.n \
combinatorics.n comm.n comm_wire.n connect.n constants.n \
control.n copyops.n counter.n crc16.n crc32.n csv.n cvs.n \
dacceptor.n ddest.n deleg_method.n deleg_proc.n des.n \
- dexec.n docidx.n docidx_intro.n docidx_lang_cmdref.n \
+ dexec.n disjointset.n \
+ docidx.n docidx_intro.n docidx_lang_cmdref.n \
docidx_lang_faq.n docidx_lang_intro.n docidx_lang_syntax.n \
docidx_plugin_apiref.n docstrip.n docstrip_util.n doctoc.n \
doctoc_intro.n doctoc_lang_cmdref.n doctoc_lang_faq.n \
@@ -42,29 +44,47 @@ MANN= aes.n ansi_cattr.n ansi_cctrl.n ansi_cmacros.n ansi_code.n \
doctools_lang_faq.n doctools_lang_intro.n doctools_lang_syntax.n \
doctools_plugin_apiref.n dsource.n dtplite.n exif.n \
expander.n fa.n faop.n filetypes.n fileutil.n fourier.n \
- ftp.n ftpd.n fuzzy.n geometry.n graph.n graph1.n html.n \
- htmlparse.n ident.n imenu.n ini.n interpolate.n ipager.n \
+ ftp.n ftp_geturl.n \
+ ftpd.n fuzzy.n gasm.n \
+ geometry.n graph.n graph1.n html.n \
+ htmlparse.n huddle.n \
+ ident.n imenu.n ini.n interpolate.n ipager.n \
irc.n javascript.n jpeg.n json.n ldap.n ldapx.n linalg.n \
log.n logger.n loggerAppender.n loggerUtils.n mapproj.n \
math.n matrix.n matrix1.n md4.n md5.n md5crypt.n me_ast.n \
me_cpu.n me_cpucore.n me_intro.n me_tcl.n me_util.n me_vm.n \
- mime.n mimetypes.n mpexpand.n multi.n multiop.n multiplexer.n \
+ mime.n mimetypes.n montecarlo.n \
+ mpexpand.n multi.n multiop.n multiplexer.n \
ncgi.n nmea.n nns_auto.n nns_client.n nns_common.n \
- nns_procotol.n nns_server.n nntp.n ntp_time.n optimize.n \
+ nns_intro.n \
+ nns_protocol.n nns_server.n \
+ nntp.n ntp_time.n optimize.n \
otp.n page.n page_intro.n page_pluginmgr.n page_util_flow.n \
page_util_norm_lemon.n page_util_norm_peg.n page_util_peg.n \
- page_util_quote.n peg.n peg_interp.n pluginmgr.n png.n \
+ page_util_quote.n peg.n peg_interp.n picoirc.n \
+ pluginmgr.n png.n \
polynomials.n pool.n pop3.n pop3d.n pop3d_dbox.n pop3d_udb.n \
- prioqueue.n profiler.n qcomplex.n queue.n rational_funcs.n \
- rc4.n rcs.n receive.n receiver.n record.n report.n ripemd128.n \
- ripemd160.n roman.n romberg.n sasl.n sha1.n skiplist.n \
+ prioqueue.n profiler.n qcomplex.n queue.n random.n \
+ rational_funcs.n \
+ rc4.n rcs.n receive.n receiver.n record.n repeat.n \
+ report.n ripemd128.n \
+ ripemd160.n roman.n romberg.n rtcore.n \
+ sasl.n sha1.n sha256.n \
+ skiplist.n \
smtp.n smtpd.n snit.n snitfaq.n soundex.n special.n stack.n \
- statistics.n stooop.n struct_list.n struct_set.n struct_tree.n \
- struct_tree1.n sum.n tar.n tcldocstrip.n tcllib_dns.n \
+ statistics.n stooop.n stringprep.n stringprep_data.n \
+ struct_list.n struct_set.n struct_tree.n \
+ struct_tree1.n sum.n tabify.n tar.n tcldocstrip.n tcllib_dns.n \
tcllib_interp.n tcllib_ip.n term.n term_bind.n term_send.n \
- textutil.n tie.n tiff.n tqueue.n transmitter.n traverse.n \
- treeql.n uevent.n units.n uri.n uuencode.n uuid.n wip.n \
- yencode.n
+ textutil.n textutil_split.n textutil_string.n \
+ tie.n tie_std.n \
+ tiff.n tqueue.n transmitter.n traverse.n \
+ treeql.n trim.n \
+ uevent.n unicode.n unicode_data.n \
+ units.n uri.n urn-scheme.n \
+ uuencode.n uuid.n wip.n \
+ xsxp.n \
+ yaml.n yencode.n
MANCOMPRESSED= no
.endif
@@ -94,11 +114,11 @@ pre-build:
#
# Preparing to run the tests as `nobody'
#
- ${FIND} ${WRKSRC} -type d | ${XARGS} ${CHOWN} nobody
+ ${FIND} ${WRKSRC} -type d -o -name jpeg.test | ${XARGS} ${CHOWN} nobody
.endif
test:
- @set -x ; if ! ${RUNTEST}; \
+ @if ! ${RUNTEST}; \
then \
${AWK} '$$NF == "FAILED" { echo = 1 } \
echo { if ($$NF == "start") echo = 0; else print }' \
@@ -106,6 +126,8 @@ test:
${CAT} ${WRKSRC}/testlog.failures; \
${UNAME} -a; \
${ECHO_MSG} Please, analyze and report the test failures; \
+ ${ECHO_MSG} Be sure to use the latest available microversion; \
+ ${ECHO_MSG} of TCL-${TCL_VER}, however.; \
fi
post-build: test
diff --git a/devel/tcllib/distinfo b/devel/tcllib/distinfo
index c72be0eec39b..e743dfe759a6 100644
--- a/devel/tcllib/distinfo
+++ b/devel/tcllib/distinfo
@@ -1,3 +1,3 @@
-MD5 (tcllib-1.10.tar.bz2) = c8692e14fe83ca7570e65335122d2ca9
-SHA256 (tcllib-1.10.tar.bz2) = 1be1625caff06427ec64be3c7d8a81d0a514421dafee5a532325594d790daef2
-SIZE (tcllib-1.10.tar.bz2) = 2732953
+MD5 (tcllib-1.11.tar.bz2) = a48fe88af81819eca9325c5a68f2708c
+SHA256 (tcllib-1.11.tar.bz2) = e4b2bbdf8a00d8910f2f9145b6d5aa0fd05f66df8bcbbb4808d25c77170161b3
+SIZE (tcllib-1.11.tar.bz2) = 3266231
diff --git a/devel/tcllib/files/patch-jpeg b/devel/tcllib/files/patch-jpeg
new file mode 100644
index 000000000000..d086986553b8
--- /dev/null
+++ b/devel/tcllib/files/patch-jpeg
@@ -0,0 +1,9 @@
+--- modules/jpeg/jpeg.tcl 2008-10-17 01:14:26.000000000 -0400
++++ modules/jpeg/jpeg.tcl 2009-02-27 15:45:23.000000000 -0500
+@@ -52,5 +52,5 @@
+
+ proc ::jpeg::imageInfo {file} {
+- set fh [openJFIF $file r+]
++ set fh [openJFIF $file r]
+ set data {}
+ if {[set app0 [lsearch -inline [markers $fh] "e0 *"]] != ""} {
diff --git a/devel/tcllib/pkg-plist b/devel/tcllib/pkg-plist
index a6ad6f9d08b8..676380cfc2aa 100644
--- a/devel/tcllib/pkg-plist
+++ b/devel/tcllib/pkg-plist
@@ -4,6 +4,10 @@ bin/tcldocstrip
lib/tcllib/aes/aes.tcl
lib/tcllib/aes/pkgIndex.tcl
@dirrm lib/tcllib/aes
+lib/tcllib/amazon-s3/pkgIndex.tcl
+lib/tcllib/amazon-s3/S3.tcl
+lib/tcllib/amazon-s3/xsxp.tcl
+@dirrm lib/tcllib/amazon-s3
lib/tcllib/asn/asn.tcl
lib/tcllib/asn/pkgIndex.tcl
@dirrm lib/tcllib/asn
@@ -191,6 +195,7 @@ lib/tcllib/interp/interp.tcl
lib/tcllib/interp/pkgIndex.tcl
@dirrm lib/tcllib/interp
lib/tcllib/irc/irc.tcl
+lib/tcllib/irc/picoirc.tcl
lib/tcllib/irc/pkgIndex.tcl
@dirrm lib/tcllib/irc
lib/tcllib/javascript/javascript.tcl
@@ -377,6 +382,11 @@ lib/tcllib/sha1/sha1v1.tcl
lib/tcllib/sha1/sha256.tcl
lib/tcllib/sha1/sha256c.tcl
@dirrm lib/tcllib/sha1
+lib/tcllib/simulation/annealing.tcl
+lib/tcllib/simulation/montecarlo.tcl
+lib/tcllib/simulation/pkgIndex.tcl
+lib/tcllib/simulation/random.tcl
+@dirrm lib/tcllib/simulation
lib/tcllib/smtpd/pkgIndex.tcl
lib/tcllib/smtpd/smtpd.tcl
@dirrm lib/tcllib/smtpd
@@ -398,10 +408,17 @@ lib/tcllib/stooop/stooop.tcl
lib/tcllib/stooop/switched.tcl
lib/tcllib/stooop/xifo.tcl
@dirrm lib/tcllib/stooop
+lib/tcllib/stringprep/pkgIndex.tcl
+lib/tcllib/stringprep/stringprep.tcl
+lib/tcllib/stringprep/stringprep_data.tcl
+lib/tcllib/stringprep/unicode.tcl
+lib/tcllib/stringprep/unicode_data.tcl
+@dirrm lib/tcllib/stringprep
+lib/tcllib/struct/disjointset.tcl
lib/tcllib/struct/graph.tcl
+lib/tcllib/struct/graph1.tcl
lib/tcllib/struct/graph_c.tcl
lib/tcllib/struct/graph_tcl.tcl
-lib/tcllib/struct/graph1.tcl
lib/tcllib/struct/list.tcl
lib/tcllib/struct/matrix.tcl
lib/tcllib/struct/matrix1.tcl
@@ -409,12 +426,16 @@ lib/tcllib/struct/pkgIndex.tcl
lib/tcllib/struct/pool.tcl
lib/tcllib/struct/prioqueue.tcl
lib/tcllib/struct/queue.tcl
+lib/tcllib/struct/queue_c.tcl
+lib/tcllib/struct/queue_tcl.tcl
lib/tcllib/struct/record.tcl
lib/tcllib/struct/sets.tcl
lib/tcllib/struct/sets_c.tcl
lib/tcllib/struct/sets_tcl.tcl
lib/tcllib/struct/skiplist.tcl
lib/tcllib/struct/stack.tcl
+lib/tcllib/struct/stack_c.tcl
+lib/tcllib/struct/stack_tcl.tcl
lib/tcllib/struct/struct.tcl
lib/tcllib/struct/struct1.tcl
lib/tcllib/struct/tree.tcl
@@ -497,5 +518,9 @@ lib/tcllib/wip/pkgIndex.tcl
lib/tcllib/wip/wip.tcl
lib/tcllib/wip/wip2.tcl
@dirrm lib/tcllib/wip
+lib/tcllib/yaml/huddle.tcl
+lib/tcllib/yaml/pkgIndex.tcl
+lib/tcllib/yaml/yaml.tcl
+@dirrm lib/tcllib/yaml
lib/tcllib/pkgIndex.tcl
@dirrm lib/tcllib