aboutsummaryrefslogtreecommitdiff
path: root/devel/tclreadline
diff options
context:
space:
mode:
authorMartin Matuska <mm@FreeBSD.org>2008-04-02 10:13:27 +0000
committerMartin Matuska <mm@FreeBSD.org>2008-04-02 10:13:27 +0000
commit9cf28aed84b2d11088a20a93ada0907b8ba7cce2 (patch)
treea563b19261b816a13e782b725111398288c6c480 /devel/tclreadline
parentd6dd92542d67d4b41256b2748b6d1cfc760e4388 (diff)
downloadports-9cf28aed84b2d11088a20a93ada0907b8ba7cce2.tar.gz
ports-9cf28aed84b2d11088a20a93ada0907b8ba7cce2.zip
Notes
Diffstat (limited to 'devel/tclreadline')
-rw-r--r--devel/tclreadline/Makefile57
1 files changed, 4 insertions, 53 deletions
diff --git a/devel/tclreadline/Makefile b/devel/tclreadline/Makefile
index 71f75023f632..43b4365066bb 100644
--- a/devel/tclreadline/Makefile
+++ b/devel/tclreadline/Makefile
@@ -7,7 +7,7 @@
PORTNAME= tclreadline
PORTVERSION= 2.1.0
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= devel tcl80 tcl82 tcl83 tcl84
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= tclreadline
@@ -15,6 +15,7 @@ MASTER_SITE_SUBDIR= tclreadline
MAINTAINER= ports@FreeBSD.org
COMMENT= GNU readline for TCL
+USE_TCL= 80+
USE_AUTOTOOLS= libtool:15
GNU_CONFIGURE= yes
INSTALLS_SHLIB= yes
@@ -22,56 +23,6 @@ MANN= tclreadline.n
PLIST_SUB+= VERSION="${PORTVERSION}"
-.include <bsd.port.pre.mk>
+CONFIGURE_ARGS= --with-tcl=${TCL_LIBDIR} --with-tcl-includes=${TCL_INCLUDEDIR}
-# Try and guess what version of Tcl to build against
-.if (!defined(WITH_TCL80) && !defined(WITH_TCL82) && !defined(WITH_TCL83) && !defined(WITH_TCL84))
-.if exists(${LOCALBASE}/bin/tclsh8.4)
-WITH_TCL84= yes
-.else
-.if exists(${LOCALBASE}/bin/tclsh8.3)
-WITH_TCL83= yes
-.else
-.if exists(${LOCALBASE}/bin/tclsh8.2)
-WITH_TCL82= yes
-.else
-.if exists(${LOCALBASE}/bin/tclsh8.0)
-WITH_TCL80= yes
-.else
-WITH_TCL84= yes
-.endif
-.endif
-.endif
-.endif
-.endif
-
-.if defined(WITH_TCL80)
-LIB_DEPENDS= tcl80.1:${PORTSDIR}/lang/tcl80
-CONFIGURE_ARGS= --with-tcl=${LOCALBASE}/lib/tcl8.0 --with-tcl-includes=${LOCALBASE}/include/tcl8.0
-TCLVERMSG= "Building for Tcl 8.0"
-.endif
-
-.if defined(WITH_TCL82)
-LIB_DEPENDS= tcl82.1:${PORTSDIR}/lang/tcl82
-CONFIGURE_ARGS= --with-tcl=${LOCALBASE}/lib/tcl8.2 --with-tcl-includes=${LOCALBASE}/include/tcl8.2
-TCLVERMSG= "Building for Tcl 8.2"
-.endif
-
-.if defined(WITH_TCL83)
-LIB_DEPENDS= tcl83.1:${PORTSDIR}/lang/tcl83
-CONFIGURE_ARGS= --with-tcl=${LOCALBASE}/lib/tcl8.3 --with-tcl-includes=${LOCALBASE}/include/tcl8.3
-TCLVERMSG= "Building for Tcl 8.3"
-.endif
-
-.if defined(WITH_TCL84)
-LIB_DEPENDS= tcl84.1:${PORTSDIR}/lang/tcl84
-CONFIGURE_ARGS= --with-tcl=${LOCALBASE}/lib/tcl8.4 --with-tcl-includes=${LOCALBASE}/include/tcl8.4
-TCLVERMSG= "Building for Tcl 8.4"
-.endif
-
-pre-fetch:
- @${ECHO} ${TCLVERMSG}
- @${ECHO} "Define WITH_TCL80, WITH_TCL82, WITH_TCL83, or WITH_TCL84"
- @${ECHO} "To compile against a different version of TCL"
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>