aboutsummaryrefslogtreecommitdiff
path: root/devel/tclreadline
diff options
context:
space:
mode:
authorVolker Stolz <vs@FreeBSD.org>2005-12-02 13:00:26 +0000
committerVolker Stolz <vs@FreeBSD.org>2005-12-02 13:00:26 +0000
commitf613507eff341c0f0f0519ccd257ad209acf39fd (patch)
treef263997269bd7fb529d4cb5a74bd207353c2b672 /devel/tclreadline
parent3175500de54ed50410dd707754327b6027a6892b (diff)
downloadports-f613507eff341c0f0f0519ccd257ad209acf39fd.tar.gz
ports-f613507eff341c0f0f0519ccd257ad209acf39fd.zip
Notes
Diffstat (limited to 'devel/tclreadline')
-rw-r--r--devel/tclreadline/Makefile47
1 files changed, 36 insertions, 11 deletions
diff --git a/devel/tclreadline/Makefile b/devel/tclreadline/Makefile
index 50f0679d0e50..254e604d37df 100644
--- a/devel/tclreadline/Makefile
+++ b/devel/tclreadline/Makefile
@@ -7,7 +7,7 @@
PORTNAME= tclreadline
PORTVERSION= 2.1.0
-CATEGORIES= devel tcl80 tcl82
+CATEGORIES= devel tcl80 tcl82 tcl83 tcl84
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= tclreadline
@@ -22,29 +22,54 @@ PLIST_SUB+= VERSION="${PORTVERSION}"
.include <bsd.port.pre.mk>
-.if (!defined(WITH_TCL80) && !defined(WITH_TCL82))
-.if exists(${PREFIX}/bin/tclsh8.0)
-WITH_TCL80= yes
+# Try and guess what version of Tcl to build against
+.if (!defined(WITH_TCL80) && !defined(WITH_TCL82) && !defined(WITH_TCL83) && !defined(WITH_TCL84))
+.if exists(${LOCALBASE}/bin/tclsh8.4)
+WITH_TCL84= yes
+.else
+.if exists(${LOCALBASE}/bin/tclsh8.3)
+WITH_TCL83= yes
.else
+.if exists(${LOCALBASE}/bin/tclsh8.2)
WITH_TCL82= yes
+.else
+.if exists(${LOCALBASE}/bin/tclsh8.0)
+WITH_TCL80= yes
+.else
+WITH_TCL84= yes
+.endif
+.endif
+.endif
.endif
.endif
.if defined(WITH_TCL80)
-LIB_DEPENDS= tcl80.1:${PORTSDIR}/lang/tcl80
-CONFIGURE_ARGS= --with-tcl=${PREFIX}/lib/tcl8.0 --with-tcl-includes=${PREFIX}/include/tcl8.0
-TCLVERMSG= "Building for Tcl 8.0"
+LIB_DEPENDS= tcl80.1:${PORTSDIR}/lang/tcl80
+CONFIGURE_ARGS= --with-tcl=${LOCALBASE}/lib/tcl8.0 --with-tcl-includes=${LOCALBASE}/include/tcl8.0
+TCLVERMSG= "Building for Tcl 8.0"
.endif
.if defined(WITH_TCL82)
-LIB_DEPENDS= tcl82.1:${PORTSDIR}/lang/tcl82
-CONFIGURE_ARGS= --with-tcl=${PREFIX}/lib/tcl8.2 --with-tcl-includes=${PREFIX}/include/tcl8.2
-TCLVERMSG= "Building for Tcl 8.2"
+LIB_DEPENDS= tcl82.1:${PORTSDIR}/lang/tcl82
+CONFIGURE_ARGS= --with-tcl=${LOCALBASE}/lib/tcl8.2 --with-tcl-includes=${LOCALBASE}/include/tcl8.2
+TCLVERMSG= "Building for Tcl 8.2"
+.endif
+
+.if defined(WITH_TCL83)
+LIB_DEPENDS= tcl83.1:${PORTSDIR}/lang/tcl83
+CONFIGURE_ARGS= --with-tcl=${LOCALBASE}/lib/tcl8.3 --with-tcl-includes=${LOCALBASE}/include/tcl8.3
+TCLVERMSG= "Building for Tcl 8.3"
+.endif
+
+.if defined(WITH_TCL84)
+LIB_DEPENDS= tcl84.1:${PORTSDIR}/lang/tcl84
+CONFIGURE_ARGS= --with-tcl=${LOCALBASE}/lib/tcl8.4 --with-tcl-includes=${LOCALBASE}/include/tcl8.4
+TCLVERMSG= "Building for Tcl 8.4"
.endif
pre-fetch:
@${ECHO} ${TCLVERMSG}
- @${ECHO} "Define WITH_TCL80, or WITH_TCL82"
+ @${ECHO} "Define WITH_TCL80, WITH_TCL82, WITH_TCL83, or WITH_TCL84"
@${ECHO} "To compile against a different version of TCL"
.include <bsd.port.post.mk>