aboutsummaryrefslogtreecommitdiff
path: root/devel/tevent
diff options
context:
space:
mode:
authorTimur I. Bakeyev <timur@FreeBSD.org>2010-02-05 00:49:49 +0000
committerTimur I. Bakeyev <timur@FreeBSD.org>2010-02-05 00:49:49 +0000
commit8ad9d41e4a47b723d2b11bc3a582e863cc08a8f5 (patch)
tree0318e7740195e39e958a0b2b04614eb0cee50933 /devel/tevent
parent92f4dc159052507499c9cb50912e8d215e99a376 (diff)
downloadports-8ad9d41e4a47b723d2b11bc3a582e863cc08a8f5.tar.gz
ports-8ad9d41e4a47b723d2b11bc3a582e863cc08a8f5.zip
Notes
Diffstat (limited to 'devel/tevent')
-rw-r--r--devel/tevent/Makefile32
-rw-r--r--devel/tevent/distinfo3
-rw-r--r--devel/tevent/files/patch-tevent.mk35
3 files changed, 55 insertions, 15 deletions
diff --git a/devel/tevent/Makefile b/devel/tevent/Makefile
index a6e84e64fbda..dbf8df0992e0 100644
--- a/devel/tevent/Makefile
+++ b/devel/tevent/Makefile
@@ -6,40 +6,42 @@
#
PORTNAME= tevent
-PORTVERSION?= 0.9.6
+PORTVERSION= 0.9.8
PORTREVISION= 0
PORTEPOCH= 0
CATEGORIES= devel
-PKGNAMESUFFIX=
+MASTER_SITES= ftp://ftp.samba.org/pub/%SUBDIR%/ \
+ ftp://ca.samba.org/pub/%SUBDIR%/ \
+ ftp://de.samba.org/pub/%SUBDIR%/
+MASTER_SITE_SUBDIR= ${PORTNAME}
+MAINTAINER= timur@FreeBSD.org
COMMENT= Talloc based event loop library
-LIB_DEPENDS= talloc.1:${PORTSDIR}/devel/talloc
+LIB_DEPENDS= talloc.2:${PORTSDIR}/devel/talloc
CONFLICTS=
-SAMBA_PORT?= samba4-devel
-SAMBA_SUBPORT= yes
-
-MASTERDIR= ${.CURDIR}/../../net/${SAMBA_PORT}
-PKGDIR= ${.CURDIR}
-
-WRKSRC= ${WRKDIR}/${DISTNAME}/lib/tevent
-
USE_GMAKE= yes
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
USE_GNOME= pkgconfig
USE_AUTOTOOLS= autoconf:262 autoheader:262
+IPATHS= -I${WRKSRC}/libreplace
+AUTOHEADER_ARGS= ${IPATHS}
+AUTOCONF_ARGS= ${IPATHS}
+
+PKGCONFIGDIR?= ${PREFIX}/libdata/pkgconfig
+PKGCONFIGDIR_REL?= ${PKGCONFIGDIR:S|^${PREFIX}/||}
+
PLIST_FILES= include/tevent.h \
- include/tevent_internal.h \
lib/libtevent.a \
lib/libtevent.so \
lib/libtevent.so.0 \
- libdata/pkgconfig/tevent.pc
+ ${PKGCONFIGDIR_REL}/tevent.pc
post-install:
- ${LN} -sf libtevent.so.0 ${PREFIX}/lib/libtevent.so
+ ${LN} -sf libtevent.so.0 ${PREFIX}/lib/libtevent.so
-.include "${MASTERDIR}/Makefile"
+.include <bsd.port.mk>
diff --git a/devel/tevent/distinfo b/devel/tevent/distinfo
new file mode 100644
index 000000000000..548e48c871d9
--- /dev/null
+++ b/devel/tevent/distinfo
@@ -0,0 +1,3 @@
+MD5 (tevent-0.9.8.tar.gz) = edc29f20fb508b6b860d70f0f07ccd3f
+SHA256 (tevent-0.9.8.tar.gz) = b004153b6ec7be3084d5d5cb75d3d4e10628c24f903bc05a634de1d1be280598
+SIZE (tevent-0.9.8.tar.gz) = 236284
diff --git a/devel/tevent/files/patch-tevent.mk b/devel/tevent/files/patch-tevent.mk
new file mode 100644
index 000000000000..c25afaba9ab6
--- /dev/null
+++ b/devel/tevent/files/patch-tevent.mk
@@ -0,0 +1,35 @@
+--- ./tevent.mk.orig 2010-01-08 23:45:07.000000000 +0000
++++ ./tevent.mk 2010-01-08 23:47:23.000000000 +0000
+@@ -1,6 +1,6 @@
+ TEVENT_SOBASE = libtevent.$(SHLIBEXT)
+ TEVENT_SONAME = $(TEVENT_SOBASE).0
+-TEVENT_SOLIB = $(TEVENT_SOBASE).$(PACKAGE_VERSION)
++TEVENT_SOLIB = $(TEVENT_SOBASE).0
+ TEVENT_STLIB = libtevent.a
+
+ $(TEVENT_STLIB): $(TEVENT_OBJ)
+@@ -9,22 +9,19 @@
+ $(TEVENT_SOBASE): $(TEVENT_SOLIB)
+ ln -fs $< $@
+
+-$(TEVENT_SONAME): $(TEVENT_SOLIB)
+- ln -fs $< $@
+-
+ dirs::
+ @mkdir -p lib
+
+ installdirs::
+ mkdir -p $(DESTDIR)$(includedir)
+ mkdir -p $(DESTDIR)$(libdir)
+- mkdir -p $(DESTDIR)$(libdir)/pkgconfig
++ mkdir -p $(DESTDIR)$(prefix)/libdata/pkgconfig
+
+ installheaders:: installdirs
+ cp $(srcdir)/tevent.h $(DESTDIR)$(includedir)
+
+ installlibs:: installdirs
+- cp tevent.pc $(DESTDIR)$(libdir)/pkgconfig
++ cp tevent.pc $(DESTDIR)$(prefix)/libdata/pkgconfig
+ cp $(TEVENT_STLIB) $(TEVENT_SOLIB) $(DESTDIR)$(libdir)
+
+ install:: all installdirs installheaders installlibs $(PYTHON_INSTALL_TARGET)