aboutsummaryrefslogtreecommitdiff
path: root/devel/thrift-cpp
diff options
context:
space:
mode:
authorJohn Marino <marino@FreeBSD.org>2016-09-10 02:50:16 +0000
committerJohn Marino <marino@FreeBSD.org>2016-09-10 02:50:16 +0000
commitedb587a20aeb97557ee62a9b06741f2093a6aef7 (patch)
treec23cf2335594116bc70050936ba8f9780c74e3cc /devel/thrift-cpp
parent12e8d047eee0f3badfd089f052d1a8cf48d729fe (diff)
Notes
Diffstat (limited to 'devel/thrift-cpp')
-rw-r--r--devel/thrift-cpp/Makefile12
1 files changed, 7 insertions, 5 deletions
diff --git a/devel/thrift-cpp/Makefile b/devel/thrift-cpp/Makefile
index 68e9d49d69f3..8a2652dabd0f 100644
--- a/devel/thrift-cpp/Makefile
+++ b/devel/thrift-cpp/Makefile
@@ -18,12 +18,12 @@ DISTINFO_FILE= ${.CURDIR}/../thrift/distinfo
LIB_DEPENDS= libboost_system.so:devel/boost-libs \
libevent.so:devel/libevent2
-USES= autoreconf pkgconfig gmake compiler:c++11-lang libtool
+USES= autoreconf pkgconfig gmake compiler:c++11-lang \
+ libtool ssl
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
MAKE_JOBS_UNSAFE= yes
PLIST_SUB= PORTVERSION="${THRIFT_PORTVERSION}"
-USE_OPENSSL= yes
OPTIONS_DEFINE= QT4
QT4_CONFIGURE_WITH= qt4
@@ -45,13 +45,15 @@ CONFIGURE_ARGS+= \
--without-ruby \
--without-go
+LDFLAGS+= -L${OPENSSLLIB}
+CFLAGS+= -I${OPENSSLINC}
+
.include <bsd.port.pre.mk>
-.if ${SSL_DEFAULT} == base && \
- ${OPSYS} == FreeBSD && ${OSVERSION} < 1000015
+.if ${SSL_DEFAULT} == base
# src/thrift/transport/TSSLSocket.cpp:147: error: 'TLSv1_1_method' was not declared in this scope
# src/thrift/transport/TSSLSocket.cpp:149: error: 'TLSv1_2_method' was not declared in this scope
-BROKEN= does not build with 9.x base OpenSSL
+BROKEN_FreeBSD_9= does not build with 9.x base OpenSSL
.endif
.if ${COMPILER_TYPE} == clang