aboutsummaryrefslogtreecommitdiff
path: root/devel/thrift/Makefile
diff options
context:
space:
mode:
authorSergey Skvortsov <skv@FreeBSD.org>2009-12-21 18:40:15 +0000
committerSergey Skvortsov <skv@FreeBSD.org>2009-12-21 18:40:15 +0000
commitcc31c91465b56789b1012db6d3c1a6af451cecee (patch)
tree66ca3f868b206f173c6d7ad54bf6fab79a986278 /devel/thrift/Makefile
parenteaa6e7aadeb7da51aba2f8b27ff026bf659624c0 (diff)
Notes
Diffstat (limited to 'devel/thrift/Makefile')
-rw-r--r--devel/thrift/Makefile31
1 files changed, 8 insertions, 23 deletions
diff --git a/devel/thrift/Makefile b/devel/thrift/Makefile
index f06feb490c56..d9375e52eb9d 100644
--- a/devel/thrift/Makefile
+++ b/devel/thrift/Makefile
@@ -6,10 +6,12 @@
#
PORTNAME= thrift
-PORTVERSION= 20090622
+PORTVERSION= 0.2.0
+PORTEPOCH= 1
CATEGORIES= devel
-MASTER_SITES= ${MASTER_SITE_LOCAL}
-MASTER_SITE_SUBDIR= bms
+MASTER_SITES= APACHE
+MASTER_SITE_SUBDIR= incubator/thrift/${PORTVERSION}-incubating
+DISTNAME= thrift-${PORTVERSION}-incubating
MAINTAINER= skv@FreeBSD.org
COMMENT= Framework for scalable cross-language services development
@@ -20,17 +22,19 @@ LIB_DEPENDS= boost_iostreams:${PORTSDIR}/devel/boost-libs \
USE_AUTOTOOLS= autoconf:262:env autoheader:262:env aclocal:19:env \
automake:19:env libtool:22:env
USE_GNOME= pkgconfig
-USE_BZIP2= yes
USE_GCC= 4.2+
GNU_CONFIGURE= yes
USE_GMAKE= yes
USE_LDCONFIG= yes
MAKE_JOBS_UNSAFE= yes
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
CONFIGURE_ARGS= --with-boost=${LOCALBASE} --with-libevent=${LOCALBASE} \
--enable-shared --enable-static --with-zlib
CONFIGURE_ENV+= ${MAKE_ENV}
+# For Erlang support, use devel/erlang-thrift.
+# For Perl support, use devel/p5-Thrift.
# For Python support, use devel/py-thrift.
# For Ruby support, use devel/ruby-thrift.
# Other languages are not yet supported, please feel free to contribute
@@ -49,25 +53,6 @@ CONFIGURE_ARGS+= \
BROKEN= Does not compile on sparc64
.endif
-#
-# To roll snapshot: as bms: env BOOTSTRAP=defined make fetch
-#
-.if defined(BOOTSTRAP)
-FETCH_DEPENDS+= svn:${PORTSDIR}/devel/subversion
-SVN_REV= 787160 # svn tip at epoch 20090622
-SVNROOT_URI= http://svn.apache.org/repos/asf/incubator/thrift
-
-do-fetch:
- ${MKDIR} ${WRKDIR}
- svn export -r ${SVN_REV} ${SVNROOT_URI}/trunk ${WRKSRC}
- cd ${WRKDIR}; tar cvfy ${DISTDIR}/${DISTNAME}.tar.bz2 ${DISTNAME}
-.if ${USER} == bms
- ${CHMOD} ugo+r ${DISTDIR}/${DISTNAME}.tar.bz2
- scp -p ${DISTDIR}/${DISTNAME}.tar.bz2 \
- freefall.freebsd.org:public_distfiles/
-.endif
-.endif # defined(BOOTSTRAP)
-
do-patch:
@${REINPLACE_CMD} 's,^pkgconfigdir = .*,pkgconfigdir=$${prefix}/libdata/pkgconfig,' ${WRKSRC}/lib/cpp/Makefile.am