aboutsummaryrefslogtreecommitdiff
path: root/devel/tide
diff options
context:
space:
mode:
authorWill Andrews <will@FreeBSD.org>2001-04-07 22:59:53 +0000
committerWill Andrews <will@FreeBSD.org>2001-04-07 22:59:53 +0000
commitf47cc9dd83130eff15e3890b8e6c370cf553dcf9 (patch)
tree300aec7fc1a9f9f7e6a3bcb4e0d95e3bb406a40b /devel/tide
parent56885aa4eb5393137c8ff8413211ce8a3bb1d400 (diff)
downloadports-f47cc9dd83130eff15e3890b8e6c370cf553dcf9.tar.gz
ports-f47cc9dd83130eff15e3890b8e6c370cf553dcf9.zip
Notes
Diffstat (limited to 'devel/tide')
-rw-r--r--devel/tide/Makefile22
-rw-r--r--devel/tide/distinfo1
-rw-r--r--devel/tide/pkg-comment1
-rw-r--r--devel/tide/pkg-descr23
-rw-r--r--devel/tide/pkg-plist46
5 files changed, 93 insertions, 0 deletions
diff --git a/devel/tide/Makefile b/devel/tide/Makefile
new file mode 100644
index 000000000000..5a100082ae82
--- /dev/null
+++ b/devel/tide/Makefile
@@ -0,0 +1,22 @@
+# New ports collection makefile for: tide
+# Date created: 16 October 2000
+# Whom: Nils M Holm <nmh@t3x.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= tide
+PORTVERSION= 1.4
+CATEGORIES= devel
+MASTER_SITES= http://www.t3x.org/Compiler/ \
+ http://www.homepages.de/home/nmh/T3X/Compiler/
+DISTNAME= tide-${PORTVERSION:S/.//g}
+
+MAINTAINER= nmh@t3x.org
+
+BUILD_DEPENDS= tx:${PORTSDIR}/lang/t3x
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+MAKE_ENV+= T3XDIR=/usr/local/t3x/r6
+
+.include <bsd.port.mk>
diff --git a/devel/tide/distinfo b/devel/tide/distinfo
new file mode 100644
index 000000000000..8f09c153f20e
--- /dev/null
+++ b/devel/tide/distinfo
@@ -0,0 +1 @@
+MD5 (tide-14.tar.gz) = 56bc159314a3166b6438948e310698d7
diff --git a/devel/tide/pkg-comment b/devel/tide/pkg-comment
new file mode 100644
index 000000000000..21d5dcd239c7
--- /dev/null
+++ b/devel/tide/pkg-comment
@@ -0,0 +1 @@
+T3X Integrated Development Environment and T3X Tool classes
diff --git a/devel/tide/pkg-descr b/devel/tide/pkg-descr
new file mode 100644
index 000000000000..8fc03b315ece
--- /dev/null
+++ b/devel/tide/pkg-descr
@@ -0,0 +1,23 @@
+TIDE is the T3X Integrated Development Environment. Basically, it
+is a text editor with an integrated interface to the T3X compiler.
+T3X 6.8 or a later version is recommended to run TIDE. The main
+purposes of TIDE are:
+
+. editing source programs
+. compiling programs without leaving the editor
+. locating formal errors
+. running programs
+
+T3Xtools is a set of classes which provides some frequently
+used functionality like
+
+. managing configuration files
+. visually and non-visually editing ASCII text
+. navigating directory trees and selecting files
+. displaying and editing forms
+. presenting menu boxes and prompt boxes
+
+WWW: http://www.t3x.org/
+
+--
+Nils M Holm <nmh@t3x.org>
diff --git a/devel/tide/pkg-plist b/devel/tide/pkg-plist
new file mode 100644
index 000000000000..e61fca8feec7
--- /dev/null
+++ b/devel/tide/pkg-plist
@@ -0,0 +1,46 @@
+bin/tide
+t3x/r6/classes/config.cls
+t3x/r6/classes/config.dir
+t3x/r6/classes/editor.cls
+t3x/r6/classes/editor.dir
+t3x/r6/classes/filebox.cls
+t3x/r6/classes/filebox.dir
+t3x/r6/classes/form.cls
+t3x/r6/classes/form.dir
+t3x/r6/classes/menu.cls
+t3x/r6/classes/menu.dir
+t3x/r6/classes/prompt.cls
+t3x/r6/classes/prompt.dir
+t3x/r6/classes/tblio.cls
+t3x/r6/classes/tblio.dir
+t3x/r6/classes/vedit.cls
+t3x/r6/classes/vedit.dir
+t3x/r6/doc/tide.sd
+t3x/r6/doc/tools.sd
+t3x/r6/tide.rc
+t3x/r6/tide/default.cs
+t3x/r6/tide/examples/apfel.t
+t3x/r6/tide/examples/fac.t
+t3x/r6/tide/examples/hello.t
+t3x/r6/tide/examples/hello2.t
+t3x/r6/tide/examples/hello3.t
+t3x/r6/tide/examples/permute.t
+t3x/r6/tide/examples/primes.t
+t3x/r6/tide/examples/ttt.t
+t3x/r6/tide/helpfile
+t3x/r6/tide/monochrm.cs
+t3x/r6/tide/tide
+@exec echo 'config:t3x,iostream,string,ttyctl' >>%D/t3x/r6/classes/CLASSNDX
+@exec echo 'editor:t3x,string' >>%D/t3x/r6/classes/CLASSNDX
+@exec echo 'tblio:t3x,string,iostream' >>%D/t3x/r6/classes/CLASSNDX
+@exec echo 'filebox:t3x,string,system,ttyctl' >>%D/t3x/r6/classes/CLASSNDX
+@exec echo 'form:t3x,ttyctl,menu,prompt' >>%D/t3x/r6/classes/CLASSNDX
+@exec echo 'menu:t3x,string,ttyctl' >>%D/t3x/r6/classes/CLASSNDX
+@exec echo 'prompt:t3x,string,ttyctl' >>%D/t3x/r6/classes/CLASSNDX
+@exec echo 'vedit:t3x,string,ttyctl,editor' >>%D/t3x/r6/classes/CLASSNDX
+@exec sh -c 'if ! grep -q tools.sd %D/t3x/r6/doc/sdv-config; then echo "file = tools.sd [THE T3XTOOLS CLASSES]">>%D/t3x/r6/doc/sdv-config; fi'
+@exec sh -c 'if ! grep -q tide.sd %D/t3x/r6/doc/sdv-config; then echo "file = tide.sd [TIDE DOCUMENTATION]" >>%D/t3x/r6/doc/sdv-config; fi'
+@unexec cp %D/t3x/r6/doc/sdv-config %D/t3x/r6/sdv.tmp && grep -v 'tools\.sd' %D/t3x/r6/sdv.tmp | grep -v 'tide\.sd' >%D/t3x/r6/doc/sdv-config && rm -f %D/t3x/r6/sdv.tmp
+@unexec sed -e '/^config:/,/^vedit:/d' <%D/t3x/r6/classes/CLASSNDX >%D/t3x/ndx.tmp && mv %D/t3x/ndx.tmp %D/t3x/r6/classes/CLASSNDX
+@dirrm t3x/r6/tide/examples
+@dirrm t3x/r6/tide