aboutsummaryrefslogtreecommitdiff
path: root/devel/tkcon/Makefile
diff options
context:
space:
mode:
authorChris Piazza <cpiazza@FreeBSD.org>1999-06-29 05:32:38 +0000
committerChris Piazza <cpiazza@FreeBSD.org>1999-06-29 05:32:38 +0000
commit6c53332d69006710ab7b2f4d537b9d4d647db4f2 (patch)
tree4ea986cc1390cbbf1dde111a252b7df1b3ebef96 /devel/tkcon/Makefile
parent9ac2c203678dd4288837a3c27802df451e6aa15f (diff)
downloadports-6c53332d69006710ab7b2f4d537b9d4d647db4f2.tar.gz
ports-6c53332d69006710ab7b2f4d537b9d4d647db4f2.zip
Notes
Diffstat (limited to 'devel/tkcon/Makefile')
-rw-r--r--devel/tkcon/Makefile32
1 files changed, 32 insertions, 0 deletions
diff --git a/devel/tkcon/Makefile b/devel/tkcon/Makefile
new file mode 100644
index 000000000000..f24eb77f9ff8
--- /dev/null
+++ b/devel/tkcon/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: tkcon
+# Version required: 1.6
+# Date created: 28 Jun 1999
+# Whom: wghicks@bellsouth.net
+#
+# $Id$
+#
+
+DISTNAME= tkcon-1.6
+CATEGORIES= devel tk80
+MASTER_SITES= ftp://ftp.neosoft.com/languages/tcl/sorted/devel/
+
+MAINTAINER= wghicks@bellsouth.net
+
+RUN_DEPENDS= wish8.0:${PORTSDIR}/x11-toolkits/tk80
+
+NO_BUILD= yes
+
+post-patch:
+ @${PERL} -pi -e 's:/usr/local:${PREFIX}:' ${WRKSRC}/tkcon.tcl
+
+do-install:
+ ${INSTALL_SCRIPT} ${WRKSRC}/tkcon.tcl ${PREFIX}/bin/tkcon
+
+post-install:
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${PREFIX}/share/doc/tkcon
+ ${INSTALL_DATA} ${WRKSRC}/README.txt $(PREFIX)/share/doc/tkcon/README.tkcon
+ ${INSTALL_DATA} ${WRKSRC}/docs/* $(PREFIX)/share/doc/tkcon
+.endif
+
+.include <bsd.port.mk>