aboutsummaryrefslogtreecommitdiff
path: root/devel/tla
diff options
context:
space:
mode:
authorSean Chittenden <seanc@FreeBSD.org>2003-08-17 22:01:07 +0000
committerSean Chittenden <seanc@FreeBSD.org>2003-08-17 22:01:07 +0000
commit0d3e362811c30c359091847e87a39f74a8812588 (patch)
treec8548cf578b8c91e6c3274c91ce00e0b7c28c6ca /devel/tla
parentd100383ce723d0fa91b8777fe02651e97bc75120 (diff)
downloadports-0d3e362811c30c359091847e87a39f74a8812588.tar.gz
ports-0d3e362811c30c359091847e87a39f74a8812588.zip
Notes
Diffstat (limited to 'devel/tla')
-rw-r--r--devel/tla/Makefile42
-rw-r--r--devel/tla/distinfo1
-rw-r--r--devel/tla/pkg-descr9
-rw-r--r--devel/tla/pkg-plist2
4 files changed, 54 insertions, 0 deletions
diff --git a/devel/tla/Makefile b/devel/tla/Makefile
new file mode 100644
index 000000000000..132670cc4f9e
--- /dev/null
+++ b/devel/tla/Makefile
@@ -0,0 +1,42 @@
+# Ports collection makefile for: tla
+# Date Created: August 17th, 2003
+# Whom: seanc
+#
+# $FreeBSD$
+#
+
+PORTNAME= tla
+PORTVERSION= 1.1.pre5
+CATEGORIES= devel
+MASTER_SITES= http://regexps.srparish.net/src/tla/
+DISTNAME= tla-1.1pre5
+
+MAINTAINER= seanc@FreeBSD.org
+COMMENT= The original arch source control management CLI written in C
+
+GNU_CONFIGURE= yes
+USE_GMAKE= yes
+
+ORIGWRKSRC= ${WRKDIR}/${DISTNAME}/src
+WRKSRC= ${ORIGWRKSRC}/=build
+
+pre-configure:
+ ${MKDIR} ${WRKSRC}
+
+do-configure:
+ cd ${WRKSRC} ; ../configure --prefix ${LOCALBASE}
+
+test:
+ cd ${WRKSRC} ; ${GMAKE} test
+
+.if !defined(NOPORTDOCS)
+post-install:
+ ${MKDIR} ${DOCSDIR}; \
+ for f in `find ${ORIGWRKSRC}/docs-tla/html -type f -name '*.html' -exec ${BASENAME} {} \;`; do \
+ ${INSTALL_DATA} ${ORIGWRKSRC}/docs-tla/html/$$f ${DOCSDIR}/; \
+ printf "share/doc/${PORTNAME}/%s\n" $$f >> ${TMPPLIST}; \
+ done; \
+ ${ECHO} @dirrm share/doc/${PORTNAME} >> ${TMPPLIST}
+.endif
+
+.include <bsd.port.mk>
diff --git a/devel/tla/distinfo b/devel/tla/distinfo
new file mode 100644
index 000000000000..23bfb5a8722e
--- /dev/null
+++ b/devel/tla/distinfo
@@ -0,0 +1 @@
+MD5 (tla-1.1pre5.tar.gz) = 16512739150bdb81764a9d2fffb6a423
diff --git a/devel/tla/pkg-descr b/devel/tla/pkg-descr
new file mode 100644
index 000000000000..f04a44f5469c
--- /dev/null
+++ b/devel/tla/pkg-descr
@@ -0,0 +1,9 @@
+Arch is a really nifty revision control system. It's "whole-tree
+changeset based" which means, roughly, that it can handle (with atomic
+commits) file and directory adds, deletes, and renames cleanly, and
+that it does branching simply and easily. Arch is also "distributed"
+which means, for example that you can make arch branches of your own
+from remote projects, even if you don't have write access to the
+revision control archives for those projects.
+
+WWW: http://arch.fifthvision.net/bin/view
diff --git a/devel/tla/pkg-plist b/devel/tla/pkg-plist
new file mode 100644
index 000000000000..0465aaa9d0c5
--- /dev/null
+++ b/devel/tla/pkg-plist
@@ -0,0 +1,2 @@
+bin/tla
+@comment automatically generated plist for docs