aboutsummaryrefslogtreecommitdiff
path: root/devel/tokamak
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2008-06-24 11:04:50 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2008-06-24 11:04:50 +0000
commit01a9ddb50e3dfe7cac89ea3fd9172aeedf41de37 (patch)
tree6e126a0aaf83aebd929f24a6ce59ab721817c2bf /devel/tokamak
parent19b99d8af67f50a18c12db649270ae86a948ce44 (diff)
downloadports-01a9ddb50e3dfe7cac89ea3fd9172aeedf41de37.tar.gz
ports-01a9ddb50e3dfe7cac89ea3fd9172aeedf41de37.zip
Notes
Diffstat (limited to 'devel/tokamak')
-rw-r--r--devel/tokamak/Makefile55
-rw-r--r--devel/tokamak/distinfo3
-rw-r--r--devel/tokamak/files/patch-build-gnu-tokamak.make42
-rw-r--r--devel/tokamak/pkg-descr7
-rw-r--r--devel/tokamak/pkg-plist15
5 files changed, 122 insertions, 0 deletions
diff --git a/devel/tokamak/Makefile b/devel/tokamak/Makefile
new file mode 100644
index 000000000000..b47235756005
--- /dev/null
+++ b/devel/tokamak/Makefile
@@ -0,0 +1,55 @@
+# New ports collection makefile for: tokamak
+# Date created: 24 Jun 2008
+# Whom: Dmitry Marakasov <amdmi3@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= tokamak
+PORTVERSION= 1.0.5a
+CATEGORIES= devel
+MASTER_SITES= SF
+MASTER_SITE_SUBDIR= tokamakp
+DISTNAME= ${PORTNAME}_${PORTVERSION}
+
+MAINTAINER= amdmi3@FreeBSD.org
+COMMENT= High performance real-time physics library
+
+USE_ZIP= yes
+USE_GMAKE= yes
+USE_DOS2UNIX= *
+
+MAKE_ENV= CC=${CC} CXX=${CXX}
+MAKEFILE= tokamak.make
+ALL_TARGET=
+
+WRKSRC= ${WRKDIR}/tokamak_release
+BUILD_WRKSRC= ${WRKSRC}/build/gnu
+
+PORTDOCS= *
+
+.include <bsd.port.pre.mk>
+
+.if !defined(WITH_DEBUG)
+MAKE_ENV+= CPPFLAGS=-DNDEBUG
+.endif
+
+post-extract:
+ @cd ${WRKSRC} && ${UNZIP_CMD} -q tokamak-premake.zip
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|malloc.h|stdlib.h|' ${WRKSRC}/include/tokamak.h
+
+do-install:
+ ${MKDIR} ${PREFIX}/include/math/
+ ${INSTALL_DATA} ${WRKSRC}/include/tokamak.h ${PREFIX}/include/
+ ${INSTALL_DATA} ${WRKSRC}/include/math/*.h ${PREFIX}/include/math/
+ ${INSTALL_DATA} ${WRKSRC}/lib/libtokamak_m.a ${PREFIX}/lib/
+
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/license.txt ${WRKSRC}/readme.txt ${DOCSDIR}
+ cd ${WRKSRC}/documentation && ${COPYTREE_SHARE} . ${DOCSDIR}
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/devel/tokamak/distinfo b/devel/tokamak/distinfo
new file mode 100644
index 000000000000..691126ad65ed
--- /dev/null
+++ b/devel/tokamak/distinfo
@@ -0,0 +1,3 @@
+MD5 (tokamak_1.0.5a.zip) = fb2df0580d506aa72a5acce49801e531
+SHA256 (tokamak_1.0.5a.zip) = 56c7e5d3f6f4852fee16540d9a90e068fa33f5ff8c9b35d45f304d19176ffcab
+SIZE (tokamak_1.0.5a.zip) = 2085830
diff --git a/devel/tokamak/files/patch-build-gnu-tokamak.make b/devel/tokamak/files/patch-build-gnu-tokamak.make
new file mode 100644
index 000000000000..f196383a76e8
--- /dev/null
+++ b/devel/tokamak/files/patch-build-gnu-tokamak.make
@@ -0,0 +1,42 @@
+--- build/gnu/tokamak.make.orig 2008-06-24 00:30:13.000000000 +0400
++++ build/gnu/tokamak.make 2008-06-24 00:31:55.000000000 +0400
+@@ -2,7 +2,7 @@
+ # Don't edit this file! Instead edit `premake.lua` then rerun `make`
+
+ ifndef CONFIG
+- CONFIG=Debug
++ CONFIG=Release
+ endif
+
+ ifeq ($(CONFIG),Debug)
+@@ -25,9 +25,9 @@
+ LIBDIR := ../../lib
+ OBJDIR := obj/Release
+ OUTDIR := ../../lib
+- CPPFLAGS := -MMD -D "WIN32" -D "_LIB" -D "_CRT_SECURE_NO_DEPRECATE" -D "NDEBUG" -I "../../include/"
+- CFLAGS += $(CPPFLAGS) $(TARGET_ARCH) -O2
+- CXXFLAGS := $(CFLAGS) --no-exceptions --no-rtti
++ CPPFLAGS += -I "../../include/"
++ CFLAGS += $(CPPFLAGS)
++ CXXFLAGS += $(CPPFLAGS) --no-exceptions --no-rtti
+ LDFLAGS += -L$(BINDIR) -L$(LIBDIR) -s
+ LDDEPS :=
+ RESFLAGS := -D "WIN32" -D "_LIB" -D "_CRT_SECURE_NO_DEPRECATE" -D "NDEBUG" -I "../../include/"
+@@ -44,7 +44,7 @@
+ $(OBJDIR)/dcd.o \
+ $(OBJDIR)/lines.o \
+ $(OBJDIR)/ne_interface.o \
+- $(OBJDIR)/perfwin32.o \
++ $(OBJDIR)/perflinux.o \
+ $(OBJDIR)/region.o \
+ $(OBJDIR)/restcontact.o \
+ $(OBJDIR)/rigidbody.o \
+@@ -139,7 +139,7 @@
+ @echo $(notdir $<)
+ @$(CXX) $(CXXFLAGS) -o $@ -c $<
+
+-$(OBJDIR)/perfwin32.o: ../../tokamaksrc/src/perfwin32.cpp
++$(OBJDIR)/perflinux.o: ../../tokamaksrc/src/perflinux.cpp
+ -@$(CMD_MKOBJDIR)
+ @echo $(notdir $<)
+ @$(CXX) $(CXXFLAGS) -o $@ -c $<
diff --git a/devel/tokamak/pkg-descr b/devel/tokamak/pkg-descr
new file mode 100644
index 000000000000..9b4bc8beb4b8
--- /dev/null
+++ b/devel/tokamak/pkg-descr
@@ -0,0 +1,7 @@
+Tokamak Game Physics SDK is a high performance real-time physics
+library designed specially for games. It has a high-level, simple
+to use programming interface. With Tokamak, game developers and
+designers are empowered to produce the next generation of interactive
+games.
+
+WWW: http://www.tokamakphysics.com/
diff --git a/devel/tokamak/pkg-plist b/devel/tokamak/pkg-plist
new file mode 100644
index 000000000000..10f257e18840
--- /dev/null
+++ b/devel/tokamak/pkg-plist
@@ -0,0 +1,15 @@
+include/math/ne_debug.h
+include/math/ne_math.h
+include/math/ne_math_m3_inline.h
+include/math/ne_math_m4_inline.h
+include/math/ne_math_misc_inline.h
+include/math/ne_math_q_inline.h
+include/math/ne_math_t3_inline.h
+include/math/ne_math_v2_inline.h
+include/math/ne_math_v3_inline.h
+include/math/ne_math_v4_inline.h
+include/math/ne_smath.h
+include/math/ne_type.h
+include/tokamak.h
+lib/libtokamak_m.a
+@dirrm include/math