aboutsummaryrefslogtreecommitdiff
path: root/devel/trio
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2001-06-03 06:57:09 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2001-06-03 06:57:09 +0000
commitf67f0b4174d0dcdc18db4bcec0f077ee3b8d443e (patch)
treef68114a9f0374dbe936d02ef694931530e3706f1 /devel/trio
parent2a2f708e8e722a5977f6ca130afb447e7ccae900 (diff)
downloadports-f67f0b4174d0dcdc18db4bcec0f077ee3b8d443e.tar.gz
ports-f67f0b4174d0dcdc18db4bcec0f077ee3b8d443e.zip
Notes
Diffstat (limited to 'devel/trio')
-rw-r--r--devel/trio/Makefile31
-rw-r--r--devel/trio/distinfo1
-rw-r--r--devel/trio/pkg-comment1
-rw-r--r--devel/trio/pkg-descr12
-rw-r--r--devel/trio/pkg-plist3
5 files changed, 48 insertions, 0 deletions
diff --git a/devel/trio/Makefile b/devel/trio/Makefile
new file mode 100644
index 000000000000..6e770fcc2d38
--- /dev/null
+++ b/devel/trio/Makefile
@@ -0,0 +1,31 @@
+# ex:ts=8
+# New ports collection makefile for: trio
+# Date created: Jun 3, 2001
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= trio
+PORTVERSION= 1.3
+CATEGORIES= devel
+MASTER_SITES= http://www.contactor.se/~dast/stuff/
+
+MAINTAINER= ijliao@FreeBSD.org
+
+MANCOMPRESSED= no
+MAN3= trio_printf.3 trio_scanf.3 trio_register.3 strio.3
+
+post-patch:
+ @${PERL} -pi -e "s,^CFLAGS,#CFLAGS,g" ${WRKSRC}/Makefile
+
+do-install:
+.for file in trio.h triop.h
+ ${INSTALL_DATA} ${WRKSRC}/${file} ${PREFIX}/include
+.endfor
+ ${INSTALL_DATA} ${WRKSRC}/libtrio.a ${PREFIX}/lib
+.for file in ${MAN3}
+ ${INSTALL_MAN} ${WRKSRC}/man/man3/${file} ${MANPREFIX}/man/man3
+.endfor
+
+.include <bsd.port.mk>
diff --git a/devel/trio/distinfo b/devel/trio/distinfo
new file mode 100644
index 000000000000..e88b81579f57
--- /dev/null
+++ b/devel/trio/distinfo
@@ -0,0 +1 @@
+MD5 (trio-1.3.tar.gz) = 81035929ba937f4fb49d07f44e699529
diff --git a/devel/trio/pkg-comment b/devel/trio/pkg-comment
new file mode 100644
index 000000000000..6a3059e53771
--- /dev/null
+++ b/devel/trio/pkg-comment
@@ -0,0 +1 @@
+A fully matured and stable set of printf and string functions
diff --git a/devel/trio/pkg-descr b/devel/trio/pkg-descr
new file mode 100644
index 000000000000..d217eb169afe
--- /dev/null
+++ b/devel/trio/pkg-descr
@@ -0,0 +1,12 @@
+Trio is a fully matured and stable set of printf and string functions designed
+be used by applications with focus on portability or with the need for
+additional features that are not supported by standard stdio implementation.
+
+There are several cases where you may want to consider using trio:
+
+ 1.Portability across heterogeneous platforms.
+ 2.Embedded systems without stdio support.
+ 3.Extendability of unsupported features.
+ 4.Your native version don't do everything you need.
+
+WWW: http://www.contactor.se/~dast/trio/
diff --git a/devel/trio/pkg-plist b/devel/trio/pkg-plist
new file mode 100644
index 000000000000..5e576ba69f72
--- /dev/null
+++ b/devel/trio/pkg-plist
@@ -0,0 +1,3 @@
+include/trio.h
+include/triop.h
+lib/libtrio.a