aboutsummaryrefslogtreecommitdiff
path: root/devel/ucpp
diff options
context:
space:
mode:
authorWesley Shields <wxs@FreeBSD.org>2011-04-06 14:28:01 +0000
committerWesley Shields <wxs@FreeBSD.org>2011-04-06 14:28:01 +0000
commitcb5f16720bbf657b588bf30199393967dd4a7dcd (patch)
treece06d2a78920ecc18759f3a56dffdde5096338a7 /devel/ucpp
parentbee041cdc831c9a6617e5d3f2d49f607103b7fc6 (diff)
downloadports-cb5f16720bbf657b588bf30199393967dd4a7dcd.tar.gz
ports-cb5f16720bbf657b588bf30199393967dd4a7dcd.zip
Notes
Diffstat (limited to 'devel/ucpp')
-rw-r--r--devel/ucpp/Makefile6
-rw-r--r--devel/ucpp/distinfo5
-rw-r--r--devel/ucpp/files/patch-Makefile25
-rw-r--r--devel/ucpp/files/patch-cpp.c22
-rw-r--r--devel/ucpp/pkg-descr2
5 files changed, 45 insertions, 15 deletions
diff --git a/devel/ucpp/Makefile b/devel/ucpp/Makefile
index 4476974e6008..b9e5fe1b9652 100644
--- a/devel/ucpp/Makefile
+++ b/devel/ucpp/Makefile
@@ -9,16 +9,16 @@
PORTNAME= ucpp
PORTVERSION= 1.3
CATEGORIES= devel
-MASTER_SITES= http://pornin.nerim.net/ucpp/
+MASTER_SITES= GOOGLE_CODE
MAINTAINER= ports@FreeBSD.org
COMMENT= A C preprocessor and lexer
-DEPRECATED= Upstream disapear and distfile is no more available
-EXPIRATION_DATE= 2011-05-01
+LICENSE= BSD
MAN1= ucpp.1
PLIST_FILES= bin/ucpp
+USE_GMAKE= yes
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
diff --git a/devel/ucpp/distinfo b/devel/ucpp/distinfo
index 392d98013735..c30c86b3c353 100644
--- a/devel/ucpp/distinfo
+++ b/devel/ucpp/distinfo
@@ -1,3 +1,2 @@
-MD5 (ucpp-1.3.tar.gz) = f6f508ab42dd3eb57c0411a25429c9e8
-SHA256 (ucpp-1.3.tar.gz) = 6057028d96d349acd3de39a83f88f5772c422f822beb7f139dca8eabcf058bfa
-SIZE (ucpp-1.3.tar.gz) = 91537
+SHA256 (ucpp-1.3.tar.gz) = d81bff52769325497d7663356ebebb358991e4c820b43aa60c40d65a29e9c376
+SIZE (ucpp-1.3.tar.gz) = 91626
diff --git a/devel/ucpp/files/patch-Makefile b/devel/ucpp/files/patch-Makefile
index b357f843dfc0..50aca81e81ff 100644
--- a/devel/ucpp/files/patch-Makefile
+++ b/devel/ucpp/files/patch-Makefile
@@ -1,22 +1,31 @@
---- Makefile.orig Wed Jan 15 02:07:44 2003
-+++ Makefile Sun Jul 27 14:51:51 2003
+--- Makefile.orig 2008-10-01 21:15:41.000000000 +0400
++++ Makefile 2011-03-17 21:05:49.000000000 +0300
@@ -56,8 +56,8 @@
#FLAGS = -O -m -DMEM_CHECK
# for gcc
-CC = gcc
--FLAGS = -g -W -Wall -ansi -DAUDIT -DMEM_DEBUG
+-FLAGS = -O3 -W -Wall -ansi
+CC ?= gcc
+FLAGS = -ansi -DAUDIT -DMEM_DEBUG
+ #FLAGS = -g -W -Wall -ansi -DAUDIT -DMEM_DEBUG
#FLAGS = -O3 -mcpu=pentiumpro -fomit-frame-pointer -W -Wall -ansi -DMEM_CHECK
#FLAGS = -O -pg -W -Wall -ansi -DMEM_CHECK
- #LDFLAGS = -pg
-@@ -80,7 +80,7 @@
+@@ -78,7 +78,7 @@
+ #LIBS = libefence.a
+ #LIBS = -lgc_dbg
+
+-#STAND_ALONE = -DSTAND_ALONE
++STAND_ALONE = -DSTAND_ALONE
+
+ ifdef STAND_ALONE
+ FINAL_STEP = $(CC) $(LDFLAGS) -o ucpp $(COBJ) $(LIBS)
+@@ -87,7 +87,7 @@
# ----- nothing should be changed below this line -----
COBJ = mem.o nhash.o cpp.o lexer.o assert.o macro.o eval.o
--CFLAGS = $(FLAGS) -DSTAND_ALONE
-+CFLAGS += $(FLAGS) -DSTAND_ALONE
+-CFLAGS = $(FLAGS) $(STAND_ALONE)
++CFLAGS += $(FLAGS) $(STAND_ALONE)
all: ucpp
-
+ @ar cq libucpp.a *.o
diff --git a/devel/ucpp/files/patch-cpp.c b/devel/ucpp/files/patch-cpp.c
new file mode 100644
index 000000000000..426b5b2e6bfd
--- /dev/null
+++ b/devel/ucpp/files/patch-cpp.c
@@ -0,0 +1,22 @@
+--- cpp.c.orig 2008-10-01 21:15:41.000000000 +0400
++++ cpp.c 2011-03-17 21:08:15.000000000 +0300
+@@ -65,8 +65,8 @@
+ FILE *emit_output;
+
+ #ifdef STAND_ALONE
+-static char *system_macros_def[] = { STD_MACROS, 0 };
+-static char *system_assertions_def[] = { STD_ASSERT, 0 };
++static char *system_macros_def[] = { "/usr/include", 0 };
++static char *system_assertions_def[] = { "", 0 };
+ #endif
+
+ char *current_filename = 0, *current_long_filename = 0;
+@@ -2364,7 +2364,7 @@
+ char *filename = 0;
+ int with_std_incpath = 1;
+ int print_version = 0, print_defs = 0, print_asserts = 0;
+- int system_macros = 0, standard_assertions = 1;
++ int system_macros = 0, standard_assertions = 0;
+
+ init_lexer_state(ls);
+ ls->flags = DEFAULT_CPP_FLAGS;
diff --git a/devel/ucpp/pkg-descr b/devel/ucpp/pkg-descr
index 86065002053e..0673b215bbaf 100644
--- a/devel/ucpp/pkg-descr
+++ b/devel/ucpp/pkg-descr
@@ -6,4 +6,4 @@ ucpp is a C preprocessor and lexer. It has the following goals:
- Possibility to use the code as a lexer (that outputs tokens
directly)
-WWW: http://pornin.nerim.net/ucpp/
+WWW: http://code.google.com/p/ucpp/