aboutsummaryrefslogtreecommitdiff
path: root/devel/ucpp
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2002-12-22 17:49:09 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2002-12-22 17:49:09 +0000
commitbaa97de7de048fb95b5f0bfec51d3101da785409 (patch)
tree32ca68231ed54d7fc142421e3f01c159559e3e0d /devel/ucpp
parentb86cdf1f95944e7d279e461b85c74f6d2e636fd3 (diff)
downloadports-baa97de7de048fb95b5f0bfec51d3101da785409.tar.gz
ports-baa97de7de048fb95b5f0bfec51d3101da785409.zip
Notes
Diffstat (limited to 'devel/ucpp')
-rw-r--r--devel/ucpp/Makefile7
-rw-r--r--devel/ucpp/files/patch-Makefile21
2 files changed, 19 insertions, 9 deletions
diff --git a/devel/ucpp/Makefile b/devel/ucpp/Makefile
index 8b122c25b58c..cfa964c207a5 100644
--- a/devel/ucpp/Makefile
+++ b/devel/ucpp/Makefile
@@ -8,17 +8,16 @@
PORTNAME= ucpp
PORTVERSION= 1.2
+PORTREVISION= 1
CATEGORIES= devel
MASTER_SITES= http://pornin.nerim.net/ucpp/
MAINTAINER= ports@FreeBSD.org
-MAKE_ENV= FLAGS="${CFLAGS}"
-
MAN1= ucpp.1
do-install:
- @${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
- @${INSTALL_MAN} ${WRKSRC}/${MAN1} ${MAN1PREFIX}/man/man1
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/${MAN1} ${MAN1PREFIX}/man/man1
.include <bsd.port.mk>
diff --git a/devel/ucpp/files/patch-Makefile b/devel/ucpp/files/patch-Makefile
index aa54a34e4a2a..859fa3ea81f8 100644
--- a/devel/ucpp/files/patch-Makefile
+++ b/devel/ucpp/files/patch-Makefile
@@ -1,11 +1,22 @@
---- Makefile.orig Mon Aug 19 19:40:18 2002
-+++ Makefile Mon Aug 19 19:41:25 2002
-@@ -57,7 +57,7 @@
+--- Makefile.orig Wed Feb 20 18:49:16 2002
++++ Makefile Sun Dec 1 09:01:06 2002
+@@ -56,8 +56,8 @@
+ #FLAGS = -O -m -DMEM_CHECK
# for gcc
- CC = gcc
+-CC = gcc
-FLAGS = -g -Wall -ansi -pedantic -DAUDIT -DMEM_DEBUG
-+FLAGS += -DAUDIT -DMEM_DEBUG
++CC ?= gcc
++FLAGS = -ansi -pedantic -DAUDIT -DMEM_DEBUG
#FLAGS = -O3 -Wall -ansi -pedantic -DMEM_CHECK
# for the Compaq C compiler on Alpha/Linux
+@@ -78,7 +78,7 @@
+ # ----- nothing should be changed below this line -----
+
+ COBJ = mem.o hash.o cpp.o lexer.o assert.o macro.o eval.o
+-CFLAGS = $(FLAGS) -DSTAND_ALONE
++CFLAGS += $(FLAGS) -DSTAND_ALONE
+
+ all: ucpp
+