aboutsummaryrefslogtreecommitdiff
path: root/devel/uds
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2001-04-02 12:32:05 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2001-04-02 12:32:05 +0000
commit911b693fb17d0dd68affdf7836f69863e694d8a9 (patch)
treea93461939956ca04e5851494c9a8f077b3297c3a /devel/uds
parenta6d5badcb74347c29f4f9555157bc66b214f654e (diff)
downloadports-911b693fb17d0dd68affdf7836f69863e694d8a9.tar.gz
ports-911b693fb17d0dd68affdf7836f69863e694d8a9.zip
Notes
Diffstat (limited to 'devel/uds')
-rw-r--r--devel/uds/Makefile7
-rw-r--r--devel/uds/distinfo2
-rw-r--r--devel/uds/files/patch-Makefile.am15
-rw-r--r--devel/uds/files/patch-Makefile.in15
-rw-r--r--devel/uds/files/patch-configure.in11
-rw-r--r--devel/uds/pkg-plist15
6 files changed, 41 insertions, 24 deletions
diff --git a/devel/uds/Makefile b/devel/uds/Makefile
index 400f5a33dfdb..dcd3587c13f8 100644
--- a/devel/uds/Makefile
+++ b/devel/uds/Makefile
@@ -7,12 +7,14 @@
#
PORTNAME= uds
-PORTVERSION= 0.9.3
+PORTVERSION= 0.9.4
CATEGORIES= devel
MASTER_SITES= http://frost.flewid.de/dist/
MAINTAINER= ijliao@FreeBSD.org
+USE_AUTOMAKE= yes
+USE_AUTOCONF= yes
USE_LIBTOOL= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --disable-debug
@@ -22,4 +24,7 @@ USE_NEWGCC= yes
INSTALLS_SHLIB= yes
+post-patch:
+ @${PERL} -pi -e "s,-lpthread,${PTHREAD_LIBS},g" ${WRKSRC}/thread/Makefile.am
+
.include <bsd.port.mk>
diff --git a/devel/uds/distinfo b/devel/uds/distinfo
index 3269555cb7f6..a880b00e60c9 100644
--- a/devel/uds/distinfo
+++ b/devel/uds/distinfo
@@ -1 +1 @@
-MD5 (uds-0.9.3.tar.gz) = 5ea0959de10314da31e8cf35d2001849
+MD5 (uds-0.9.4.tar.gz) = 61ff8da45829cfee99bb5e154dcc024a
diff --git a/devel/uds/files/patch-Makefile.am b/devel/uds/files/patch-Makefile.am
new file mode 100644
index 000000000000..d307972c3d50
--- /dev/null
+++ b/devel/uds/files/patch-Makefile.am
@@ -0,0 +1,15 @@
+--- Makefile.am.orig Mon Apr 2 20:06:43 2001
++++ Makefile.am Mon Apr 2 20:07:20 2001
+@@ -12,9 +12,9 @@
+
+
+ install-data-hook:
+- rm -Rf $(prefix)/doc/uds
+- mkdir -p $(prefix)/doc/uds
+- cp $(srcdir)/doc/*.html $(prefix)/doc/uds
++ rm -Rf $(prefix)/share/doc/uds
++ mkdir -p $(prefix)/share/doc/uds
++ cp $(srcdir)/doc/*.html $(prefix)/share/doc/uds
+
+ uninstall-local:
+ rm -Rf /usr/doc/uds
diff --git a/devel/uds/files/patch-Makefile.in b/devel/uds/files/patch-Makefile.in
deleted file mode 100644
index 3b2bedadf1bb..000000000000
--- a/devel/uds/files/patch-Makefile.in
+++ /dev/null
@@ -1,15 +0,0 @@
---- Makefile.in.orig Tue Feb 27 14:29:36 2001
-+++ Makefile.in Tue Feb 27 14:30:46 2001
-@@ -377,9 +377,9 @@
- cp `find $(srcdir)/test/ -type f -maxdepth 1` $(top_distdir)/test
-
- install-data-hook:
-- rm -Rf $(prefix)/doc/uds
-- mkdir -p $(prefix)/doc/uds
-- cp $(srcdir)/doc/*.html $(prefix)/doc/uds
-+ rm -Rf $(prefix)/share/uds/doc
-+ mkdir -p $(prefix)/share/uds/doc
-+ cp $(srcdir)/doc/*.html $(prefix)/share/uds/doc
-
- uninstall-local:
- rm -Rf /usr/doc/uds
diff --git a/devel/uds/files/patch-configure.in b/devel/uds/files/patch-configure.in
new file mode 100644
index 000000000000..a44be528acf1
--- /dev/null
+++ b/devel/uds/files/patch-configure.in
@@ -0,0 +1,11 @@
+--- configure.in.orig Mon Apr 2 20:09:38 2001
++++ configure.in Mon Apr 2 20:09:49 2001
+@@ -23,7 +23,7 @@
+ AC_LANG_CPLUSPLUS
+
+ dnl Checks for libraries.
+-AC_CHECK_LIB(pthread, main, thread_dir=thread, thread_dir=)
++AC_CHECK_LIB(c_r, main, thread_dir=thread, thread_dir=)
+ AC_SUBST(thread_dir)
+
+ dnl Checks for header files.
diff --git a/devel/uds/pkg-plist b/devel/uds/pkg-plist
index 7c1198cf550d..e9a1e892ac8a 100644
--- a/devel/uds/pkg-plist
+++ b/devel/uds/pkg-plist
@@ -11,6 +11,7 @@ include/uds/exception.hh
include/uds/exit.hh
include/uds/flex_func.hh
include/uds/functional.hh
+include/uds/init.hh
include/uds/log.hh
include/uds/md5.h
include/uds/procstream.hh
@@ -30,12 +31,12 @@ include/uds/uds.hh
lib/libuds.a
lib/libuds.so
lib/libuds.so.0
-share/uds/doc/relnotes.html
-share/uds/doc/index.html
-share/uds/doc/features.html
-share/uds/doc/download.html
-share/uds/doc/contributing.html
-share/uds/doc/config.html
+share/doc/uds/config.html
+share/doc/uds/contributing.html
+share/doc/uds/download.html
+share/doc/uds/features.html
+share/doc/uds/index.html
+share/doc/uds/relnotes.html
+@dirrm share/doc/uds
share/uds/udsdeff.cc
-@dirrm share/uds/doc
@dirrm share/uds