aboutsummaryrefslogtreecommitdiff
path: root/devel/upnp/Makefile
diff options
context:
space:
mode:
authorClive Lin <clive@FreeBSD.org>2002-08-04 07:31:27 +0000
committerClive Lin <clive@FreeBSD.org>2002-08-04 07:31:27 +0000
commit2711126f9a505638a6988c2ce3a5dac2c2b1824d (patch)
treec7db53187901a7b41aff2b4ee309ae9c340fbcac /devel/upnp/Makefile
parentf1b3108e151feb24c4305c81c7a2f5967cffb5cb (diff)
Notes
Diffstat (limited to 'devel/upnp/Makefile')
-rw-r--r--devel/upnp/Makefile38
1 files changed, 38 insertions, 0 deletions
diff --git a/devel/upnp/Makefile b/devel/upnp/Makefile
new file mode 100644
index 000000000000..b6f1ec651362
--- /dev/null
+++ b/devel/upnp/Makefile
@@ -0,0 +1,38 @@
+# New ports collection makefile for: upnp
+# Date created: 02 August 2002
+# Whom: Yen-Ming Lee <leeym@leeym.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= upnp
+PORTVERSION= 1.0.4
+CATEGORIES= devel
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+DISTNAME= ${PORTNAME}sdk-${PORTVERSION}
+
+MAINTAINER= leeym@leeym.com
+
+LIB_DEPENDS= uuid.1:${PORTSDIR}/sysutils/e2fsprogs
+
+USE_GMAKE= yes
+USE_REINPLACE= yes
+MAKEFILE= makefile
+MAKE_ENV= PTHREAD_LIBS=${PTHREAD_LIBS}
+INSTALLS_SHLIB= yes
+
+post-patch:
+ @cd ${WRKSRC} && ${REINPLACE_CMD} -e 's,MAKE = make,MAKE = ${GMAKE},' \
+ src/genlib/makefile src/makefile
+ @cd ${WRKSRC} && ${REINPLACE_CMD} -e 's,malloc.h,stdlib.h,' \
+ src/inc/genlib/client_table/client_table.h \
+ src/inc/genlib/http_client/http_client.h \
+ src/inc/genlib/service_table/service_table.h \
+ src/inc/genlib/timer_thread/timer_thread.h \
+ src/upnpdom/domCif.cpp
+ @cd ${WRKSRC} && ${REINPLACE_CMD} -e 's,MSG_NOSIGNAL,0,' \
+ src/genlib/http_client/http_client.c \
+ src/genlib/net/http/readwrite.cpp
+
+.include <bsd.port.mk>