aboutsummaryrefslogtreecommitdiff
path: root/devel/upnp104/files
diff options
context:
space:
mode:
authorcvs2svn <cvs2svn@FreeBSD.org>2005-04-20 06:16:18 +0000
committercvs2svn <cvs2svn@FreeBSD.org>2005-04-20 06:16:18 +0000
commit8673c7ec800a8bcc6da14c506081a3cb76e2b8ea (patch)
treead3f495c08f0cc331b6958d319f699d021175c19 /devel/upnp104/files
parent0d9507efb9d902ba8e7fafa90edd7893d2f8db19 (diff)
Notes
Diffstat (limited to 'devel/upnp104/files')
-rw-r--r--devel/upnp104/files/patch-makefile45
-rw-r--r--devel/upnp104/files/patch-src::api::makefile22
-rw-r--r--devel/upnp104/files/patch-src::api::upnpapi.c11
-rw-r--r--devel/upnp104/files/patch-src::gena::Makefile11
-rw-r--r--devel/upnp104/files/patch-src::genlib::tpool::interrupts.cpp11
-rw-r--r--devel/upnp104/files/patch-src::genlib::util::gmtdate.cpp20
-rw-r--r--devel/upnp104/files/patch-src::ssdp::ssdplib.c11
7 files changed, 0 insertions, 131 deletions
diff --git a/devel/upnp104/files/patch-makefile b/devel/upnp104/files/patch-makefile
deleted file mode 100644
index 9482ec00fa36..000000000000
--- a/devel/upnp104/files/patch-makefile
+++ /dev/null
@@ -1,45 +0,0 @@
---- makefile.orig Thu Aug 16 02:20:11 2001
-+++ makefile Sat Aug 3 17:22:35 2002
-@@ -29,11 +29,11 @@
- ##
- ###########################################################################
-
--MAKE = make
-+MAKE = gmake
- UPNP = bin/libupnp.so
- SUBDIRS = src
-
--VERSION=1.0.4
-+VERSION=1
-
- ifeq ($(DEBUG),1)
- STRIPU =
-@@ -102,17 +102,17 @@
- @if [ -f "doc/upnpsdk.aux" ]; then rm doc/upnpsdk.aux; fi
-
- install: upnp
-- @install -d /usr/include/upnp
-- @install -d /usr/include/upnp/upnpdom
-- @install -d /usr/include/upnp/tools
-- @install bin/libupnp.so /usr/lib/libupnp.so.$(VERSION)
-- ln -s /usr/lib/libupnp.so.$(VERSION) /usr/lib/libupnp.so
-- @install inc/*.h /usr/include/upnp
-- @install inc/upnpdom/*.h /usr/include/upnp/upnpdom
-- @install inc/tools/*.h /usr/include/upnp/tools
-+ @install -d ${PREFIX}/include/upnp
-+ @install -d ${PREFIX}/include/upnp/upnpdom
-+ @install -d ${PREFIX}/include/upnp/tools
-+ @install bin/libupnp.so ${PREFIX}/lib/libupnp.so.$(VERSION)
-+ ln -fs ${PREFIX}/lib/libupnp.so.$(VERSION) ${PREFIX}/lib/libupnp.so
-+ @install inc/*.h ${PREFIX}/include/upnp
-+ @install inc/upnpdom/*.h ${PREFIX}/include/upnp/upnpdom
-+ @install inc/tools/*.h ${PREFIX}/include/upnp/tools
-
- uninstall:
-- @if [ -d /usr/include/upnp ]; then rm -rf /usr/include/upnp; fi
-- @if [ -f /usr/lib/libupnp.so ]; then rm /usr/lib/libupnp.so; fi
-- @if [ -f /usr/lib/libupnp.so.$(VERSION) ]; then rm /usr/lib/libupnp.so.$(VERSION); fi
-+ @if [ -d ${PREFIX}/include/upnp ]; then rm -rf ${PREFIX}/include/upnp; fi
-+ @if [ -f ${PREFIX}/lib/libupnp.so ]; then rm ${PREFIX}/lib/libupnp.so; fi
-+ @if [ -f ${PREFIX}/lib/libupnp.so.$(VERSION) ]; then rm ${PREFIX}/lib/libupnp.so.$(VERSION); fi
-
diff --git a/devel/upnp104/files/patch-src::api::makefile b/devel/upnp104/files/patch-src::api::makefile
deleted file mode 100644
index 6e45724c5e35..000000000000
--- a/devel/upnp104/files/patch-src::api::makefile
+++ /dev/null
@@ -1,22 +0,0 @@
---- src/api/makefile.orig Fri Jun 15 08:21:33 2001
-+++ src/api/makefile Sat Aug 3 16:29:38 2002
-@@ -34,15 +34,15 @@
- CC = gcc
- CFLAGS = -Wall -fpic $(DEFS)
- C2FLAGS = -Wall $(DEFS) -shared -Wl,-soname,libupnp.so
--INCLUDES = -I ../inc -I ../../inc -I ../../inc/upnpdom -I ../inc/tools
--LIBS = -lpthread -luuid
-+INCLUDES = -I ../inc -I ../../inc -I ../../inc/upnpdom -I ../inc/tools -I $(LOCALBASE)/include
-+LIBS = ${PTHREAD_LIBS} -luuid -L$(LOCALBASE)/lib
-
- ifeq ($(DEBUG),1)
- CFLAGS += -g -O -DDEBUG
- C2FLAGS += -g -O -DDEBUG
- else
--CFLAGS += -O2
--C2FLAGS += -O2
-+CFLAGS += -g -ggdb
-+C2FLAGS += -g -ggdb
- endif
-
- objects = upnpapi.o config.o ../lib/ssdp.o ../lib/soap.o \
diff --git a/devel/upnp104/files/patch-src::api::upnpapi.c b/devel/upnp104/files/patch-src::api::upnpapi.c
deleted file mode 100644
index d08caa93fc7a..000000000000
--- a/devel/upnp104/files/patch-src::api::upnpapi.c
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/api/upnpapi.c.orig Fri Jun 15 08:22:15 2001
-+++ src/api/upnpapi.c Sat Aug 3 16:29:38 2002
-@@ -44,7 +44,7 @@
- #include<string.h>
-
- #include <sys/ioctl.h>
--#include <linux/if.h>
-+#include <net/if.h>
- #include <sys/utsname.h>
- #include <sys/socket.h>
- #include <netinet/in.h>
diff --git a/devel/upnp104/files/patch-src::gena::Makefile b/devel/upnp104/files/patch-src::gena::Makefile
deleted file mode 100644
index 9674cd45f921..000000000000
--- a/devel/upnp104/files/patch-src::gena::Makefile
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/gena/Makefile.orig Fri Jun 15 08:21:33 2001
-+++ src/gena/Makefile Sat Aug 3 16:29:39 2002
-@@ -61,7 +61,7 @@
-
- TARGET = $(upnp_lib_dir)/gena.o
-
--CFLAGS = -I$(upnp_inc_dir) -I$(upnp_src_inc_dir) -fpic -Wall -c -D_REENTRANT
-+CFLAGS = -I$(upnp_inc_dir) -I$(upnp_src_inc_dir) -I$(LOCALBASE)/include -fpic -Wall -c -D_REENTRANT
-
- ifeq ($(DEBUG),1)
- CFLAGS += -g -O -DDEBUG
diff --git a/devel/upnp104/files/patch-src::genlib::tpool::interrupts.cpp b/devel/upnp104/files/patch-src::genlib::tpool::interrupts.cpp
deleted file mode 100644
index fda9eca21463..000000000000
--- a/devel/upnp104/files/patch-src::genlib::tpool::interrupts.cpp
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/genlib/tpool/interrupts.cpp.orig Fri Jun 15 08:22:16 2001
-+++ src/genlib/tpool/interrupts.cpp Sat Aug 3 16:29:39 2002
-@@ -82,7 +82,7 @@
- int code;
-
- newset.sa_handler = signal_handler_alpha;
-- newset.sa_flags = SA_NOMASK;
-+ newset.sa_flags = SA_NODEFER;
- code = sigaction( signalNum, &newset, &g_OldAction );
- if ( code < 0 )
- {
diff --git a/devel/upnp104/files/patch-src::genlib::util::gmtdate.cpp b/devel/upnp104/files/patch-src::genlib::util::gmtdate.cpp
deleted file mode 100644
index 419b9a202687..000000000000
--- a/devel/upnp104/files/patch-src::genlib::util::gmtdate.cpp
+++ /dev/null
@@ -1,20 +0,0 @@
---- src/genlib/util/gmtdate.cpp.orig Fri Jun 15 08:22:16 2001
-+++ src/genlib/util/gmtdate.cpp Sat Aug 3 16:29:39 2002
-@@ -41,7 +41,7 @@
- #include <stdlib.h>
- #include <ctype.h>
- #include <string.h>
--#include <values.h>
-+#include <machine/limits.h>
- #include <genlib/util/gmtdate.h>
- #include <genlib/util/miscexceptions.h>
-
-@@ -254,7 +254,7 @@
-
- val = (int)strtol( str, &endptr, 10 );
-
-- if ( val < 0 || val == MAXINT )
-+ if ( val < 0 || val == INT_MAX )
- {
- return -1;
- }
diff --git a/devel/upnp104/files/patch-src::ssdp::ssdplib.c b/devel/upnp104/files/patch-src::ssdp::ssdplib.c
deleted file mode 100644
index a9152fe2e8bd..000000000000
--- a/devel/upnp104/files/patch-src::ssdp::ssdplib.c
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/ssdp/ssdplib.c.orig Thu Aug 16 02:17:31 2001
-+++ src/ssdp/ssdplib.c Sat Aug 3 16:29:39 2002
-@@ -403,7 +403,7 @@
- bzero((char *)&SelfAddr, sizeof(struct sockaddr_in));
-
- SelfAddr.sin_family = AF_INET;
-- SelfAddr.sin_addr.s_addr = inet_addr(SSDP_IP);
-+ SelfAddr.sin_addr.s_addr = htonl(INADDR_ANY);
- SelfAddr.sin_port = htons(SSDP_PORT);
- if (bind( SsdpSock, (struct sockaddr *) &SelfAddr, sizeof(SelfAddr)) != 0)
- {