aboutsummaryrefslogtreecommitdiff
path: root/devel/upp
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2006-06-09 20:36:44 +0000
committerPav Lucistnik <pav@FreeBSD.org>2006-06-09 20:36:44 +0000
commit47c5fd80cc9b882e0bbaffcbe2a544e7e93d8244 (patch)
tree77397c88675436181deed577df760183e25990eb /devel/upp
parent180a23ffae4dc722a7f8e4f096298bbb7fd29992 (diff)
downloadports-47c5fd80cc9b882e0bbaffcbe2a544e7e93d8244.tar.gz
ports-47c5fd80cc9b882e0bbaffcbe2a544e7e93d8244.zip
Notes
Diffstat (limited to 'devel/upp')
-rw-r--r--devel/upp/Makefile27
-rw-r--r--devel/upp/distinfo5
-rw-r--r--devel/upp/files/patch-examples-SDLExample-SDLExample.upp8
-rw-r--r--devel/upp/files/patch-examples-SDLExample-main.cpp17
-rw-r--r--devel/upp/files/patch-examples-imgsrv-imgsrv.upp9
-rw-r--r--devel/upp/files/patch-uppsrc-Core-Core.upp11
-rw-r--r--devel/upp/files/patch-uppsrc-Core-Stream.cpp32
-rw-r--r--devel/upp/files/patch-uppsrc-Draw-Draw.upp35
-rw-r--r--devel/upp/files/patch-uppsrc-ide-Makefile74
9 files changed, 69 insertions, 149 deletions
diff --git a/devel/upp/Makefile b/devel/upp/Makefile
index 034f38a1cdf4..90c40c6a1168 100644
--- a/devel/upp/Makefile
+++ b/devel/upp/Makefile
@@ -6,11 +6,11 @@
#
PORTNAME= upp
-PORTVERSION= 602
+PORTVERSION= 605
CATEGORIES= devel x11-toolkits
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE_EXTENDED}
MASTER_SITE_SUBDIR= ${PORTNAME}
-DISTNAME= upp-src-602
+DISTNAME= ${PORTNAME}-src-${PORTVERSION}
MAINTAINER= m.sund@arcor.de
COMMENT= Ultimate++, a BSD-licensed, cross-platform, C/C++ RAD suite
@@ -20,9 +20,16 @@ LIB_DEPENDS= Xft:${PORTSDIR}/x11-fonts/libXft\
expat.6:${PORTSDIR}/textproc/expat2
USE_ZIP= yes
+USE_DOS2UNIX= yes
USE_GMAKE= yes
USE_X_PREFIX= yes
+.if defined(WITH_SDL)
+USE_SDL= sdl
+.endif
+
+EXTRACT_AFTER_ARGS= "-d${DISTNAME}"
+
BUILD_WRKSRC= ${WRKSRC}/uppsrc/ide
INSTALL_DIRS= Common examples reference uppsrc
@@ -33,16 +40,14 @@ INSTALL_DIRS= Common examples reference uppsrc
BROKEN= Ultimate++ is not supported on FreeBSD 4.x
.endif
-post-extract:
- @${MKDIR} ${WRKDIR}/${DISTNAME}
- @for d in ${INSTALL_DIRS}; do ${MV} ${WRKDIR}/$$d ${WRKSRC}; done;
+pre-everything::
+.if !defined(WITH_SDL)
+ @${ECHO_MSG} ""
+ @${ECHO_MSG} "Define WITH_SDL to install SDL library for running SDL example."
+ @${ECHO_MSG} ""
+.endif
pre-patch:
- @${FIND} -E ${WRKDIR} -type f -iregex \
- ".*\.(c|h|cpp|icpp|upp|tpp|am|in|lay|key|txt)" -print0 | \
- ${XARGS} -0 ${REINPLACE_CMD} -e 's/[[:cntrl:]]*$$//'
- @for f in `${FIND} -E ${WRKDIR} -type f -name Makefile -print`; \
- do ${CP} $$f $$f.bak && (${CAT} $$f.bak | ${TR} -d "\r" > $$f); done
@${REINPLACE_CMD} -e 's|CFLAGS|C_FLAGS|' ${BUILD_WRKSRC}/Makefile
pre-build:
@@ -51,7 +56,7 @@ pre-build:
@${REINPLACE_CMD} -e 's|CINC =(.*)|$1 ${PTHREAD_CFLAGS}|' ${BUILD_WRKSRC}/Makefile
post-build:
- @${FIND} -E ${WRKDIR} -type f -iregex ".*\.(bak|orig)" -exec ${RM} -r {} \;
+ @${RM} ${BUILD_WRKSRC}/Makefile.*
@${ECHO_CMD} "BUILDER = \"GCC\"" > ${WRKSRC}/GCC32.bm
@${ECHO_CMD} "COMPILER = \"\";" >> ${WRKSRC}/GCC32.bm
@${ECHO_CMD} "DEBUG_INFO = \"0\";" >> ${WRKSRC}/GCC32.bm
diff --git a/devel/upp/distinfo b/devel/upp/distinfo
index 0a9533418192..0f3a73b06cde 100644
--- a/devel/upp/distinfo
+++ b/devel/upp/distinfo
@@ -1,3 +1,4 @@
-MD5 (upp-src-602.zip) = f3d38ec40089635614f2ff9faa8e35d3
-SHA256 (upp-src-602.zip) = 7e797be5b5b54cb05eed7069e7d8764209d795738a9b3be5d1e8967d1dd520d8
+MD5 (upp-src-605.zip) = a9c7dccd6270fb007104dbed7ac792d8
+SHA256 (upp-src-605.zip) = d7664c72e84545558064c4ea7649ec57ab05b6c0fdd7f084ba1f10ed121e9476
+SIZE (upp-src-605.zip) = 6965517
SIZE (upp-src-602.zip) = 5994800
diff --git a/devel/upp/files/patch-examples-SDLExample-SDLExample.upp b/devel/upp/files/patch-examples-SDLExample-SDLExample.upp
index 5f8e6e0fc6f4..dd2d4e739669 100644
--- a/devel/upp/files/patch-examples-SDLExample-SDLExample.upp
+++ b/devel/upp/files/patch-examples-SDLExample-SDLExample.upp
@@ -1,12 +1,12 @@
---- examples/SDLExample/SDLExample.upp.orig Sat Mar 4 19:46:31 2006
-+++ examples/SDLExample/SDLExample.upp Sat Mar 4 19:46:38 2006
+--- examples/SDLExample/SDLExample.upp.orig Tue Jun 6 20:57:56 2006
++++ examples/SDLExample/SDLExample.upp Tue Jun 6 21:18:25 2006
@@ -7,6 +7,10 @@
library(LINUX) "SDL SDLmain";
-+library(FREEBSD) "SDL-1.1 vgl X11 Xext vga aa usbhid ncurses";
++library(FREEBSD) "SDL-1.1 m vgl X11 Xext vga aa usbhid";
+
-+options(FREEBSD) -I/usr/local/include/SDL11;
++link(FREEBSD) -pthread;
+
file
main.cpp;
diff --git a/devel/upp/files/patch-examples-SDLExample-main.cpp b/devel/upp/files/patch-examples-SDLExample-main.cpp
index 2e04c9456afb..4248aa882a27 100644
--- a/devel/upp/files/patch-examples-SDLExample-main.cpp
+++ b/devel/upp/files/patch-examples-SDLExample-main.cpp
@@ -1,10 +1,11 @@
---- examples/SDLExample/main.cpp.orig Sat Mar 4 17:47:29 2006
-+++ examples/SDLExample/main.cpp Sat Mar 4 17:47:41 2006
-@@ -1,6 +1,6 @@
- #include <Core/Core.h>
-
--#ifdef PLATFORM_WIN32
-+#if defined PLATFORM_WIN32 || defined PLATFORM_FREEBSD
+--- examples/SDLExample/main.cpp.orig Tue Jun 6 21:18:47 2006
++++ examples/SDLExample/main.cpp Tue Jun 6 21:18:58 2006
+@@ -3,7 +3,7 @@
+ #ifdef PLATFORM_WIN32
#include <SDL.h>
#else
- #include <SDL/SDL.h>
+-#include <SDL/SDL.h>
++#include <SDL11/SDL.h>
+ #endif
+
+ const int maxpoint = 1000;
diff --git a/devel/upp/files/patch-examples-imgsrv-imgsrv.upp b/devel/upp/files/patch-examples-imgsrv-imgsrv.upp
deleted file mode 100644
index 771f1b57af08..000000000000
--- a/devel/upp/files/patch-examples-imgsrv-imgsrv.upp
+++ /dev/null
@@ -1,9 +0,0 @@
---- examples/imgsrv/imgsrv.upp.orig Sat Mar 4 19:51:12 2006
-+++ examples/imgsrv/imgsrv.upp Sat Mar 4 19:51:26 2006
-@@ -7,5 +7,5 @@
- imgsrv.cpp;
-
- mainconfig
-- "" = "";
-+ "" = "GUI";
-
diff --git a/devel/upp/files/patch-uppsrc-Core-Core.upp b/devel/upp/files/patch-uppsrc-Core-Core.upp
deleted file mode 100644
index 859b0b413732..000000000000
--- a/devel/upp/files/patch-uppsrc-Core-Core.upp
+++ /dev/null
@@ -1,11 +0,0 @@
---- uppsrc/Core/Core.upp.orig Sat Mar 4 19:46:59 2006
-+++ uppsrc/Core/Core.upp Sat Mar 4 19:47:05 2006
-@@ -13,6 +13,8 @@
-
- library(WIN32 GCC) "ole32 oleaut32 uuid";
-
-+library(FREEBSD) pthread;
-+
- options(XGNU) -O0;
-
- options(XGNU) -ffunction-sections;
diff --git a/devel/upp/files/patch-uppsrc-Core-Stream.cpp b/devel/upp/files/patch-uppsrc-Core-Stream.cpp
deleted file mode 100644
index 4758a07896f5..000000000000
--- a/devel/upp/files/patch-uppsrc-Core-Stream.cpp
+++ /dev/null
@@ -1,32 +0,0 @@
---- uppsrc/Core/Stream.cpp.orig Sat Mar 4 17:09:13 2006
-+++ uppsrc/Core/Stream.cpp Sat Mar 4 17:09:22 2006
-@@ -10,11 +10,14 @@
- #define LLOGHEXDUMP(x, y) // RLOGHEXDUMP(x, y)
-
- #ifdef PLATFORM_POSIX
-+#define LOFF_T_ off_t
- #define LSEEK64_ lseek
- #define FTRUNCATE64_ ftruncate
- #endif
-
- #ifdef PLATFORM_LINUX
-+#undef LOFF_T_
-+#define LOFF_T_ loff_t
- #undef LSEEK64_
- #define LSEEK64_ lseek64
- #undef FTRUNCATE64_
-@@ -1217,12 +1220,12 @@
- void FileStream::SetStreamSize(int64 pos)
- {
- if(handle < 0) return;
-- loff_t cur = LSEEK64_(handle, 0, SEEK_CUR);
-+ LOFF_T_ cur = LSEEK64_(handle, 0, SEEK_CUR);
- if(cur < 0) {
- SetLastError();
- return;
- }
-- loff_t len = LSEEK64_(handle, 0, SEEK_END);
-+ LOFF_T_ len = LSEEK64_(handle, 0, SEEK_END);
- if(len < 0) {
- SetLastError();
- LSEEK64_(handle, cur, SEEK_SET);
diff --git a/devel/upp/files/patch-uppsrc-Draw-Draw.upp b/devel/upp/files/patch-uppsrc-Draw-Draw.upp
deleted file mode 100644
index 4666b12b48da..000000000000
--- a/devel/upp/files/patch-uppsrc-Draw-Draw.upp
+++ /dev/null
@@ -1,35 +0,0 @@
---- uppsrc/Draw/Draw.upp.orig Sat Mar 4 19:48:28 2006
-+++ uppsrc/Draw/Draw.upp Sat Mar 4 19:48:44 2006
-@@ -1,22 +1,24 @@
--uses
-- Core;
--
- acceptflags
- XLFD;
-
-+uses
-+ Core;
-+
- library(WIN32) "user32 gdi32";
-
--library(LINUX) "X11";
-+library(LINUX) X11;
-
--library(LINUX) "dl";
-+library(LINUX) dl;
-
--library(LINUX !XLFD) "Xft";
-+library(LINUX !XLFD) Xft;
-
--library(FREEBSD) "X11";
-+library(FREEBSD) X11;
-
--library(FREEBSD !XLFD) "Xft fontconfig";
-+library(FREEBSD !XLFD) Xft;
-
- library(LINUX !XLFD !SHARED) "fontconfig Xrender freetype expat";
-+
-+library(FREEBSD !XLFD !SHARED) "fontconfig Xrender freetype expat";
-
- file
- Draw.h,
diff --git a/devel/upp/files/patch-uppsrc-ide-Makefile b/devel/upp/files/patch-uppsrc-ide-Makefile
index 749e05995f4e..8a07af10a339 100644
--- a/devel/upp/files/patch-uppsrc-ide-Makefile
+++ b/devel/upp/files/patch-uppsrc-ide-Makefile
@@ -1,5 +1,5 @@
----uppsrc/ide/Makefile.orig Mon Mar 20 18:36:35 2006
-+++ uppsrc/ide/Makefile Mon Mar 20 18:37:40 2006
+--- uppsrc/ide/Makefile.orig Sat Jun 3 15:34:49 2006
++++ uppsrc/ide/Makefile Sat Jun 3 15:38:38 2006
@@ -1,13 +1,13 @@
-UPPDIR1 = /src/uppsrc/
+UPPDIR1 = ../
@@ -26,7 +26,7 @@
Macro_PdfDraw = $(Macro)
OutDir = $(OutDir_ide)
--OutFile = /src/ide
+-OutFile = /home/cxl/ide
+OutFile = $(UPPDIR1)../ide
.PHONY: all
@@ -68,40 +68,40 @@
- -mkdir -p $(OutDir_RichText)
- -mkdir -p $(OutDir_CtrlCore)
- -mkdir -p $(OutDir_PdfDraw)
-+ -$(MKDIR) $(OutDir)
-+ -$(MKDIR) $(OutDir_ide)
-+ -$(MKDIR) $(OutDir_ide_Common)
-+ -$(MKDIR) $(OutDir_ide_LayDes)
-+ -$(MKDIR) $(OutDir_ide_IconDes)
-+ -$(MKDIR) $(OutDir_ide_Builders)
-+ -$(MKDIR) $(OutDir_ide_Debuggers)
-+ -$(MKDIR) $(OutDir_ide_Browser)
-+ -$(MKDIR) $(OutDir_ide_Topic)
-+ -$(MKDIR) $(OutDir_ide_VectorDes)
-+ -$(MKDIR) $(OutDir_CodeEditor)
-+ -$(MKDIR) $(OutDir_Topic)
-+ -$(MKDIR) $(OutDir_CtrlLib)
-+ -$(MKDIR) $(OutDir_Web)
-+ -$(MKDIR) $(OutDir_plugin_bz2)
-+ -$(MKDIR) $(OutDir_HexView)
-+ -$(MKDIR) $(OutDir_Esc)
-+ -$(MKDIR) $(OutDir_Core)
-+ -$(MKDIR) $(OutDir_RichEdit)
-+ -$(MKDIR) $(OutDir_plugin_png)
-+ -$(MKDIR) $(OutDir_plugin_gif)
-+ -$(MKDIR) $(OutDir_Image)
-+ -$(MKDIR) $(OutDir_plugin_tif)
-+ -$(MKDIR) $(OutDir_plugin_jpg)
-+ -$(MKDIR) $(OutDir_Draw)
-+ -$(MKDIR) $(OutDir_plugin_z)
-+ -$(MKDIR) $(OutDir_coff_binobj)
-+ -$(MKDIR) $(OutDir_coff)
-+ -$(MKDIR) $(OutDir_plugin_ndisasm)
-+ -$(MKDIR) $(OutDir_CppBase)
-+ -$(MKDIR) $(OutDir_VectorDes)
-+ -$(MKDIR) $(OutDir_RichText)
-+ -$(MKDIR) $(OutDir_CtrlCore)
-+ -$(MKDIR) $(OutDir_PdfDraw)
++ -${MKDIR} $(OutDir)
++ -${MKDIR} $(OutDir_ide)
++ -${MKDIR} $(OutDir_ide_Common)
++ -${MKDIR} $(OutDir_ide_LayDes)
++ -${MKDIR} $(OutDir_ide_IconDes)
++ -${MKDIR} $(OutDir_ide_Builders)
++ -${MKDIR} $(OutDir_ide_Debuggers)
++ -${MKDIR} $(OutDir_ide_Browser)
++ -${MKDIR} $(OutDir_ide_Topic)
++ -${MKDIR} $(OutDir_ide_VectorDes)
++ -${MKDIR} $(OutDir_CodeEditor)
++ -${MKDIR} $(OutDir_Topic)
++ -${MKDIR} $(OutDir_CtrlLib)
++ -${MKDIR} $(OutDir_Web)
++ -${MKDIR} $(OutDir_plugin_bz2)
++ -${MKDIR} $(OutDir_HexView)
++ -${MKDIR} $(OutDir_Esc)
++ -${MKDIR} $(OutDir_Core)
++ -${MKDIR} $(OutDir_RichEdit)
++ -${MKDIR} $(OutDir_plugin_png)
++ -${MKDIR} $(OutDir_plugin_gif)
++ -${MKDIR} $(OutDir_Image)
++ -${MKDIR} $(OutDir_plugin_tif)
++ -${MKDIR} $(OutDir_plugin_jpg)
++ -${MKDIR} $(OutDir_Draw)
++ -${MKDIR} $(OutDir_plugin_z)
++ -${MKDIR} $(OutDir_coff_binobj)
++ -${MKDIR} $(OutDir_coff)
++ -${MKDIR} $(OutDir_plugin_ndisasm)
++ -${MKDIR} $(OutDir_CppBase)
++ -${MKDIR} $(OutDir_VectorDes)
++ -${MKDIR} $(OutDir_RichText)
++ -${MKDIR} $(OutDir_CtrlCore)
++ -${MKDIR} $(OutDir_PdfDraw)
$(OutFile): \
$(OutDir_ide)SelectPkg.o \