aboutsummaryrefslogtreecommitdiff
path: root/devel/ustl/Makefile
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2005-01-25 01:55:58 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2005-01-25 01:55:58 +0000
commite3d809db438e29e820f71ee5668e4be833c4a0e6 (patch)
tree3a73ad0f96972595a5662b533ed589f1cc9dee84 /devel/ustl/Makefile
parentdc91ddc6dfb06df8f060f6aade778dc49b2199a8 (diff)
downloadports-e3d809db438e29e820f71ee5668e4be833c4a0e6.tar.gz
ports-e3d809db438e29e820f71ee5668e4be833c4a0e6.zip
Notes
Diffstat (limited to 'devel/ustl/Makefile')
-rw-r--r--devel/ustl/Makefile10
1 files changed, 9 insertions, 1 deletions
diff --git a/devel/ustl/Makefile b/devel/ustl/Makefile
index fa6235da8706..9bc0862a760b 100644
--- a/devel/ustl/Makefile
+++ b/devel/ustl/Makefile
@@ -25,9 +25,17 @@ HAS_CONFIGURE= yes
USE_GMAKE= yes
ALL_TARGET= # empty
+PLIST_FILES= lib/libustl.a
+
post-patch:
@${REINPLACE_CMD} -e "s,/bin/bash,${LOCALBASE}/bin/bash," ${WRKSRC}/configure
@${REINPLACE_CMD} -e "s|SIZE_MAX|UINT_MAX|" ${WRKSRC}/memblock.h
- @${REINPLACE_CMD} -e "s|-Werror||" ${WRKSRC}/Common.mk.in
+ @${REINPLACE_CMD} -e "s|-Werror||;s|-O3||" ${WRKSRC}/Common.mk.in
+
+post-install:
+ @${FIND} ${PREFIX}/include/ustl* ! -type d | \
+ ${SED} 's,^${PREFIX}/,,' >> ${TMPPLIST}
+ @${FIND} ${PREFIX}/include/ustl* -type d | ${SORT} -r | \
+ ${SED} 's,^${PREFIX}/,@dirrm ,' >> ${TMPPLIST}
.include <bsd.port.mk>