aboutsummaryrefslogtreecommitdiff
path: root/devel/varconf
diff options
context:
space:
mode:
authorAlexander Langer <alex@FreeBSD.org>2001-04-05 19:24:57 +0000
committerAlexander Langer <alex@FreeBSD.org>2001-04-05 19:24:57 +0000
commit483a3e0dc0609217a6d05f497e8ea86fcf28c7c7 (patch)
treef9e570b905256f84ed1524b3784bc9589693f9ed /devel/varconf
parentbb1c0fa37e8ffef03a0da7dabce0ed8627f17f24 (diff)
downloadports-483a3e0dc0609217a6d05f497e8ea86fcf28c7c7.tar.gz
ports-483a3e0dc0609217a6d05f497e8ea86fcf28c7c7.zip
Notes
Diffstat (limited to 'devel/varconf')
-rw-r--r--devel/varconf/Makefile25
-rw-r--r--devel/varconf/distinfo1
-rw-r--r--devel/varconf/pkg-comment1
-rw-r--r--devel/varconf/pkg-descr5
-rw-r--r--devel/varconf/pkg-plist9
5 files changed, 41 insertions, 0 deletions
diff --git a/devel/varconf/Makefile b/devel/varconf/Makefile
new file mode 100644
index 000000000000..fd45442dd77c
--- /dev/null
+++ b/devel/varconf/Makefile
@@ -0,0 +1,25 @@
+# New ports collection makefile for: varconf
+# Date created: 29 March 2001
+# Whom: Oliver Lehmann <lehmann@ans-netz.de>
+#
+# $FreeBSD$
+#
+
+PORTNAME= varconf
+PORTVERSION= 0.3.0
+CATEGORIES= devel
+MASTER_SITES= ftp://ftp.ecs.soton.ac.uk/pub/worldforge/libs/varconf/ \
+ ftp://two.woovis.com/pub/worldforge/libs/varconf/ \
+ http://dreadnought.res.cmu.edu/worldforge/libs/varconf/ \
+ http://kafka.i-site.com/~novalis/mirrors/acorn/0.3/src/ \
+ http://65.100.132.89/wf/downloads/libs/varconf/
+
+MAINTAINER= lehmann@ans-netz.de
+
+LIB_DEPENDS= sigc.1:${PORTSDIR}/devel/libsigc++ \
+ Atlas.0:${PORTSDIR}/devel/atlas
+
+USE_LIBTOOL= YES
+CONFIGURE_ARGS= --prefix=${PREFIX}
+
+.include <bsd.port.mk>
diff --git a/devel/varconf/distinfo b/devel/varconf/distinfo
new file mode 100644
index 000000000000..e424278de7e4
--- /dev/null
+++ b/devel/varconf/distinfo
@@ -0,0 +1 @@
+MD5 (varconf-0.3.0.tar.gz) = 962d6ec1ea7b50b6eeafb6a4a41292d7
diff --git a/devel/varconf/pkg-comment b/devel/varconf/pkg-comment
new file mode 100644
index 000000000000..10abd9a8a4fb
--- /dev/null
+++ b/devel/varconf/pkg-comment
@@ -0,0 +1 @@
+A Configuration System for the STAGE Server
diff --git a/devel/varconf/pkg-descr b/devel/varconf/pkg-descr
new file mode 100644
index 000000000000..528f9d2729cf
--- /dev/null
+++ b/devel/varconf/pkg-descr
@@ -0,0 +1,5 @@
+Varconf is a configuration system designed for the STAGE server.
+Varconf can parse configuration files, command-line arguments and
+environment variables. It supports callbacks and can store its
+configuration information in separate Config objects or in one
+global configuration instance.
diff --git a/devel/varconf/pkg-plist b/devel/varconf/pkg-plist
new file mode 100644
index 000000000000..67dd83bab307
--- /dev/null
+++ b/devel/varconf/pkg-plist
@@ -0,0 +1,9 @@
+lib/libvarconf.so.0
+lib/libvarconf.la
+lib/libvarconf.a
+include/varconf/Config.h
+include/varconf/parse_error.h
+include/varconf/variable.h
+include/varconf/varconf.h
+bin/conftest
+@dirrm include/varconf