aboutsummaryrefslogtreecommitdiff
path: root/devel/viewvc/Makefile
diff options
context:
space:
mode:
authorJohann Visagie <wjv@FreeBSD.org>2001-08-23 13:26:43 +0000
committerJohann Visagie <wjv@FreeBSD.org>2001-08-23 13:26:43 +0000
commit11c04b6c8628bd87e89f69a0a7c7ac33c349b830 (patch)
tree35bfd289e85724485d4ee896c4a6d3e2c38411bd /devel/viewvc/Makefile
parent0ceeb37c93fe7b2b0363a7a26bc680a4cf15d05c (diff)
downloadports-11c04b6c8628bd87e89f69a0a7c7ac33c349b830.tar.gz
ports-11c04b6c8628bd87e89f69a0a7c7ac33c349b830.zip
Notes
Diffstat (limited to 'devel/viewvc/Makefile')
-rw-r--r--devel/viewvc/Makefile19
1 files changed, 11 insertions, 8 deletions
diff --git a/devel/viewvc/Makefile b/devel/viewvc/Makefile
index 8854dc730a34..e79a019a2858 100644
--- a/devel/viewvc/Makefile
+++ b/devel/viewvc/Makefile
@@ -13,20 +13,23 @@ MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= ports@FreeBSD.org
-BUILD_DEPENDS= python:${PORTSDIR}/lang/python
-RUN_DEPENDS= python:${PORTSDIR}/lang/python
-
+USE_PYTHON= yes
NO_BUILD= yes
+PKGMESSAGE= ${WRKDIR}/pkg-message
pre-install:
- ${PERL} -pi -e "s:/usr/local/viewcvs-dev:${PREFIX}/share/viewcvs:g" ${WRKSRC}/viewcvs-install
+ @ ${PERL} -pi -e "s:/usr/local/viewcvs-dev:${PREFIX}/share/viewcvs:g" \
+ ${WRKSRC}/viewcvs-install
do-install:
- (cd ${WRKSRC} && ${LOCALBASE}/bin/python ${WRKSRC}/viewcvs-install)
+ @ cd ${WRKSRC} && ${PYTHON_CMD} viewcvs-install
post-install:
- @${ECHO}
- @${CAT} ${PKGMESSAGE} | ${SED} -e "s:%%PREFIX%%:${PREFIX}:g"
- @${ECHO}
+ @ ${SED} -e "s:%%PREFIX%%:${PREFIX}:g" pkg-message >${PKGMESSAGE}
+.if !defined(BATCH)
+ @ ${ECHO}
+ @ ${CAT} ${PKGMESSAGE}
+ @ ${ECHO}
+.endif
.include <bsd.port.mk>