aboutsummaryrefslogtreecommitdiff
path: root/devel/vstr
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2004-02-11 20:28:13 +0000
committerPav Lucistnik <pav@FreeBSD.org>2004-02-11 20:28:13 +0000
commitb90f7c1e828bdf4c0497725c53c1b861ecadab63 (patch)
tree2dfd1cd5561fc2c6c611007caa172d327a078829 /devel/vstr
parent78318f38b973ba6d9baabd5caad977c4cd813b26 (diff)
downloadports-b90f7c1e828bdf4c0497725c53c1b861ecadab63.tar.gz
ports-b90f7c1e828bdf4c0497725c53c1b861ecadab63.zip
Notes
Diffstat (limited to 'devel/vstr')
-rw-r--r--devel/vstr/Makefile25
-rw-r--r--devel/vstr/distinfo1
-rw-r--r--devel/vstr/files/patch-ltmain.sh51
-rw-r--r--devel/vstr/pkg-descr8
-rw-r--r--devel/vstr/pkg-plist41
5 files changed, 126 insertions, 0 deletions
diff --git a/devel/vstr/Makefile b/devel/vstr/Makefile
new file mode 100644
index 000000000000..e749b4eb3a6c
--- /dev/null
+++ b/devel/vstr/Makefile
@@ -0,0 +1,25 @@
+# Ports collection makefile for: vstr
+# Date created: 11 February 2004
+# Whom: Robert Schlotterbeck <robert@rs.tarrant.tx.us>
+#
+# $FreeBSD$
+#
+
+PORTNAME= vstr
+PORTVERSION= 1.0.12
+CATEGORIES= devel
+MASTER_SITES= ftp://ftp.and.org/pub/james/vstr/${PORTVERSION}/
+
+MAINTAINER= robert@rs.tarrant.tx.us
+COMMENT= General purpose string library for C
+
+GNU_CONFIGURE= yes
+USE_LIBTOOL= yes
+USE_BZIP2= yes
+USE_GMAKE= yes
+USE_GNOME= gnomehack pkgconfig
+INSTALLS_SHLIB= yes
+
+MAN3= vstr.3 vstr_const.3
+
+.include <bsd.port.mk>
diff --git a/devel/vstr/distinfo b/devel/vstr/distinfo
new file mode 100644
index 000000000000..1025ad1e4d41
--- /dev/null
+++ b/devel/vstr/distinfo
@@ -0,0 +1 @@
+MD5 (vstr-1.0.12.tar.bz2) = a39a1199feed065d9645667e7f3df15e
diff --git a/devel/vstr/files/patch-ltmain.sh b/devel/vstr/files/patch-ltmain.sh
new file mode 100644
index 000000000000..1d5a5c7b87e1
--- /dev/null
+++ b/devel/vstr/files/patch-ltmain.sh
@@ -0,0 +1,51 @@
+--- ltmain.sh.orig Fri Sep 12 14:51:51 2003
++++ ltmain.sh Sun Sep 21 17:49:07 2003
+@@ -1280,7 +1280,7 @@
+ esac
+ elif test "X$arg" = "X-lc_r"; then
+ case $host in
+- *-*-openbsd* | *-*-freebsd*)
++ *-*-openbsd* | *-*-freebsd4*)
+ # Do not include libc_r directly, use -pthread flag.
+ continue
+ ;;
+@@ -1290,8 +1290,16 @@
+ continue
+ ;;
+
++ -pthread)
++ compile_command="$compile_command -pthread"
++ finalize_command="$finalize_command -pthread"
++ compiler_flags="$compiler_flags -pthread"
++ continue
++ ;;
++
+ -module)
+ module=yes
++ build_old_libs=no
+ continue
+ ;;
+
+@@ -3000,6 +3008,9 @@
+ # problems, so we reset it completely
+ verstring=
+ ;;
++ *-*-freebsd*)
++ # FreeBSD doesn't need this...
++ ;;
+ *)
+ verstring="0.0"
+ ;;
+@@ -5428,10 +5439,12 @@
+ fi
+
+ # Install the pseudo-library for information purposes.
++ if /usr/bin/false; then
+ name=`$echo "X$file" | $Xsed -e 's%^.*/%%'`
+ instname="$dir/$name"i
+ $show "$install_prog $instname $destdir/$name"
+ $run eval "$install_prog $instname $destdir/$name" || exit $?
++ fi
+
+ # Maybe install the static library, too.
+ test -n "$old_library" && staticlibs="$staticlibs $dir/$old_library"
diff --git a/devel/vstr/pkg-descr b/devel/vstr/pkg-descr
new file mode 100644
index 000000000000..18f54f1b5bed
--- /dev/null
+++ b/devel/vstr/pkg-descr
@@ -0,0 +1,8 @@
+Vstr is a string library, designed so you can work optimally with
+readv()/writev() for input/output. This means that, for instance, you
+can readv() data to the end of the string and writev() data from the
+beginning of the string without having to allocate or move memory. It
+also means that the library is completely happy with data that has
+multiple zero bytes in it.
+
+WWW: http://www.and.org/vstr/
diff --git a/devel/vstr/pkg-plist b/devel/vstr/pkg-plist
new file mode 100644
index 000000000000..b1f4543e3e96
--- /dev/null
+++ b/devel/vstr/pkg-plist
@@ -0,0 +1,41 @@
+include/vstr-conf.h
+include/vstr-const.h
+include/vstr-def.h
+include/vstr-extern.h
+include/vstr-inline.h
+include/vstr-switch.h
+include/vstr.h
+lib/libvstr-1.0.so
+lib/libvstr-1.0.so.12
+lib/libvstr.a
+lib/libvstr.so
+libdata/pkgconfig/vstr.pc
+share/doc/vstr-devel-1.0.12/basic_cat.c.html
+share/doc/vstr-devel-1.0.12/compare_licenses/SafeStr.txt
+share/doc/vstr-devel-1.0.12/compare_licenses/bstring.txt
+share/doc/vstr-devel-1.0.12/compare_licenses/cords.txt
+share/doc/vstr-devel-1.0.12/compare_licenses/ossp-str.txt
+share/doc/vstr-devel-1.0.12/compare_licenses/rope.txt
+share/doc/vstr-devel-1.0.12/compare_licenses/sz.txt
+share/doc/vstr-devel-1.0.12/compare_licenses/toolbox.txt
+share/doc/vstr-devel-1.0.12/comparison.html
+share/doc/vstr-devel-1.0.12/constants.html
+share/doc/vstr-devel-1.0.12/constants.txt
+share/doc/vstr-devel-1.0.12/design.html
+share/doc/vstr-devel-1.0.12/f_c.css
+share/doc/vstr-devel-1.0.12/functions.html
+share/doc/vstr-devel-1.0.12/functions.txt
+share/doc/vstr-devel-1.0.12/internal_structure.dia
+share/doc/vstr-devel-1.0.12/namespace.html
+share/doc/vstr-devel-1.0.12/overview.html
+share/doc/vstr-devel-1.0.12/printf_comparison.html
+share/doc/vstr-devel-1.0.12/req_trunc_io.html
+share/doc/vstr-devel-1.0.12/security.html
+share/doc/vstr-devel-1.0.12/security_problems.html
+share/doc/vstr-devel-1.0.12/size_cmp.gnumeric
+share/doc/vstr-devel-1.0.12/speed.html
+share/doc/vstr-devel-1.0.12/structs.html
+share/doc/vstr-devel-1.0.12/structs.txt
+share/doc/vstr-devel-1.0.12/tutorial.html
+@dirrm share/doc/vstr-devel-1.0.12/compare_licenses
+@dirrm share/doc/vstr-devel-1.0.12