aboutsummaryrefslogtreecommitdiff
path: root/devel/websvn
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2004-05-25 20:41:27 +0000
committerPav Lucistnik <pav@FreeBSD.org>2004-05-25 20:41:27 +0000
commit3527016a40d00174d070ce8bf345f2458e2a380a (patch)
tree3566989984a3b20a5322bc981567ed79fcbb0bf8 /devel/websvn
parent788d7a54196fcc76a54291236757eef2bae18e34 (diff)
downloadports-3527016a40d00174d070ce8bf345f2458e2a380a.tar.gz
ports-3527016a40d00174d070ce8bf345f2458e2a380a.zip
Notes
Diffstat (limited to 'devel/websvn')
-rw-r--r--devel/websvn/Makefile30
-rw-r--r--devel/websvn/distinfo2
-rw-r--r--devel/websvn/pkg-descr7
-rw-r--r--devel/websvn/pkg-plist54
4 files changed, 93 insertions, 0 deletions
diff --git a/devel/websvn/Makefile b/devel/websvn/Makefile
new file mode 100644
index 000000000000..6cc460a457d6
--- /dev/null
+++ b/devel/websvn/Makefile
@@ -0,0 +1,30 @@
+# New ports collection makefile for: websvn
+# Date created: 11 May 2004
+# Whom: Yuan-Chung Hsiao (ychsiao@ychsiao.idv.tw)
+#
+# $FreeBSD$
+#
+
+PORTNAME= websvn
+PORTVERSION= 1.38
+CATEGORIES= devel www
+MASTER_SITES= http://websvn.tigris.org/files/documents/1380/10659/
+DISTNAME= WebSVN
+
+MAINTAINER= ychsiao@ychsiao.idv.tw
+COMMENT= Subversion repository web frontend
+
+USE_PHP= yes
+NO_BUILD= yes
+WRKSRC= ${WRKDIR}/WebSVN
+
+WEBSVNDIR?= www/data/WebSVN
+
+PLIST_SUB+= WEBSVNDIR=${WEBSVNDIR}
+
+do-install:
+ ${MKDIR} ${PREFIX}/${WEBSVNDIR}
+ ${CP} -R ${WRKSRC}/* ${PREFIX}/${WEBSVNDIR}
+ ${CHOWN} www:www ${PREFIX}/${WEBSVNDIR}
+
+.include <bsd.port.mk>
diff --git a/devel/websvn/distinfo b/devel/websvn/distinfo
new file mode 100644
index 000000000000..ed52915d91af
--- /dev/null
+++ b/devel/websvn/distinfo
@@ -0,0 +1,2 @@
+MD5 (WebSVN.tar.gz) = 7add4c9292bbe86ab53153d00eb7173d
+SIZE (WebSVN.tar.gz) = 50993
diff --git a/devel/websvn/pkg-descr b/devel/websvn/pkg-descr
new file mode 100644
index 000000000000..fdae127e12d7
--- /dev/null
+++ b/devel/websvn/pkg-descr
@@ -0,0 +1,7 @@
+WebSVN offers a view onto your subversion repositories that's been designed
+to reflect the Subversion methodology. You can view the log of any file or
+directory and see a list of all the files changed, added or deleted in any
+given revision. You can also view the differences between 2 versions of
+a file so as to see exactly what was changed in a particular revision.
+
+WWW: http://websvn.tigris.org/
diff --git a/devel/websvn/pkg-plist b/devel/websvn/pkg-plist
new file mode 100644
index 000000000000..382484d5101b
--- /dev/null
+++ b/devel/websvn/pkg-plist
@@ -0,0 +1,54 @@
+www/data/WebSVN/cache/tmp
+www/data/WebSVN/changes.txt
+www/data/WebSVN/diff.php
+www/data/WebSVN/filedetails.php
+www/data/WebSVN/form.php
+www/data/WebSVN/include/command.inc
+www/data/WebSVN/include/configclass.inc
+www/data/WebSVN/include/distconfig.inc
+www/data/WebSVN/include/setup.inc
+www/data/WebSVN/include/svnlook.inc
+www/data/WebSVN/include/template.inc
+www/data/WebSVN/include/utils.inc
+www/data/WebSVN/include/version.inc
+www/data/WebSVN/index.php
+www/data/WebSVN/install.txt
+www/data/WebSVN/languages/english.inc
+www/data/WebSVN/languages/german.inc
+www/data/WebSVN/licence.txt
+www/data/WebSVN/listing.php
+www/data/WebSVN/log.php
+www/data/WebSVN/templates.txt
+www/data/WebSVN/templates/BlueGrey/diff.tmpl
+www/data/WebSVN/templates/BlueGrey/directory.tmpl
+www/data/WebSVN/templates/BlueGrey/file.png
+www/data/WebSVN/templates/BlueGrey/file.tmpl
+www/data/WebSVN/templates/BlueGrey/filec.png
+www/data/WebSVN/templates/BlueGrey/fileh.png
+www/data/WebSVN/templates/BlueGrey/files.png
+www/data/WebSVN/templates/BlueGrey/folder.png
+www/data/WebSVN/templates/BlueGrey/footer.tmpl
+www/data/WebSVN/templates/BlueGrey/header.tmpl
+www/data/WebSVN/templates/BlueGrey/index.tmpl
+www/data/WebSVN/templates/BlueGrey/log.tmpl
+www/data/WebSVN/templates/BlueGrey/png.js
+www/data/WebSVN/templates/BlueGrey/repo.png
+www/data/WebSVN/templates/BlueGrey/styles.css
+www/data/WebSVN/templates/BlueGrey/subversion.png
+www/data/WebSVN/templates/Standard/diff.tmpl
+www/data/WebSVN/templates/Standard/directory.tmpl
+www/data/WebSVN/templates/Standard/file.tmpl
+www/data/WebSVN/templates/Standard/footer.tmpl
+www/data/WebSVN/templates/Standard/header.tmpl
+www/data/WebSVN/templates/Standard/index.tmpl
+www/data/WebSVN/templates/Standard/log.tmpl
+www/data/WebSVN/templates/Standard/styles.css
+www/data/WebSVN/wsvn.php
+@dirrm www/data/WebSVN/templates/Standard
+@dirrm www/data/WebSVN/templates/BlueGrey
+@dirrm www/data/WebSVN/templates
+@dirrm www/data/WebSVN/temp
+@dirrm www/data/WebSVN/languages
+@dirrm www/data/WebSVN/include
+@dirrm www/data/WebSVN/cache
+@dirrm www/data/WebSVN