aboutsummaryrefslogtreecommitdiff
path: root/devel/whups
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2003-11-15 20:37:04 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2003-11-15 20:37:04 +0000
commit3dfcb69b7713730d22282332e61d19042167992f (patch)
tree14ba4292ad28106c8850a8687b0478783ab3362c /devel/whups
parent69159be6d154e71e1b93cb66fad84dc503d37c54 (diff)
downloadports-3dfcb69b7713730d22282332e61d19042167992f.tar.gz
ports-3dfcb69b7713730d22282332e61d19042167992f.zip
Notes
Diffstat (limited to 'devel/whups')
-rw-r--r--devel/whups/Makefile6
1 files changed, 4 insertions, 2 deletions
diff --git a/devel/whups/Makefile b/devel/whups/Makefile
index 9b62022b4a18..0ea0daed3fd4 100644
--- a/devel/whups/Makefile
+++ b/devel/whups/Makefile
@@ -19,6 +19,8 @@ BROKEN= "Doesn't run with Horde 2.1 or 2.2"
NO_BUILD= yes
+USE_REINPLACE= yes
+
DOCS= LICENSE docs/CHANGES
CONFFILE= conf.php html.php prefs.php
SUB_DIRS= config graphics lib locale po scripts templates
@@ -49,9 +51,9 @@ do-install:
@${CHOWN} -R www:www ${WHUPSDIR}
@${CHMOD} -R o-rwx ${CONFDIR}
@${CP} -p ${FILESDIR}/httpd.conf.whups ${HORDE_INC}
- @${PERL} -pi -e "s:/home/httpd/html/horde/whups:${WHUPSDIR}:g" \
+ @${REINPLACE_CMD} -e "s:/home/httpd/html/horde/whups:${WHUPSDIR}:g" \
${HORDE_INC}/httpd.conf.whups
- @${PERL} -pi -e "s://UNCOMMENTWHENINSTWHUPS::" ${HORDEDIR}/config/registry.php
+ @${REINPLACE_CMD} -e "s://UNCOMMENTWHENINSTWHUPS::" ${HORDEDIR}/config/registry.php
.if !defined(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}
.for FILE in ${DOCS}