aboutsummaryrefslogtreecommitdiff
path: root/devel/wininfo
diff options
context:
space:
mode:
authorThierry Thomas <thierry@FreeBSD.org>2004-06-13 20:19:33 +0000
committerThierry Thomas <thierry@FreeBSD.org>2004-06-13 20:19:33 +0000
commit9f89f2389aa719b9a8b279c6f9621d663e9d8a3c (patch)
treedfdc353f95e992133bc871969f9d10827a015eb0 /devel/wininfo
parent076a04a30d6a965afcecad427f37cd79b8680001 (diff)
downloadports-9f89f2389aa719b9a8b279c6f9621d663e9d8a3c.tar.gz
ports-9f89f2389aa719b9a8b279c6f9621d663e9d8a3c.zip
Notes
Diffstat (limited to 'devel/wininfo')
-rw-r--r--devel/wininfo/Makefile25
-rw-r--r--devel/wininfo/distinfo2
-rw-r--r--devel/wininfo/files/patch-src::wininfo.c10
-rw-r--r--devel/wininfo/pkg-descr16
-rw-r--r--devel/wininfo/pkg-plist2
5 files changed, 55 insertions, 0 deletions
diff --git a/devel/wininfo/Makefile b/devel/wininfo/Makefile
new file mode 100644
index 000000000000..c3537c6418fd
--- /dev/null
+++ b/devel/wininfo/Makefile
@@ -0,0 +1,25 @@
+# New ports collection makefile for: X Window Information
+# Date created: 11 Jun 2004
+# Whom: Jean-Yves Lefort <jylefort@brutele.be>
+#
+# $FreeBSD$
+#
+
+PORTNAME= wininfo
+PORTVERSION= 0.5
+CATEGORIES= devel
+MASTER_SITES= http://www.freedesktop.org/Software/wininfo/
+
+MAINTAINER= jylefort@brutele.be
+COMMENT= A window information utility
+
+USE_X_PREFIX= yes
+USE_GNOME= gtk20 gnomeprefix
+GNU_CONFIGURE= yes
+
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -I${X11BASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib -L${X11BASE}/lib"
+
+MAN1= wininfo.1
+
+.include <bsd.port.mk>
diff --git a/devel/wininfo/distinfo b/devel/wininfo/distinfo
new file mode 100644
index 000000000000..470f8eac3f84
--- /dev/null
+++ b/devel/wininfo/distinfo
@@ -0,0 +1,2 @@
+MD5 (wininfo-0.5.tar.gz) = b9fcb6cfe2347c96e83eaa73d89a4ab1
+SIZE (wininfo-0.5.tar.gz) = 478836
diff --git a/devel/wininfo/files/patch-src::wininfo.c b/devel/wininfo/files/patch-src::wininfo.c
new file mode 100644
index 000000000000..a341dc3ec24f
--- /dev/null
+++ b/devel/wininfo/files/patch-src::wininfo.c
@@ -0,0 +1,10 @@
+--- src/wininfo.c.orig Fri Jun 11 00:10:25 2004
++++ src/wininfo.c Fri Jun 11 00:10:29 2004
+@@ -23,7 +23,6 @@
+ */
+
+ #include <stdio.h>
+-#include <stdint.h>
+ #include <string.h>
+ #include <gtk/gtk.h>
+ #include <gdk/gdk.h>
diff --git a/devel/wininfo/pkg-descr b/devel/wininfo/pkg-descr
new file mode 100644
index 000000000000..f139d4e95ec3
--- /dev/null
+++ b/devel/wininfo/pkg-descr
@@ -0,0 +1,16 @@
+X Window Information is a window information utility for developers of
+applications, toolkits, and window managers. X Window Information
+follows your pointer providing information about the windows below.
+Information presented includes:
+
+ * A detailed description of the window hierarchy below the pointer.
+
+ * Parsed interpretations of standard properties from both the
+ application window and the window manager.
+
+ * Information about X server resources used by the application.
+
+WWW: http://www.freedesktop.org/Software/wininfo
+
+- Jean-Yves Lefort
+jylefort@brutele.be
diff --git a/devel/wininfo/pkg-plist b/devel/wininfo/pkg-plist
new file mode 100644
index 000000000000..d71987b3de2c
--- /dev/null
+++ b/devel/wininfo/pkg-plist
@@ -0,0 +1,2 @@
+bin/wininfo
+share/gnome/applications/xdg-wininfo.desktop