aboutsummaryrefslogtreecommitdiff
path: root/devel/winpdb
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2007-02-15 10:07:32 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2007-02-15 10:07:32 +0000
commite91ad7f1afc27918bd5c43f4ba80b174d1340b49 (patch)
treec598faa7cf72055814cacc9e93802e6752b2b59c /devel/winpdb
parentd8ac3054c687ab784142c8d19925ab7c76b0403e (diff)
Notes
Diffstat (limited to 'devel/winpdb')
-rw-r--r--devel/winpdb/Makefile29
-rw-r--r--devel/winpdb/distinfo3
-rw-r--r--devel/winpdb/pkg-descr5
-rw-r--r--devel/winpdb/pkg-plist8
4 files changed, 45 insertions, 0 deletions
diff --git a/devel/winpdb/Makefile b/devel/winpdb/Makefile
new file mode 100644
index 000000000000..68ea14678a90
--- /dev/null
+++ b/devel/winpdb/Makefile
@@ -0,0 +1,29 @@
+# ex:ts=8
+# Ports collection makefile for: winpdb
+# Date created: Feb 15, 2007
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= winpdb
+PORTVERSION= 1.0.8
+CATEGORIES= devel python
+MASTER_SITES= SF
+
+MAINTAINER= python@FreeBSD.org
+COMMENT= An advanced Python debugger
+
+RUN_DEPENDS= ${PYTHON_SITELIBDIR}/Crypto/__init__.py:${PORTSDIR}/security/py-pycrypto
+
+USE_PYTHON= yes
+USE_PYDISTUTILS= yes
+USE_WX= 2.6
+WX_COMPS= python
+
+post-install:
+.for file in rpdb2 winpdb
+ @${MV} -f ${PREFIX}/bin/_${file}.py ${PREFIX}/bin/${file}
+.endfor
+
+.include <bsd.port.mk>
diff --git a/devel/winpdb/distinfo b/devel/winpdb/distinfo
new file mode 100644
index 000000000000..47a72d448d06
--- /dev/null
+++ b/devel/winpdb/distinfo
@@ -0,0 +1,3 @@
+MD5 (winpdb-1.0.8.tar.gz) = f9e0a551e152e6c9dbfca0e59a684f43
+SHA256 (winpdb-1.0.8.tar.gz) = 27d4919483f1aafa606f344c44d41da4f3e83fbb007113899bbc498a8d2dc388
+SIZE (winpdb-1.0.8.tar.gz) = 81011
diff --git a/devel/winpdb/pkg-descr b/devel/winpdb/pkg-descr
new file mode 100644
index 000000000000..9c9e41186fd8
--- /dev/null
+++ b/devel/winpdb/pkg-descr
@@ -0,0 +1,5 @@
+Winpdb is a GPL python debugger, with support for smart breakpoints, multiple
+threads, namespace modification, embedded debugging, password encrypted
+communication and speed of up to 20 times that of pdb.
+
+WWW: http://winpdb.sourceforge.net/
diff --git a/devel/winpdb/pkg-plist b/devel/winpdb/pkg-plist
new file mode 100644
index 000000000000..966f276671f8
--- /dev/null
+++ b/devel/winpdb/pkg-plist
@@ -0,0 +1,8 @@
+bin/rpdb2
+bin/winpdb
+%%PYTHON_SITELIBDIR%%/rpdb2.py
+%%PYTHON_SITELIBDIR%%/rpdb2.pyc
+%%PYTHON_SITELIBDIR%%/rpdb2.pyo
+%%PYTHON_SITELIBDIR%%/winpdb.py
+%%PYTHON_SITELIBDIR%%/winpdb.pyc
+%%PYTHON_SITELIBDIR%%/winpdb.pyo