aboutsummaryrefslogtreecommitdiff
path: root/devel/xlslib/Makefile
diff options
context:
space:
mode:
authorEmanuel Haupt <ehaupt@FreeBSD.org>2005-12-13 13:39:47 +0000
committerEmanuel Haupt <ehaupt@FreeBSD.org>2005-12-13 13:39:47 +0000
commit4cafe7bc377f29157a8a54e7f2e8c1732c3aecc2 (patch)
tree9660267252b3429e908f21cfff9bd5bb36183513 /devel/xlslib/Makefile
parent20fa08eaa14964741b55ed6975ad4082d254448d (diff)
downloadports-4cafe7bc377f29157a8a54e7f2e8c1732c3aecc2.tar.gz
ports-4cafe7bc377f29157a8a54e7f2e8c1732c3aecc2.zip
Notes
Diffstat (limited to 'devel/xlslib/Makefile')
-rw-r--r--devel/xlslib/Makefile30
1 files changed, 30 insertions, 0 deletions
diff --git a/devel/xlslib/Makefile b/devel/xlslib/Makefile
new file mode 100644
index 000000000000..2f744b1f9b56
--- /dev/null
+++ b/devel/xlslib/Makefile
@@ -0,0 +1,30 @@
+# New ports collection makefile for: xlslib
+# Date created: 13 December 2005
+# Whom: Sergey Prikhodko<sergey@network-asp.biz>
+#
+# $FreeBSD$
+#
+
+PORTNAME= xlslib
+PORTVERSION= 0.2.1
+CATEGORIES= devel
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+
+MAINTAINER= sergey@network-asp.biz
+COMMENT= A C++ library for generation of Excel(TM) files
+
+GNU_CONFIGURE= yes
+INSTALLS_SHLIB= yes
+USE_REINPLACE= yes
+USE_GCC= 3.4+
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|^\(SUBDIRS.*src\).*|\1|' \
+ ${WRKSRC}/Makefile.in
+ @${REINPLACE_CMD} -e 's|^\(CXXFLAGS\).*|\1 = @CXXFLAGS@|' \
+ ${WRKSRC}/src/Makefile.in
+ @${REINPLACE_CMD} -e 's|\(.*class\)\ xlslib_core::\(range\)|\1 \2|' \
+ ${WRKSRC}/src/xlslib/common.h
+
+.include <bsd.port.mk>