aboutsummaryrefslogtreecommitdiff
path: root/devel/xxgdb
diff options
context:
space:
mode:
authorMichael Johnson <ahze@FreeBSD.org>2006-07-07 02:33:15 +0000
committerMichael Johnson <ahze@FreeBSD.org>2006-07-07 02:33:15 +0000
commitfc86b31b2071d6b77f832c1b5c888f1c973f1873 (patch)
tree06b4318b66d8cc9df2ac4c3c18f8a35fb209b891 /devel/xxgdb
parent4ad87006d23ceeee3af77aeeba5323692c6bc1da (diff)
downloadports-fc86b31b2071d6b77f832c1b5c888f1c973f1873.tar.gz
ports-fc86b31b2071d6b77f832c1b5c888f1c973f1873.zip
Notes
Diffstat (limited to 'devel/xxgdb')
-rw-r--r--devel/xxgdb/Makefile4
-rw-r--r--devel/xxgdb/files/patch-af13
2 files changed, 11 insertions, 6 deletions
diff --git a/devel/xxgdb/Makefile b/devel/xxgdb/Makefile
index 1acd19ee91a2..70ef76876db9 100644
--- a/devel/xxgdb/Makefile
+++ b/devel/xxgdb/Makefile
@@ -19,10 +19,6 @@ MAN1= xxgdb.1
.include <bsd.port.pre.mk>
-.if ${ARCH} == "sparc64"
-BROKEN= "Does not compile on sparc64"
-.endif
-
# This isn't included in the original Imakefile for some reason.
# Yes, I know this will recompile the program every time, but
# we have the cookie anyway and it's much easier this way
diff --git a/devel/xxgdb/files/patch-af b/devel/xxgdb/files/patch-af
index 52495e44629b..0c4491bdd747 100644
--- a/devel/xxgdb/files/patch-af
+++ b/devel/xxgdb/files/patch-af
@@ -1,5 +1,5 @@
---- regex.c.orig Thu Apr 20 01:58:00 1995
-+++ regex.c Fri Nov 17 21:37:49 2000
+--- regex.c.orig Wed Apr 19 12:58:00 1995
++++ regex.c Thu Jul 6 22:30:45 2006
@@ -114,7 +114,7 @@
* Date : July 27, 1990
*/
@@ -9,3 +9,12 @@
#include <malloc.h>
#endif
#include <string.h>
+@@ -123,7 +123,7 @@
+ #include <assert.h>
+
+ #ifdef sparc
+-#include <alloca.h>
++/* #include <alloca.h> */
+ #else
+ #pragma alloca
+ #endif