aboutsummaryrefslogtreecommitdiff
path: root/devel/xxl/Makefile
diff options
context:
space:
mode:
authorRong-En Fan <rafan@FreeBSD.org>2006-08-14 16:08:54 +0000
committerRong-En Fan <rafan@FreeBSD.org>2006-08-14 16:08:54 +0000
commit694d75e09f60be77f169092a4b325e8873622bbd (patch)
treeb62d1fbd65544a929b369d7046ac08b73773e674 /devel/xxl/Makefile
parente6fecfdbd2decfb779d36a5b638b2179fc3a6b98 (diff)
downloadports-694d75e09f60be77f169092a4b325e8873622bbd.tar.gz
ports-694d75e09f60be77f169092a4b325e8873622bbd.zip
Notes
Diffstat (limited to 'devel/xxl/Makefile')
-rw-r--r--devel/xxl/Makefile34
1 files changed, 24 insertions, 10 deletions
diff --git a/devel/xxl/Makefile b/devel/xxl/Makefile
index f6779f93d79f..fade1be3e211 100644
--- a/devel/xxl/Makefile
+++ b/devel/xxl/Makefile
@@ -5,17 +5,31 @@
# $FreeBSD$
#
-PORTNAME= xxl
-PORTVERSION= 1.0.1
-CATEGORIES= devel
-MASTER_SITES= http://www.zork.org/software/
+PORTNAME= xxl
+PORTVERSION= 1.0.1
+PORTREVISION= 1
+CATEGORIES= devel
+MASTER_SITES= http://www.zork.org/software/
-MAINTAINER= ports@FreeBSD.org
-COMMENT= C and C++ that provides exception handling and asset management
+MAINTAINER= ssedov@mbsd.msk.ru
+COMMENT= C/C++ library for exception handling and asset management
-GNU_CONFIGURE= yes
-CONFIGURE_ARGS+= --without-threads
-INSTALLS_SHLIB= yes
-CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
+GNU_CONFIGURE= yes
+USE_GNOME= gnometarget
+USE_LDCONFIG= yes
+
+.if defined(WITHOUT_THREADS)
+CONFIGURE_ARGS= --without-threads
+.endif
+
+.if !defined(NOPORTDOCS)
+PORTDOCS= xxl.pdf xxl.html
+.endif
+
+post-install:
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${PORTDOCS:S,^,${WRKSRC}/,} ${DOCSDIR}/
+.endif
.include <bsd.port.mk>