aboutsummaryrefslogtreecommitdiff
path: root/devel/z80asm
diff options
context:
space:
mode:
authorLars Engels <lme@FreeBSD.org>2007-12-31 21:30:16 +0000
committerLars Engels <lme@FreeBSD.org>2007-12-31 21:30:16 +0000
commit952adc552abadef8b88fea8880b6b8b54346adcf (patch)
treefecdcc898c64a279f20aeca0a3820a576123eca1 /devel/z80asm
parent9714dc657231d615a97e43ea88bb01d2f1856709 (diff)
downloadports-952adc552abadef8b88fea8880b6b8b54346adcf.tar.gz
ports-952adc552abadef8b88fea8880b6b8b54346adcf.zip
Notes
Diffstat (limited to 'devel/z80asm')
-rw-r--r--devel/z80asm/Makefile39
-rw-r--r--devel/z80asm/distinfo3
-rw-r--r--devel/z80asm/files/patch-Makefile15
-rw-r--r--devel/z80asm/pkg-descr19
-rw-r--r--devel/z80asm/pkg-plist10
5 files changed, 86 insertions, 0 deletions
diff --git a/devel/z80asm/Makefile b/devel/z80asm/Makefile
new file mode 100644
index 000000000000..3d3ada7a315f
--- /dev/null
+++ b/devel/z80asm/Makefile
@@ -0,0 +1,39 @@
+# New ports collection makefile for: z80asm
+# Date created: 29 Dec 2007
+# Whom: Sean McLaughlin <sigma.zx@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= z80asm
+PORTVERSION= 1.6
+CATEGORIES= devel
+MASTER_SITES= http://download.savannah.nongnu.org/releases/z80asm/
+
+MAINTAINER= sigma.zx@gmail.com
+COMMENT= Assembler for the Z80 microprcessor
+
+USE_GMAKE= yes
+MAN1= z80asm.1
+
+post-patch:
+ ${ECHO} ${PATCHDIR}
+ @${REINPLACE_CMD} -e 's#/bin/bash#/bin/sh#' ${WRKSRC}/Makefile
+
+do-install:
+ ${INSTALL_MAN} ${WRKSRC}/z80asm.1 ${PREFIX}/man/man1
+ ${INSTALL_PROGRAM} ${WRKSRC}/z80asm ${PREFIX}/bin
+
+.if !defined(NOEXAMPLES)
+ ${MKDIR} ${EXAMPLESDIR}
+ ${INSTALL_MAN} -m 444 ${WRKSRC}/examples/hello.asm ${EXAMPLESDIR}
+ ${INSTALL_MAN} -m 444 ${WRKSRC}/examples/macro.asm ${EXAMPLESDIR}
+ ${INSTALL_MAN} -m 444 ${WRKSRC}/examples/seek.asm ${EXAMPLESDIR}
+ ${INSTALL_MAN} -m 444 ${WRKSRC}/headers/msx-bios.asm ${EXAMPLESDIR}
+ ${INSTALL_MAN} -m 444 ${WRKSRC}/headers/msx2+-bios.asm ${EXAMPLESDIR}
+ ${INSTALL_MAN} -m 444 ${WRKSRC}/headers/msx2-bios.asm ${EXAMPLESDIR}
+ ${INSTALL_MAN} -m 444 ${WRKSRC}/headers/msx2-subrom.asm ${EXAMPLESDIR}
+ ${INSTALL_MAN} -m 444 ${WRKSRC}/headers/msxturbor-bios.asm ${EXAMPLESDIR}
+.endif
+
+.include <bsd.port.mk>
diff --git a/devel/z80asm/distinfo b/devel/z80asm/distinfo
new file mode 100644
index 000000000000..e27cb9f88a11
--- /dev/null
+++ b/devel/z80asm/distinfo
@@ -0,0 +1,3 @@
+MD5 (z80asm-1.6.tar.gz) = 9bfb5580c7ad14276c835afa74bf629b
+SHA256 (z80asm-1.6.tar.gz) = 9585830f5e2ec8d4c5d14cdf898ee46cafd9c6496575c73189be1e4ca04ac9b7
+SIZE (z80asm-1.6.tar.gz) = 57032
diff --git a/devel/z80asm/files/patch-Makefile b/devel/z80asm/files/patch-Makefile
new file mode 100644
index 000000000000..45c4807bfbb3
--- /dev/null
+++ b/devel/z80asm/files/patch-Makefile
@@ -0,0 +1,15 @@
+--- Makefile 2007-12-29 18:53:32.000000000 -0800
++++ Makefile-mod 2007-12-29 18:53:14.000000000 -0800
+@@ -16,9 +16,9 @@
+ # You should have received a copy of the GNU General Public License
+ # along with this program. If not, see <http://www.gnu.org/licenses/>.
+
+-CC = gcc
+-CFLAGS = -O0 -Wall -Wwrite-strings -Wcast-qual -Wcast-align -Wstrict-prototypes -Wmissing-prototypes -Wmissing-declarations -Wredundant-decls -Wnested-externs -Winline -pedantic -ansi -Wshadow -ggdb3 -W -Ignulib
+-SHELL = /bin/bash
++CC?= gcc
++CFLAGS+= -Wall -Wwrite-strings -Wcast-qual -Wcast-align -Wstrict-prototypes -Wmissing-prototypes -Wmissing-declarations -Wredundant-decls -Wnested-externs -Winline -pedantic -ansi -Wshadow -ggdb3 -W -Ignulib
++SHELL = /bin/sh
+ VERSION ?= $(shell echo -n `cat VERSION | cut -d. -f1`. ; echo $$[`cat VERSION | cut -d. -f2` + 1])
+
+ all:z80asm
diff --git a/devel/z80asm/pkg-descr b/devel/z80asm/pkg-descr
new file mode 100644
index 000000000000..f8f0d5d70f06
--- /dev/null
+++ b/devel/z80asm/pkg-descr
@@ -0,0 +1,19 @@
+z80asm is an assembler for the Z80 microprcessor. The assembler aims to be
+portable and complete. Of course it assembles all official mnemonics, but it
+also aims to assemble the unofficial mnemonics.
+
+The assembler features the output of listing files which show the source with
+the assembled codes and address next to it.
+
+It also allows outputting of label files, in a format which can be included by
+other assembler source files.
+
+Other noteworthy features are complete calculation capabilities, conditional
+assembling of parts of the code, and inclusion of other source files.
+
+The assembler was written with the MSX computer in mind as the target platform,
+but it can be used for any system with a Z80 in it. The original idea was to
+make header files with labels of MSX specific addresses (BIOS, BDOS, system
+variables), but nothing like this has been done yet.
+
+WWW: http://savannah.nongnu.org/projects/z80asm/
diff --git a/devel/z80asm/pkg-plist b/devel/z80asm/pkg-plist
new file mode 100644
index 000000000000..facfa14c7212
--- /dev/null
+++ b/devel/z80asm/pkg-plist
@@ -0,0 +1,10 @@
+bin/z80asm
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/hello.asm
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/macro.asm
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/msx-bios.asm
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/msx2+-bios.asm
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/msx2-bios.asm
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/msx2-subrom.asm
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/msxturbor-bios.asm
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/seek.asm
+%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%